Varning USB strömöverdrag

Tråden skapades och har fått 11 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Värnamo
  • 2014-04-09 19:17

Jag får ständiga pop-up varningar i stil med "eftersom en USB-enhet drog för mycket ström så har USB-enheterna avaktiverats" - trots att jag inte har någon anslutning alls till USB-port . Inte en gång utan 5-6 pop-ups inom bara några sekunder. Tar jag bort dem så så kommer direkt 5 nya. Och så håller det på hela tiden så jag aldrig hinner/kommer åt att använda datorn. Det här händer i såväl OS 10.5 och OS 10.6 (i OS 10.4 sker det bara en gång, när jag startar datorn, sen kommer det inte igen). Har prövat resetting av NVRAM/PRAM och SMC utan resultat

Sitter med en gammal värsting, MacBook Pro 1.2/2.16 GHz Intel Core Duo, 2 GB 667 Mhz.

Leif

  • Medlem
  • Karlskoga
  • 2014-04-09 20:10

Nu var det ju ingen fråga ställd, men jag antar att du vill veta vad du kan göra...
Eftersom det har varit så under tre olika OSX-versioner är det nog ett hårdvarufel. Vilket du skulle lämnat in den för direkt.
En chansning är ju att blåsa maskinen och installera ett helt rent OSX bara för att testa.
Har du inget alls installerat i någon USBport?

Edit: sitter inte CDspelaren ansluten på USB på den maskinen? Funkar den?

  • Skribent
  • Sollentuna
  • 2014-04-09 20:16

Nåt skräp i USB-porten som kortsluter strömpinnarna?

  • Medlem
  • Värnamo
  • 2014-04-09 20:45

Jag är inte helt korkad.. Har givetvis först prövat med att ha OS 10.6 och "blåst" systemet liksom med OS 10.5 och "blåst" systemet, för att sedan prövat OS 10.4 (och först där fåtts det acceptabelt). Kan inte lämna in den eftersom det skulle kosta för mycket att investera i denna gamla maskin. Och som jag sa. Inget är installerat i någon USB-port. CD-spelaren fungerar och är separat från USB.
Det verkar som att alla program fungerar klanderfritt ända upp till OS 10.6.8 (utom just dessa USB-meddelanden som omöjliggör att använda maskinen på ett rationellt sätt). Apple säger också att alla Intel-maskiner ska fungera på OS 10.6.

Det enda som har hänt är att det uppladdningsbara batteriet har svällt upp och det behövs ett nytt (borttaget under testerna). Har svårt att tänka mig att det kan ha påverkat maskinvaran eftersom OS 10.4.11 fungerar utan mer än "en" USB-varning.

  • Medlem
  • Värnamo
  • 2014-04-09 20:51

Vad kan det finnas för "skräp" i USB-portarna som kortsluter strömpinnarna. Är det i så fall något man kan åtgärda själv.Som sagt att lämna in en sådan gammal maskin + att köpa ett nytt uppladdningsbart batteri tycks lite för dyrt. Då blir alternativet snarast att kasta maskinen och köpa en bättre begagnad och lite nyare bärbar.

Ursprungligen av 666666:

Jag är inte helt korkad...

Det är ingen som har påstått att du är korkad. Men eftersom du inte berättade om att du hade provat det, så var det helt naturligt att tipsa om en total ominstallation.

Man måste redan från början berätta allt man har provat, så slipper man få tips om de sakerna, och slipper då bli irriterad på de tipsen.

Senast redigerat 2014-04-09 22:46
Ursprungligen av 666666:

Vad kan det finnas för "skräp" i USB-portarna som kortsluter strömpinnarna...

Svårt att säga. Det kan ju vara nästan vad som helst som har råkat komma in där.

Ursprungligen av 666666:

...Är det i så fall något man kan åtgärda själv...

Ja, kanske. Du kan ju börja med att titta i USB-portarna om du kan se något där.

Ursprungligen av Ola:

Struliga USB-portar kan i vissa lägen avhjälpas med en SMC-reset:
http://support.apple.com/kb/ht3964

Har du läst första inlägget?

"Har prövat resetting av NVRAM/PRAM och SMC utan resultat"

Ursprungligen av 666666:

…Det enda som har hänt är att det uppladdningsbara batteriet har svällt upp och det behövs ett nytt (borttaget under testerna)…

Där har du antagligen skälet till problemet med USB-portarna. Något kan ha blivit klämt och skadat.

  • Medlem
  • Göteborg
  • 2014-04-09 23:41

Antagligen är det en kortslutning någonstans. Börja med luft på burk i usb-portarna.

Om du inte kan hitta och åtgärda kortslutningen så kanske du kan koppla bort usb-funktionen helt genom att ta bort dess usb-drivrutiner och använda datorn hjälpligt ändå? Pröva till exempel med att ta bort System/Library/Extentions/IOUSBFamily.kext. Men om det lyckas så kommer troligtvis tangentbord och stryplatta sluta fungera (liksom alla externa tangentbord och möss) så du kan bara använda datorn via VNC eller annan fjärrstyrning.

En bättre approach är att hitta och isolera felet, om du gillar att skruva. Felsök genom att koppla ur usb-portar fysiskt.

1) Ett uppsvällt batteri kan ha tryckt på anslutningen till tangentbordet och skadat den. Du kan testa att koppla bort tangentbordskabeln från moderkortet. Om det löser problemet går ju datorn att använda med externt tangentbord.
MacBook Pro 17" Models A1151 A1212 A1229 and A1261 Keyboard Replacement

2) De två vänstra usb-portarna sitter på ett separat dotterkort. Lokalisera kabeln som kopplar det till moderkortet. Troligtvis förlorar du ljud in/ut också då. Ström och högtalarkabel som också sitter på det kortet låter du vara kvar, du stannar alltså vid steg 11 i denna beskrivning:
MacBook Pro 17" Models A1151 A1212 A1229 and A1261 Left I/O Board Cable Replacement

3) Den sista usb-porten på höger sida är lödd direkt på moderkortet, så det är svårare. Men som sista utväg, pröva att löda av det.

  • Medlem
  • Värnamo
  • 2014-04-10 08:36

Sorry. Tog det som självklart att man måste blåsa varje systemversion när man testar. Ska bättra mig.
Felskicken/dubbelskicken beror på ovana med forumets gränssnitt för var man ska svara.

Leif

  • Medlem
  • Värnamo
  • 2014-04-10 08:39

Tack Jesper, Reboot81 och IngoX. Ska kolla över era förslag till helgen

Leif

1
Bevaka tråden