Framåt/bakåt-bugg i Safari? Mavericks

Tråden skapades och har fått 19 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • 2013-10-25 09:27

Är det fler som upplever en stor bugg med Safari i Mavericks?
Jag kan sällan använda framåt/bakåt i Safari. Klickar jag på en länk på tex DN eller motsvarande för att läsa en artikel så kan jag aldrig svepa åt höger för att gå tillbaka när artikeln är färdigläst. Jag måste stänga ner den flik där sidan finns och sedan öppna den igen.
Hade detta hänt en eller två gånger på en dag hade väl inte det varit hela världen, men nu händer det ju nästan varje gång!
Fler som stött på detta?

#mavericks

Senast redigerat 2013-10-25 11:19

Jag har själv haft ett stort problem med Safari efter Mavericks. Det har varit omöjligt att avsluta Safari om fler än en tab har varit öppen. Det har hängt sig och force quit har varit enda lösningen. Det har dock startat normalt efter det och alla tabs har varit intakta.

Ditt problem kan ha att göra med gestures för mus och/eller trackpad i system preferences att göra. Jag läste om någon som upptäckte att någon eller några checkboxes var urkryssade efter Mavericks installation. Kolla det först.

Om det inte funkar, gör som jag:
Avinstallera Adobe Air
Avinstallera Adobe Flash
Rensa bort alla gamla mappar som har med Macromedia och Flash att göra
Avinstallera MS Silverlight
Avinstallera alla Safari extensions
Rensa/avinstallera onödiga Internet Plug-ins som ligger i Library för system och användarmapp.
Avinstallera Google Chrome
Rensa googles mappar och plist-filer för keystone och annat gammalt bråte
Rensa en massa plist-filer i olika safari-mappar (backuppa bokmärkena först)

Efter det har jag återinstallerat 1password extension och Flash.

Nu verkar det rulla som det ska. Jag kan inte med säkerhet avgöra vilket som var lösningen men jag tror det var rensningen av Safaris plist-filer som gjorde susen.

  • Medlem
  • International user
  • 2013-10-25 17:11

Allt det där lät jobbigt, det räckte med att rensa safari's cash och starta om för mig. Så försvann den buggen

Ursprungligen av panther:

Allt det där lät jobbigt, det räckte med att rensa safari's cash och starta om för mig. Så försvann den buggen

Haha, trust me. Jag resetade och rensade webbhistorik, cache och cookies über alles, omstarter, trix och fix innan jag fick gå på djupet.

  • Medlem
  • International user
  • 2013-10-25 17:19
Ursprungligen av stormstereo:

Haha, trust me. Jag resetade och rensade webbhistorik, cache och cookies über alles, omstarter, trix och fix innan jag fick gå på djupet.

Stackars dig

  • Medlem
  • 2013-10-26 12:53

Är det verkligen ingen annan som upplever detta? Även om man inte upplever det kan man få posta ett "nej" i tråden. För då kan man ju utreda om jag är helt ensam om detta problem. Och då kanske en ominstallation kan lösa problemet.

  • Medlem
  • Örnsköldsvik
  • 2013-10-26 14:36

Nej, jag har inte det problemet, men ska man inte kunna gå tillbaks från en sida till föregående och sedan framåt igen genom att svepa med två fingrar från höger till vänster?

Vänster -> höger = bakåt
Höger -> vänster <> framåt ?

Ett irriterande sak jag såg i Safari när man swipade tillbaks, det blir ett litet stopp där man inget kan göra, troligen uppdateras sidan man går tillbaks till.
Detta stopp ser jag inte i Firefox, så back to Firefox igen.

  • Medlem
  • 2013-10-26 15:34

Det är svepet jag frågar om. Hela den öppna fliken i safari hänger sig om jag sveper.

  • Medlem
  • Örnsköldsvik
  • 2013-10-26 16:00

Jag har inte sett sådana hängningar som du beskriver, bara de mindre stoppen vid återgång, fast de är nog så irriterande..

En annan svep-relaterad sak, kan man inte svepa bland öppna flikar (som i Firefox)?
Jag har alltid många flikar öppna, och en svepning (+ ett klick på fliken) uppe vid flikarnas överdel är ett enkelt sätt att hoppa mellan flikar.

  • Avstängd
  • Bangkok Thailand
  • 2013-10-26 16:29

Inga problem med svep framåt eller bakåt.
Inget stopp för att uppdatera sidan heller.

  • Medlem
  • Karlskoga
  • 2013-10-26 18:28

Jag har också ett kort stopp innan uppdatering av sidan. Senaste Mac mini med DVDläsare, uppdaterat Mavericks från 10.8.5 (ej nyinstallerat).

  • Medlem
  • Södertälje
  • 2013-10-26 21:38

Jag har varit tvungen att klicka i "Sweep between pages" (vet inte vad det heter om man har det på svenska) igen på bägge mina Mac:ar efter uppgraderingen.

Har inte haft några problem med hängningar i Safari.

  • Medlem
  • 2013-10-26 22:03
Ursprungligen av jbygden:

Jag har varit tvungen att klicka i "Sweep between pages" (vet inte vad det heter om man har det på svenska) igen på bägge mina Mac:ar efter uppgraderingen.

Det var också min första tanke, att den av någon konstig anledning hade blivit avbockad. Men så var inte fallet.

  • Medlem
  • Örnsköldsvik
  • 2013-10-26 22:24

Hittade detta om flikar som fryser: https://discussions.apple.com/thread/5467320?tstart=0

En PRAM reset alltså..

Hmm, såg just att swipe fungerar både framåt och bakåt nu.
Kanske det är en bug som tillkommit i Mavericks..

Ursprungligen av panther:

Stackars dig

Och så har det hänt igen. Safari men även Aperture vägrar ibland att avsluta. Force quit som gäller. Nu såg jag i Activity Monitor att processen iCloud Photos var röd med tillägget "(not responding)". Jag kunde heller inte gå in på iCloud-inställningarna i system preferences. Force quit av den också. Omstart fixade det. Får se hur länge det håller. Vet inte om Safari har så mycket att göra med iCloud. Så - även om mitt problem eventuellt har med iCloud att göra så låter det ändå ganska orimligt att ditt swipe-problem härör därifrån.

Ursprungligen av stormstereo:

Och så har det hänt igen. Safari men även Aperture vägrar ibland att avsluta. Force quit som gäller. Nu såg jag i Activity Monitor att processen iCloud Photos var röd med tillägget "(not responding)". Jag kunde heller inte gå in på iCloud-inställningarna i system preferences. Force quit av den också. Omstart fixade det. Får se hur länge det håller. Vet inte om Safari har så mycket att göra med iCloud. Så - även om mitt problem eventuellt har med iCloud att göra så låter det ändå ganska orimligt att ditt swipe-problem härör därifrån.

Här kommer jag och våldgästar igen.
Jag tror att jag har hittat lösningen på mitt problem med att Safari (och Aperture, iCloud settings, Calendar) hängde sig. Det hela verkar ha hängt samman med processen kallad "iCloud Photos" som lyste illrött i Activity Monitor tidigare. Innan jag uppdaterade till Mavericks hade jag ett gäng delade fotoströmmar i Aperture. Jag bestämde mig för att radera dessa samt att stänga av allting som har med fotoströmmar att göra i Aperture, iCloud settings på iMac:en samt på iPad och iPhone. Efter en reboot av alla enheter slog jag igång tjänsten igen och började med iMac:en. Efter det har jag ännu inte haft en enda hängning. *ta i trä*

Det verkar alltså som att uppdateringen till Mavericks sabbade min iCloud Photos-funktion och att det behövdes en reset av densamma. Håll tummarna nu.

Nu fick jag exakt samma problem! Fast mitt började med magic trackpaden som inte anslöt efter sovläge eller omstart. Nu får jag inte magic trackpaden att fungera alls, omstart hjälper ej. Kopplade bort min Macbook (Air, 2011) från extern skärm och märkte att safari också börjat krångla, det hänger sig när man sveper för att gå bakåt och måste startas om för att börja funka (på den inbyggda track paden). Testade Firefox, nu kan jag inte scrolla varken i safari eller FF. Allt detta med en ren installation av Mavericks. Har funkat klockrent sedan Mavericks släppet tills nu, fattar inte. Får trixa runt lite.

Känner igen detta. Jag rensade cache och startade om datorn, och allt funkar bra nu.

Efter mycket om och men var det batterierna som inte var hundra även om jag bytte men tydligen var inte de hundra de heller! Väldigt förvirrande! Alla scrollnings problem och annat konstigt i safari avhjälptes genom att rensa cache och starta om, som för de flesta i denna tråden.

  • Medlem
  • International user
  • 2013-12-10 18:07

Med den nya iMacen som kom igår, har jag inte känt antydningen ens till att det ska hända.
Fick en känsla precis varje gång när det skulle hända på den gamla iMacen. När det blev lite segare i svepningarna.
Kom lite sporadisk även efter jag trodde det var fixat med cachen 1:a gången, men det gick ju bra att fortsätta göra det.
Undrar om det har med minne att göra, tänkte jag nu?
Det blev ofta inte mycket kvar på gamla iMacen, och särskilt inte när man hade haft igång Safari ett tag.
Nu finns det gott om det.
Ska rapportera in om det uppträder på denna nya speedade och icke-senila saken

1
Bevaka tråden