Ljudproblem via airplay med MBA 2013

Tråden skapades och har fått 19 svar. Det senaste inlägget skrevs .
1

Hej!

Har köpt en ny Macbook Air 2013 och har problem med airplay. När jag väljer att köra ljudet till min Apple TV så sprakar och hackar ljudet något fruktansvärt. Detta sker inte på andra enheter utan bara när jag kör min nya MBA -> ATV. Har provat att byta till andra kanaler i min router för att inte ligga på samma som grannarna, dock inget resultat (På både 2,5 och 5 GHz) . Vad kan felet vara? Fattar ingeting. . . hjälp!

Spelar du upp ljudet från iTunes?

Vilka enheter är det som det fungerar med?

Ursprungligen av barbapappa_86:

Spelar du upp ljudet från iTunes?

Vilka enheter är det som det fungerar med?

Spelar inte någon roll om det är VLC, iTunes eller spotify.

Fungerar med iPad och iPhone vad jag vet. Kan försöka prova med en annan dator också senare. . .

EDIT: Fungerar även med en annan dator (OS X 10.7.5)

Det blir lite bättre om jag speglar både bild och ljud, men inte helt bra. Kör jag bara ljud låter det som när man spelar på en sprängd högtalare typ, samt hack. Vad ska man göra?

Kan det vara Airport Extreme som inte lirar med datorn? Hur kan jag installera tidigare firmware? (Sitter på 7.6.4 nu)

Senast redigerat 2013-10-16 22:51
  • Medlem
  • Karlskoga
  • 2013-10-17 21:20

Kör du trådlöst? I så fall, någon skillnad med kabel?

Ursprungligen av kenjon:

Kör du trådlöst? I så fall, någon skillnad med kabel?

Eftersom jag har en Macbook Air kan jag inte köra trådat (Har ingen adapter)

  • Medlem
  • Borås
  • 2013-10-17 21:33

Hur fungerar det om du kör med Airfoil? Det finns en gratis demo på http://www.rogueamoeba.com/airfoil/mac/

Ursprungligen av Ola:

Hur fungerar det om du kör med Airfoil? Det finns en gratis demo på http://www.rogueamoeba.com/airfoil/mac/

Airfoil fungerar . . . vilket betyder att mjukvaran som apple tillhandahåller suger? Det enda jag kan göra är att vänta på uppdatering?

  • Medlem
  • Borås
  • 2013-10-17 22:10

Eller köp Airfoil, det är inte dyrt. Det har fler funktioner än Apples inbyggda lösning. Jag har kört det i flera år mot flera ATV:s och rena Airplay mottagare och det fungerar grymt bra. Det bästa är att man kan välja vilket programs ljud som skall skickas ut, mao kan jag spela Spotify på flera ställen i huset samtidigt som jag gör annat på datorn utan att det ljudet stör.

Ursprungligen av Ola:

Eller köp Airfoil, det är inte dyrt. Det har fler funktioner än Apples inbyggda lösning. Jag har kört det i flera år mot flera ATV:s och rena Airplay mottagare och det fungerar grymt bra. Det bästa är att man kan välja vilket programs ljud som skall skickas ut, mao kan jag spela Spotify på flera ställen i huset samtidigt som jag gör annat på datorn utan att det ljudet stör.

Det känns inte rimligt att behöva köpa program från andra tillverkare för att få apples egna produkter att lira tillsammans.

Börjar seriöst att tröttna på apple och deras produkter på senaste tiden, känns som det går utför. . . men det är väl bara att bita i det "sura äpplet"

  • Medlem
  • Borås
  • 2013-10-17 22:25

Jag håller med om att din setup borde fungera, jag har en Air 2011 med 10.8.5 och det fungerar över en Airport Extreme med Apples inbyggda lösning. Felsök vidare så löser det sig säkert.

Lång shot men har du samma problem med en annan användare?

Tack för all hjälp i alla fall! Få se hur det utvecklar sig i framtiden, ska prova med mavericks först få se vad som händer. Ska även prova min dator hemma hos någon annan som kör AE samt ATV.

  • Medlem
  • 2013-10-18 00:16

Jag har en MBA 2013. Kan streama musik till Express, ATV samt en Denon-receiver med Airplay utan problem. Klen tröst i sammanhanget, men ditt problem beror nog snarare på mjukvara än hårdvara.

  • Medlem
  • Sollentuna
  • 2013-10-18 09:53
Ursprungligen av SirBergman123:

Hej!

Har köpt en ny Macbook Air 2013 och har problem med airplay. När jag väljer att köra ljudet till min Apple TV så sprakar och hackar ljudet något fruktansvärt. Detta sker inte på andra enheter utan bara när jag kör min nya MBA -> ATV. Har provat att byta till andra kanaler i min router för att inte ligga på samma som grannarna, dock inget resultat (På både 2,5 och 5 GHz) . Vad kan felet vara? Fattar ingeting. . . hjälp!

Du beskriver två olika problem i samma felbild:

  • sprakar tyder på att ljudet är överstyrt. Det har du alltid (ja, så länge som jag minns) kunnat göra med VLC om du drar ljudregeln på max. Självklart tänker du rätt i att du vill ha så hög nivå på ljudet ut för att inte förstärka brus. Men VLC klarar också av att, på något sätt, generera för hög nivå ut så att det sprakar (aka distar!) i högtalarna.

  • hackar tyder på att du tappar paket i överföringen. Nu är det väl som så att Airplay buffrar (för jag har en flera sekunders fördröjning mellan MacBook Air och ljudet i AppleTV. Dock inte via iPhone... Underligt) och då tyder det på allvarliga problem med nätverket eller i allafall applikationens förmåga att få över trafik till din AppleTV.

Det första problemet kan vi kan enklare lösa än den senare. Vad tror du?

Ursprungligen av frazze:

Du beskriver två olika problem i samma felbild:

  • sprakar tyder på att ljudet är överstyrt. Det har du alltid (ja, så länge som jag minns) kunnat göra med VLC om du drar ljudregeln på max. Självklart tänker du rätt i att du vill ha så hög nivå på ljudet ut för att inte förstärka brus. Men VLC klarar också av att, på något sätt, generera för hög nivå ut så att det sprakar (aka distar!) i högtalarna.

  • hackar tyder på att du tappar paket i överföringen. Nu är det väl som så att Airplay buffrar (för jag har en flera sekunders fördröjning mellan MacBook Air och ljudet i AppleTV. Dock inte via iPhone... Underligt) och då tyder det på allvarliga problem med nätverket eller i allafall applikationens förmåga att få över trafik till din AppleTV.

Det första problemet kan vi kan enklare lösa än den senare. Vad tror du?

Signalen är inte överstyrd, det var det första jag undersökte.

Det verkar snarare som paketförlust. Små paketförluster uppfattas som brus/dist och större uppfattas som hack? Saken är ju som sagt att det fungerar med 3 andra (olika typer) enheter i samma nätverk. Bara överföring av ljud är riktigt uselt, dock bättre med ljud och bild, men inte bra. Hur kan jag felsöka detta? Pingade ATV från min Macbook Air också. . . .

Hur går jag vidare?

PING XX.X.X.X (XX.X.X.X): 56 data bytes
64 bytes from XX.X.X.X: icmp_seq=0 ttl=64 time=87.772 ms
64 bytes from XX.X.X.X: icmp_seq=1 ttl=64 time=8.398 ms
64 bytes from XX.X.X.X: icmp_seq=2 ttl=64 time=235.704 ms
64 bytes from XX.X.X.X: icmp_seq=3 ttl=64 time=156.273 ms
64 bytes from XX.X.X.X: icmp_seq=4 ttl=64 time=78.348 ms
64 bytes from XX.X.X.X: icmp_seq=5 ttl=64 time=9.955 ms
64 bytes from XX.X.X.X: icmp_seq=6 ttl=64 time=4.268 ms
64 bytes from XX.X.X.X: icmp_seq=7 ttl=64 time=142.446 ms
64 bytes from XX.X.X.X: icmp_seq=8 ttl=64 time=63.011 ms
64 bytes from XX.X.X.X: icmp_seq=9 ttl=64 time=7.037 ms

--- XX.X.X.X ping statistics ---
10 packets transmitted, 10 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 4.268/79.321/235.704/74.431 ms

EDIT: Har nu provat version 7.6, 7.6.1, 7.6.3, 7.6.4 i Airport Extreme dock ingen skillnad.

Senast redigerat 2013-10-18 11:29
  • Medlem
  • Karlskoga
  • 2013-10-18 11:49

Din ping ser inget vidare ut. Störningar från andra nät, dålig signalstyrka? Flytta APn till anföra rum? Några "smarta-hem"-styrningar? De sänder ut rätt mycket, speciellt de som kör på elnätet (typ homeplug).

Ursprungligen av kenjon:

Din ping ser inget vidare ut. Störningar från andra nät, dålig signalstyrka? Flytta APn till anföra rum? Några "smarta-hem"-styrningar? De sänder ut rätt mycket, speciellt de som kör på elnätet (typ homeplug).

Har fimpat "smarta hem" prylar. Sitter en meter från router som är en meter från ATV. Har bytt till "fria" kanaler. 5GHz.

PING XX.X.X:X (XX.X.X:X): 56 data bytes
64 bytes from XX.X.X:X: icmp_seq=0 ttl=64 time=59.514 ms
64 bytes from XX.X.X:X: icmp_seq=1 ttl=64 time=23.392 ms
64 bytes from XX.X.X:X: icmp_seq=2 ttl=64 time=40.566 ms
64 bytes from XX.X.X:X: icmp_seq=3 ttl=64 time=59.006 ms
64 bytes from XX.X.X:X: icmp_seq=4 ttl=64 time=50.623 ms
64 bytes from XX.X.X:X: icmp_seq=5 ttl=64 time=96.391 ms
64 bytes from XX.X.X:X: icmp_seq=6 ttl=64 time=117.557 ms
64 bytes from XX.X.X:X: icmp_seq=7 ttl=64 time=117.000 ms
64 bytes from XX.X.X:X: icmp_seq=8 ttl=64 time=40.396 ms
64 bytes from XX.X.X:X: icmp_seq=9 ttl=64 time=174.409 ms
64 bytes from XX.X.X:X: icmp_seq=10 ttl=64 time=188.322 ms
64 bytes from XX.X.X:X: icmp_seq=11 ttl=64 time=108.877 ms
64 bytes from XX.X.X:X: icmp_seq=12 ttl=64 time=27.907 ms
64 bytes from XX.X.X:X: icmp_seq=13 ttl=64 time=6.027 ms
64 bytes from XX.X.X:X: icmp_seq=14 ttl=64 time=175.956 ms
64 bytes from XX.X.X:X: icmp_seq=15 ttl=64 time=97.088 ms
64 bytes from XX.X.X:X: icmp_seq=16 ttl=64 time=18.163 ms
64 bytes from XX.X.X:X: icmp_seq=17 ttl=64 time=244.731 ms
64 bytes from XX.X.X:X: icmp_seq=18 ttl=64 time=165.746 ms
64 bytes from XX.X.X:X: icmp_seq=19 ttl=64 time=72.985 ms

--- XX.X.X:X ping statistics ---
20 packets transmitted, 20 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 6.027/94.233/244.731/65.029 ms

Överföringen av ljud fungerar klockrent från itunes med Mavericks. MEN jag kan inte längre välja att strömma ljudet till Apple TV, vad är problemet? Det går alltså inte att välja Apple TV som enhet för ljud ut.

Nu fungerar det med överföring av ljud, men bara genom itunes. Uppspelning med andra program gör att det skramlar och poppar! Jag blir så trött på apple . . .

Hej, jag har samma problem med Mavericks och Apple tv 3 när jag streamar bara ljud via OSX på min MBP Retina hösten 2013. Ljudet hackar otroligt mycket så att det knappt går att lyssna. Jag har inte kopplat in hdmi i min Apple tv utan enbart ljudet via den optiska utgången.

Jag testade precis Airfoil och det funkar hur bra som helst. Trist att behöva köpa ett tredjepartsprogram men det är en workaround åtminstone.

1
Bevaka tråden