time machine förbättra tillförlitligheten - skapar nya "backuper".

Tråden skapades och har fått 13 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • 2013-09-28 15:21

av någon anledning har jag börjat få meddelande ganska ofta om att time machine har slutfört kontrollen av min backup och vill skapa ny för att förbättra tillförlitligheten på den.

någon som vet varför det blir så här och vad jag kan göra för att förbättra/fixa så det inte blir så fortsättningsvis?

  • Medlem
  • Stockholm
  • 2013-09-28 19:21

Går TM till en USB-disk, en Time Capsule eller till något hemmasnickrat?

  • Medlem
  • 2013-09-28 19:28
Ursprungligen av pesc:

Går TM till en USB-disk, en Time Capsule eller till något hemmasnickrat?

Förlåt, hade så bråttom så glömde det viktigaste.

Den går till min nas. (Synology)

  • Avstängd
  • Bangkok Thailand
  • 2013-09-28 22:23

Jag hade samma problem till min NAS fast det var en Netgear.
När jag bytte till Synology har jag inte upplevt samma problem.
Men jag bytte router samtidigt till en AirPort extreme om det spelade någon roll vet jag inte.

  • Medlem
  • 2013-09-29 05:03
Ursprungligen av lappen71:

Jag hade samma problem till min NAS fast det var en Netgear.
När jag bytte till Synology har jag inte upplevt samma problem.
Men jag bytte router samtidigt till en AirPort extreme om det spelade någon roll vet jag inte.

ok, sitter med airport extreme jag också.

en tanke jag fick var att det kanske kan vara diskarna/disken som börjar bli trasiga sektorer på och då gör att time machine känner av det och vill skapa ny backup, kan det vara så?

men å andra sidan så säger inte synology dsm något om att diskarna skulle vara trasiga. står att de är ok i menyn till höger och kör jag s.m.a.r.t-testet så står det även där att de är ok.

  • Avstängd
  • Bangkok Thailand
  • 2013-09-29 07:53
Ursprungligen av mjewl:

ok, sitter med airport extreme jag också.

en tanke jag fick var att det kanske kan vara diskarna/disken som börjar bli trasiga sektorer på och då gör att time machine känner av det och vill skapa ny backup, kan det vara så?

men å andra sidan så säger inte synology dsm något om att diskarna skulle vara trasiga. står att de är ok i menyn till höger och kör jag s.m.a.r.t-testet så står det även där att de är ok.

Det trodde jag med men s.m.a.r.t har aldrig gett mig några felmeddelnden.
Vid byte av router så placerades den på ett bättre ställe för bättre mottagning om det kan spela någon roll.
Min teori är att om det är svajig signalstyrka på wi-fi kan det uppstå men det som sagt enbart en gissning.

  • Medlem
  • Stockholm
  • 2013-09-29 09:22

Kolla logfilerna om du ser några varningar.

Öppna programmet systemmeddelanden och filtrera på backupd. Ser du något skumt? Feltexter eller varningar?

Time Machine mot en NAS är mer komplext än vad man först kan tro eftersom TM bygger på att målenheten är formaterad i HFS+. Detta kan uppnås genom att använda en sparse bundle. Man blir då känslig för avbrott i förbindelsen med NASen. Detta pareras genom att man använder AFP och en del speciella kommandon i detta protokoll för att säkerställa integriteten.

Många problem kan undvikas om man har en bra nätverksförbindelse och är noga med att avmontera enheter innan datorn stängs av eller man går iväg med sin laptop.

Mer info finns här:
http://support.apple.com/kb/PH11171

Vad tillverkaren av NAS måste klara av står här. Gör din NAS det?
https://developer.apple.com/library/mac/docum...

Senast redigerat 2013-09-29 09:36
  • Medlem
  • 2013-09-29 11:01
Ursprungligen av pesc:

Kolla logfilerna om du ser några varningar.

Öppna programmet systemmeddelanden och filtrera på backupd. Ser du något skumt? Feltexter eller varningar?

Time Machine mot en NAS är mer komplext än vad man först kan tro eftersom TM bygger på att målenheten är formaterad i HFS+. Detta kan uppnås genom att använda en sparse bundle. Man blir då känslig för avbrott i förbindelsen med NASen. Detta pareras genom att man använder AFP och en del speciella kommandon i detta protokoll för att säkerställa integriteten.

Många problem kan undvikas om man har en bra nätverksförbindelse och är noga med att avmontera enheter innan datorn stängs av eller man går iväg med sin laptop.

Mer info finns här:
http://support.apple.com/kb/PH11171

Vad tillverkaren av NAS måste klara av står här. Gör din NAS det?
https://developer.apple.com/library/mac/docum...

kom på ytterligare en sak jag glömt nämna.. (shame on me)

kör även TM från min mac mini (trådad) och där får jag aldrig detta fel.
så kanske är som @lappen71 säger, att det har med wifi att göra. (eftersom det bara uppstår på min macbook pro med wifi)

har ingen aning om min NAS stödjer allt det där. har en synology ds413j. men det finns en funktion i DSM att aktivera time machine där man aktiverar mac fil-service (AFP). och eftersom det fungerar felfritt (än så länge) från min mac mini så förmodar jag att den stödjer allt det som stod på sidan du länka.

kollade loggen och hittade detta felet:

2013-09-28 15:16:40,136 com.apple.backupd[1250]: Starting automatic backup
2013-09-28 15:16:40,235 com.apple.backupd[1250]: Attempting to mount network destination URL: afp://admin@m-nas.local/Time%20Machine
2013-09-28 15:16:40,964 com.apple.backupd[1250]: Mounted network destination at mount point: /Volumes/Time Machine using URL: afp://admin@m-nas.local/Time%20Machine
2013-09-28 15:17:47,677 com.apple.backupd[1250]: Runtime corruption detected on /Volumes/Time Machine/m-macbook.sparsebundle (fsck_hfs -q termination status: 3)
2013-09-28 15:17:47,959 com.apple.backupd[1250]: Network destination already mounted at: /Volumes/Time Machine
2013-09-28 15:18:27,452 com.apple.backupd[1250]: Recovery backup declined by user.
2013-09-28 15:18:27,679 com.apple.backupd[1250]: Backup canceled.

Jag har också haft dessa problem på de bärbara. Var 2-3 månad har man fått börja om på nytt med backupen. Min iMac och Mini har funkat bra. Jag har löst det genom att i Time Machines inställningar på de bärbara stänga av automatiska backuper och istället alltid dra igång manuellt ('Säkerhetskopiera nu' från menyraden) och då alltid se till att backupen får gå klart innan jag stänger locket och låter maskinen vila.

Jag tror att problemen kan bero på att man kanske avbryter backupen vid känsliga ögonblick när man har automatiken igång och obetänksamt slänger igen locket och stänger ner datorn utan att backuppen får gå klart.

Efter att jag börjat köra manuellt så har jag inte längre haft några problem.

Jag använder Netatalk 2.2.1 på en Fedora 15 Linux-PC som min Time Machine-server. Det är förmodligen också Netatalk som används till Time Machine i din Synology-NAS.

  • Medlem
  • 2013-09-29 19:31
Ursprungligen av Sir N.:

Jag har också haft dessa problem på de bärbara. Var 2-3 månad har man fått börja om på nytt med backupen. Min iMac och Mini har funkat bra. Jag har löst det genom att i Time Machines inställningar på de bärbara stänga av automatiska backuper och istället alltid dra igång manuellt ('Säkerhetskopiera nu' från menyraden) och då alltid se till att backupen får gå klart innan jag stänger locket och låter maskinen vila.

Jag tror att problemen kan bero på att man kanske avbryter backupen vid känsliga ögonblick när man har automatiken igång och obetänksamt slänger igen locket och stänger ner datorn utan att backuppen får gå klart.

Efter att jag börjat köra manuellt så har jag inte längre haft några problem.

Jag använder Netatalk 2.2.1 på en Fedora 15 Linux-PC som min Time Machine-server. Det är förmodligen också Netatalk som används till Time Machine i din Synology-NAS.

ok, det är dock mycket märkligt att jag inte upplevde dessa problem tidigare på samma dator men då med usb-disk i airport extreme istället för nas.

kanske hade tur med lock-stängningarna då.

får väl helt enkelt vara mer noga och se om det är någon backup som körs innan jag stänger locket.

Ursprungligen av mjewl:

ok, det är dock mycket märkligt att jag inte upplevde dessa problem tidigare på samma dator men då med usb-disk i airport extreme istället för nas.

kanske hade tur med lock-stängningarna då.

får väl helt enkelt vara mer noga och se om det är någon backup som körs innan jag stänger locket.

Kan ju vara nån bugg i Netatalk eftersom du säger att det gick bra när du körde Apples Airport Extreme. Den version jag kör är ju rätt gammal. Netatalk är ju uppe på version 3.nånting numera. Kan du se vilken version körs i din NAS?

  • Medlem
  • Helsingborg
  • 2013-09-29 20:43
Ursprungligen av Sir N.:

Kan ju vara nån bugg i Netatalk eftersom du säger att det gick bra när du körde Apples Airport Extreme. Den version jag kör är ju rätt gammal. Netatalk är ju uppe på version 3.nånting numera. Kan du se vilken version körs i din NAS?

I synology DSM 4.3 är det

Citat:

Netatalk is updated to 2.2.3.

Denna uppdatering kom dock i ver. 4.1 redan.

http://www.synology.com/releaseNote_enu/DS151...

  • Medlem
  • 2013-09-30 00:14
Ursprungligen av Sir N.:

Kan ju vara nån bugg i Netatalk eftersom du säger att det gick bra när du körde Apples Airport Extreme. Den version jag kör är ju rätt gammal. Netatalk är ju uppe på version 3.nånting numera. Kan du se vilken version körs i din NAS?

kör DSM 4.2, så förmodar att det då är som @illerG säger att det är netatalk 2.2.3

  • Medlem
  • Stockholm
  • 2013-09-30 09:22
Ursprungligen av mjewl:

...
2013-09-28 15:17:47,677 com.apple.backupd[1250]: Runtime corruption detected on /Volumes/Time Machine/m-macbook.sparsebundle (fsck_hfs -q termination status: 3)
...

Vad som händer är att TM monterar en sparse bundle på din NAS som innehåller ett helt filsystem i HFS+. En sparse bundle är ett knippe filer som representerar "råinnehållet" på en HFS+-disk. Klienten uppdaterar filsystemet genom block-I/O. Din NAS har ingen aning om vad som sker, eller att det finns ett HFS+-filsystem, etc.

Din klient (TM) har bestämt sig för att kolla integriteten i detta filsystem och kört fsck. Fel har hittats. Ibland går det att reparera fel i ett filsystem, men ibland går det inte. Då måste man kassera hela filsystemet och man får börja om från början med sina backuper.

Varför blev det fel? Man kan gissa på att en förbindelse bröts (HFS+-filsystemet avmonterades aldrig korrekt). Eller att din NAS startades om. Eller att block-I/O har kommit i fel ordning. Eller nåt. Svårt att veta. AFP-protokollet innehåller en del hantering för att undvika att HFS-systemet blir korrupt då anslutningsfel inträffar. Detta är ganska avancerade features som är svåra att få rätt. Jag har ingen aning om netatalk lyckas med det fullt ut. Om man kör TM mot någon typ av NAS är det nog rätt viktigt att se till att netatalk är ordentligt uppdaterat.

Om man kör med t.ex. en USB-ansluten disk så uppstår inte denna problematik. Men det är klart att trådlös backup på laptops är trevlig (själv kör jag USB-disk med TM-historik sedan 2009 utan en enda glitch).

Om du har en Mac Mini så är ju ett alternativ att skaffa en stor USB-disk och direktansluta den till Minin. Laptops kan då backa upp mot denna disk. Fördelen är att man då använder Apples AFP-server som man kan förmoda innehåller alla obskyra features som behövs för att göra systemet felsäkert och man kör på en konfiguration som Apple supportar för TM.

1
Bevaka tråden