Summera negativa tal i Numbers?

Tråden skapades och har fått 14 svar. Det senaste inlägget skrevs .
1

Hur summerar jag en kolumn negativa tal i Numbers?
Provade =SUM(D2-D156,"<0") men det gick inte…

Någon som vet hur man gör?

  • Medlem
  • Kungälv
  • 2013-06-19 12:12

Är if inbakat i sum i numbers?

Excel hade varit =sumif(D2:D156;"<0")

Ursprungligen av Json_81:

Är if inbakat i sum i numbers?

Excel hade varit =sumif(D2:D156;"<0")

SUMMA.OM finns men det funkar inte heller. Testade på en radda positiva värden och där funkade det inte heller...

  • Medlem
  • 2013-06-19 13:08

=SUMMA.OM(B2:B9;"<0") fungerar iallafall för mej...

  • Medlem
  • Stockholm
  • 2013-06-19 17:47

Varför inte bara =SUMMA(B2:B9), det funkar både på negativa och positiva tal

Ursprungligen av Gnulia:

Varför inte bara =SUMMA(B2:B9), det funkar både på negativa och positiva tal

Summa av alla celler blir 0,0. Även en kolumn som bara har positiva värden i sig blir 0,0.

Ursprungligen av Gnulia:

Varför inte bara =SUMMA(B2:B9), det funkar både på negativa och positiva tal

Jag tror att kolumnen innehåller både positiva och negativa tal, och man vill bara summera de negativa.

9.134,29
10.899,29

Dessa två värden bli 0,0 när jag tar =SUMMA(E2:E3)

Ursprungligen av Mattias Hedman:

9.134,29
10.899,29

Dessa två värden bli 0,0 när jag tar =SUMMA(E2:E3)

För att det är fel format. Ta bort punkten, byt komma mot punkt.

9134.29
10899.29
--------
20033.58
  • Medlem
  • Örnsköldsvik
  • 2013-06-19 19:57

Eller snarare punkt till komma, tror jag.

Ursprungligen av mattiL:

Eller snarare punkt till komma, tror jag.

Du kan ju prova dubbla decimaler.

  • Medlem
  • Stockholm
  • 2013-06-19 20:03

=SUMMA.OM(B2:B9;"<0") funkar för mig

Ursprungligen av keptang:

För att det är fel format. Ta bort punkten, byt komma mot punkt.

9134.29
10899.29
--------
20033.58

Tack!
Så klart det var det. Doh.

Och att vissa tal tydligen räknades som bokstäver… som jag blev tvungen att konvertera.

  • Medlem
  • Örnsköldsvik
  • 2013-06-20 18:14

Vad har du för skumma språkinställningar?
I Sverige är komma decimaltecken, och formeln du angav verkar vara svensk (SUMMA.OM() )

1
Bevaka tråden