Intervall för summering med villkor i excel

Tråden skapades och har fått 6 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Täby
  • 2013-05-28 15:03

Hej.

Jag ska summera kostnader för olika kontonnr. Låt säga att vi har ett kategori som innefattar ett antal kontonr, t ex kontonr 41260-41268. Då vill jag skapa en summa.om/summa.omf formel som har villkoret att kontonr:et ska vara mellan 41260-41268. Jag får inte till det! Just nu ser formeln ut såhär:

=SUMMA.OMF(F13:F135;D13:D135;"<=41268"&">=41260")
Ja jag vet att intervallet är helt fel

Tacksam för lite hjälp

Vilken version av Excel pratar vi om? Och vilket operativsystem?

Det här borde funka:
=SUMMA.OMF(F13:F135;D13:D135;">=41260";D13:D135;"<=41268")

  • Medlem
  • Kungälv
  • 2013-05-28 16:31

Vet inte om summa.omf är samma sak som sumifs, men isåfall har du fel syntax.

=SUMIFS(B:B;A:A;">2";A:A;"<5") kommer summera allt i kolumn B där värdet i kolumn A är större än 2 och mindre än 5.
För syntax kan väl inte skilja mellan språkversionerna?

  • Medlem
  • Täby
  • 2013-05-28 16:32
Ursprungligen av Jesper Ohlsson:

Vilken version av Excel pratar vi om? Och vilket operativsystem?

Det här borde funka:
=SUMMA.OMF(F13:F135;D13:D135;">=41260";D13:D135;"<=41268")

Det är en PC faktiskt. office '11. Men funktionerna brukar ju vara likadana som på mac.

Jag provade den funktionen också och då summerar den ju alla konton under och över vilket blir jättemycket. Den enda lösning jag hittat hittills som är lite omständig tycker jag är denna:

=SUMMA.OM(D13:D135;"<41269";F13:F135)+SUMMA.OM(D13:D135;">41259";F13:F135)-SUMMA(F13:F135)

Jag summerar alla konton och drar bort de konton som är över och under det intervall jag är ute efter. Det väldigt märkliga är att tecknet blev negativt därför är den här formeln bakvänd, om du förstår hur jag menar.

  • Medlem
  • Kungälv
  • 2013-05-28 16:40
Ursprungligen av bearen:

Jag provade den funktionen också och då summerar den ju alla konton under och över vilket blir jättemycket.

Har du vänt på tecknen? Det borde fungera.

Ursprungligen av bearen:

...då summerar den ju alla konton under och över vilket blir jättemycket...

Nej, det gör den inte.

Jag har testat nu (Office 2010, Win 7), och här funkar den formeln alldeles utmärkt.

Ursprungligen av bearen:

...Det är en PC faktiskt. office '11...

Det finns ingen Office 2011 för Windows.

Windows = 2003, 2007, 2010, 2013
Mac = 2004, 2008, 2011

  • Medlem
  • Täby
  • 2013-05-29 07:04

Jag orkade inte kolla version på office, det är nog '10.

Ja, jag insåg att jag hade vänt på tecknen men det hade ni redan skrivit ser jag. Tack för hjälpen

1
Bevaka tråden