xbmc och spotify på squeezebox, felmeddelande/portkrångel?

Tråden skapades och har fått 4 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • 2013-05-27 14:08

jag kör xbmc och logitech media center på samma burk (min server)

på logitech mediacenter har jag lagt till ett plugin från triode som gör att man kan spela spotify på sin squeezebox.

tyvärr verkar dessa två saker inte funka ihop och av det lilla jag kan få fram på google-sökningar så verkar det vara portarna som krockar.

xbmc (remote communication service) kör port 9090 vad jag fått fram
spotify (spotifyd) kör 9001 och helper app kör 9005

så förstår inte hur det kan krocka. om det nu ens är så att de gör det..

grejjen är att om jag försöker starta en låt på squeezeboxen med spotify så blev det först bara timed out eller disconnected.
kör jag igång xbmc så får jag couldnt connect eller något liknande felmeddelande med remote communication service. (eller är det server?)

innan jag la till logitech media center/spotify på squeezebox så funkade xbmc (dvs inga felmeddelanden)

hur som helst så verkar spotify fungera nu helt plötsligt av någon anledning. men får fortfarande felmeddelande på xbmc.

så något som vet hur jag löser detta lilla irriterande problem?

Det bör finnas några loggfiler från XBMC/Squeezebox som talar om vad som sker och kanske hjälper till i felsökandet.

  • Medlem
  • 2013-05-27 14:17
Ursprungligen av keptang:

Det bör finnas några loggfiler från XBMC/Squeezebox som talar om vad som sker och kanske hjälper till i felsökandet.

sant, är ruskigt dålig på att utläsa information från loggtexter dock.
men ska försöka ta reda på hur man får fram logg från xbmc och se om jag kan få fram någon nyttig info.

här är i alla fall logg-filen med debugging påslaget:
https://dl.dropboxusercontent.com/u/30289280/xbmc.log

Senast redigerat 2013-05-27 14:39

Vilka plugins använder du för detta?

  • Medlem
  • 2013-05-27 16:54

var helt enkelt bara så att det räckte att gå till inställningar i logitech media center, sedan till avancerade inställningar. där valde man fliken "plugins-program" och i kommandogränsnitts-något (CLI) så ändrade man bort till något annat än 9090

men nu har ett annat problem dykt upp istället som jag ska försöka lösa, men får väl ta det i någon annan tråd då det inte har med xbmc att göra (tror jag)

när jag spelar musik nu så slutar en spela efter en stund, för att börja igen (likt buffering) men sedan efter två gånger så slutar den helt.
och i spotifyd.log så står det att den loggar ut..

funderar över om det kan ha något med os x server som jag precis la in och att DNS är aktiverat där.. (men har ju ip till servern i airport och i servern har jag opendns ip)

jaja.. alltid är det något.

Senast redigerat 2013-05-27 17:21
1
Bevaka tråden