Slå samman 2 tabeller i Numbers eller Excel?

Tråden skapades och har fått 6 svar. Det senaste inlägget skrevs .
1

Jag har 2 tabeller med kundstatistik för 2 olika perioder.

De är ungefär så här:

Adams Svets

452 kr

Kalles Svets

345 kr

Nisses Svets

367 kr

Och i den andra

Adams Svets

564 kr

Charlies Svets

786 kr

Nisses Svets

876 kr

Nu vill jag slå samman dessa tabellerna så här:

Namn

Oms 2011

Oms 2012

Adams Svets

452 kr

564 kr

Charlies Svets

0 kr

786 kr

Kalles Svets

345 kr

0 kr

Nisses Svets

367 kr

876 kr

Dokumenten är i Excel-format och jag kan använda antingen Numbers eller Excel.
Finns det någon smidig väg att kombinera detta, eller är det manuellt klipp-och-klistra som gäller? Det rör sig om data på ca 250 kunder.

Senast redigerat 2013-03-04 12:04

Gjorde ett snabbhack bara som du kan jobba vidare på.
https://dl.dropbox.com/u/4962892/svets.xlsx

Fyll i data i 2011/2012.
Fyll i alla dina "svetsare" i kolumn A i total, kopiera ner formlerna i kolumn B och C i total.

Ursprungligen av keptang:

Gjorde ett snabbhack bara som du kan jobba vidare på.
https://dl.dropbox.com/u/4962892/svets.xlsx

Fyll i data i 2011/2012.
Fyll i alla dina "svetsare" i kolumn A i total, kopiera ner formlerna i kolumn B och C i total.

Stort tack! Ett litet problem bara. Jag har ju 2 tabeller med kundnamn som stämmer överens till typ 90%. Hur får jag in dem i kolumn A på fliken Total? Det är för många poster med för mycket text för att jag ska kunna mata in namnen manuellt.

Du kan klistra in alla i en tom flik bara efter varann, köra data, filter, advanced. Klicka i Unique records only (beroende på Excel-version).

Så får du en lista med unika records som du kan lägga in i total.

Lysande! Tack!

Ursprungligen av pmarriott:

Jag har 2 tabeller med kundstatistik för 2 olika perioder.

De är ungefär så här:

Adams Svets

452 kr

Kalles Svets

345 kr

Nisses Svets

367 kr

Och i den andra

Adams Svets

564 kr

Charlies Svets

786 kr

Nisses Svets

876 kr

Nu vill jag slå samman dessa tabellerna så här:

Namn

Oms 2011

Oms 2012

Adams Svets

452 kr

564 kr

Charlies Svets

0 kr

786 kr

Kalles Svets

345 kr

0 kr

Nisses Svets

367 kr

876 kr

Dokumenten är i Excel-format och jag kan använda antingen Numbers eller Excel.
Finns det någon smidig väg att kombinera detta, eller är det manuellt klipp-och-klistra som gäller? Det rör sig om data på ca 250 kunder.

Nu har jag ett annat besvär. Det står totalt still i huvudet på mig. Hur skriver jag en formel som anger i en kolumn hur 2 tal förhåller sig till varandra procentuellt? Det jag vill åstadkomma är detta:

100

200

100%

200

100

-50%

0

100

∞%

100

0

-100%

100

150

50%

=(B1-A1)/A1

(Formatera som procent eller multiplicera med 100)

Edit: Division med 0 är inte definierat och kommer att ge ett fel. Om du nödvändigtvis vill ha ett oändlighetstecken istället kan detta fungera:

=OM(A1;(B1-A1)/A1;"∞%")

Senast redigerat 2013-03-04 21:52
1
Bevaka tråden