Macbook pro crashar när jag kopplar in min iphone!

Tråden skapades och har fått 22 svar. Det senaste inlägget skrevs .
1

Tjena, jag har en MB pro som jag köpte på blocket för några dagar sedan, jag formaterade den direkt och köpa mountain lion ( har lion på min mb air) och märkte ett problem när jag kopplar in min iphone via usb, då krashar datorn direkt och det kommer upp en bild med en text på massor av olika språk där det står att datorn har krashat och jag måste starta om den, något i den stilen, detta händer varje gång. Hur som helst så tänkte jag att det är väl bara något konstigt fel ( har använt mac i 2 år och innan det windows i många år, så jag är van vid konstiga problem). idag fick jag hem 8gb ram och en ssd hybrid, jag har nu installerat grejerna och gjort en helt ny installation av ML (har känt att lion funkar bättre men tänker ge ML en chans till) men problemet kvarstår, datorn krashar direkt när jag kopplar in telefonen. någon som har samma problem eller vet en lösning?

Har du installerat alla tillgängliga uppdateringar i datorn (t.ex OS X 10.8.2)?

Vilken MacBook Pro-modell?

Vilken iPhone-modell?

Vilken version av iOS i telefonen?

Jag har testat med annan kabel nu, igen skillnad, krashar direkt! hmm.. dåliga minnen, problemet var med både original minnena och med mina helt nya minnen som inte ens varit igång i 2h. så jag hoppas att det inte är minnena som är problemet.

Ursprungligen av greken91:

Tjena, jag har en MB pro som jag köpte på blocket för några dagar sedan, jag formaterade den direkt och köpa mountain lion ( har lion på min mb air) och märkte ett problem när jag kopplar in min iphone via usb, då krashar datorn direkt och det kommer upp en bild med en text på massor av olika språk där det står att datorn har krashat och jag måste starta om den, något i den stilen, detta händer varje gång. Hur som helst så tänkte jag att det är väl bara något konstigt fel ( har använt mac i 2 år och innan det windows i många år, så jag är van vid konstiga problem). idag fick jag hem 8gb ram och en ssd hybrid, jag har nu installerat grejerna och gjort en helt ny installation av ML (har känt att lion funkar bättre men tänker ge ML en chans till) men problemet kvarstår, datorn krashar direkt när jag kopplar in telefonen. någon som har samma problem eller vet en lösning?

Byt USB-kabel.

Allt är uppgradetat!
macbook pro 15" mid 2010, 2,4 GHz i5, 8gb ram, 750gb ssd hybrid, osx version 10.8.2. behöver du veta något mer så säg till.

iphone 4s, senaste ios, antar att det är ios6.

den funkar perfekt på min mb air med vanliga lion.

@grenhall - som jag sa så funkar det perfekt till min mb air

  • Medlem
  • Malmö
  • 2013-01-15 21:38

Testa annan kabel först men jag har haft exakt detta problemet och det orsakades av dåliga RAM-minnen.

Helt ren dator? Testat ny användare?

Vad säger crash-rapporten från OS X? Du bör få upp en ruta där du kan ta del av informationen: OS X: Om kernel panic

100% ny, har testat ny användare (även fast den jag sitter på är helt ny den också), jag kollade igenom lite snabbt bara, fattade inte så mycket, kan koppla in telefonen igen och kopiera om ni vill ta er en titt.

Ursprungligen av greken91:

100% ny....

Ja, den är kanske ny, men den är inte ren (har vi ju fått reda på nu). Och det var just en ren installation som suddgummi frågade om.

Prova med en helt ren installation först. Om det fungerar då, så kan du börja installera program.

Har du original Apple USB sladd? Provat olika portar? Blåst rent kontaktytorna? Provat ny användare & säkert läge?

Inte för att jag tror det beror på dina minnespinnar, men det kan vara bra att testa dem.

När du säger krashar direkt, menar du i samma ögonblick kontakten tryck in i mobilen? Eller när datorn tänker 'tjena iphone, ska vi hitta på nåt?' typ 1,2s senare?

Sladden är original ja! jag har provat båda portarna, jag har testat blåsa rent och testat ny användare, ska prova säkert läge nu!

Jag skulle väl säga att det tar 0,5 sec kanske, jag hinner trycka in kontakten och när jag släpper taget om den så krashar datorn, telefonen hinner exakt lysa till när det krashar, så dom hinner antagligen säga "tje"

Jag försökte starta i säkert läge, men den tjatar om lösenord för användaren och jag använder inte lösenord.

Jag hoppas att det inte står någon känslig info här i, men här kommer krash rapporten:

Tue Jan 15 23:12:22 2013
panic(cpu 0 caller 0xffffff801aab7bd5): Kernel trap at 0xffffff801aaf2ad1, type 14=page fault, registers:
CR0: 0x0000000080010033, CR2: 0x00000000000000c0, CR3: 0x0000000074edc000, CR4: 0x0000000000000660
RAX: 0x0000000001000001, RBX: 0x0000000000000020, RCX: 0x0000000003000000, RDX: 0xffffff802d561870
RSP: 0xffffff810314bcb0, RBP: 0xffffff810314bcd0, RSI: 0x0000000000000020, RDI: 0xffffff802d561870
R8: 0x0000000000000000, R9: 0x00000000000003ff, R10: 0xffffffffffffffff, R11: 0x00000000ffffffff
R12: 0xffffff802d5a6b70, R13: 0xffffff802d8fd000, R14: 0x0000000000000000, R15: 0x00000000000000c0
RFL: 0x0000000000010282, RIP: 0xffffff801aaf2ad1, CS: 0x0000000000000008, SS: 0x0000000000000010
Fault CR2: 0x00000000000000c0, Error code: 0x0000000000000000, Fault CPU: 0x0

Backtrace (CPU 0), Frame : Return Address
0xffffff810314b950 : 0xffffff801aa1d626
0xffffff810314b9c0 : 0xffffff801aab7bd5
0xffffff810314bb90 : 0xffffff801aace4ed
0xffffff810314bbb0 : 0xffffff801aaf2ad1
0xffffff810314bcd0 : 0xffffff7f9d02fb40
0xffffff810314bd20 : 0xffffff801ab2055d
0xffffff810314bd70 : 0xffffff801ab11ec4
0xffffff810314bde0 : 0xffffff801ab08459
0xffffff810314be30 : 0xffffff801ad4ae63
0xffffff810314be60 : 0xffffff801ad77ae3
0xffffff810314bf60 : 0xffffff801ade1533
0xffffff810314bfb0 : 0xffffff801aacea1d
Kernel Extensions in backtrace:
com.github.osxfuse.filesystems.osxfusefs(2.3.8)[6AC3DE62-14A4-3895-A6A4-E3253A0B00F3]@0xffffff7f9d02f000->0xffffff7f9d044fff

BSD process name corresponding to current thread: mobile_fs_util

Mac OS version:
12C60

Kernel version:
Darwin Kernel Version 12.2.0: Sat Aug 25 00:48:52 PDT 2012; root:xnu-2050.18.24~1/RELEASE_X86_64
Kernel UUID: 69A5853F-375A-3EF4-9247-478FD0247333
Kernel slide: 0x000000001a800000
Kernel text base: 0xffffff801aa00000
System model name: MacBookPro6,2 (Mac-F22586C8)

System uptime in nanoseconds: 4929148559222
last loaded kext at 4929141865813: com.github.osxfuse.filesystems.osxfusefs 2.3.8 (addr 0xffffff7f9d02f000, size 90112)
last unloaded kext at 4176709306611: com.vmware.kext.vmci 90.4.18 (addr 0xffffff7f9d02f000, size 73728)
loaded kexts:
com.github.osxfuse.filesystems.osxfusefs 2.3.8
com.parallels.kext.prl_vnic 7.0 15106.786747
com.parallels.kext.prl_netbridge 7.0 15106.786747
com.parallels.kext.prl_hid_hook 7.0 15106.786747
com.parallels.kext.prl_hypervisor 7.0 15106.786747
foo.tun 1.0
foo.tap 1.0
com.parallels.kext.prl_usb_connect 7.0 15106.786747
com.paceap.kext.pacesupport.snowleopard 5.8
com.apple.driver.AppleUSBCDC 4.1.22
com.apple.driver.AppleBluetoothMultitouch 75.15
com.apple.driver.AppleHWSensor 1.9.5d0
com.apple.iokit.IOBluetoothSerialManager 4.0.9f33
com.apple.driver.AudioAUUC 1.60
com.apple.filesystems.autofs 3.0
com.apple.driver.AGPM 100.12.69
com.apple.driver.AppleMikeyHIDDriver 122
com.apple.driver.AppleHDA 2.3.1f2
com.apple.driver.AppleMikeyDriver 2.3.1f2
com.apple.driver.ACPI_SMC_PlatformPlugin 1.0.0
com.apple.driver.AppleSMCLMU 2.0.2d0
com.apple.driver.AppleLPC 1.6.0
com.apple.driver.AppleMuxControl 3.2.11
com.apple.driver.AppleSMCPDRC 1.0.0
com.apple.iokit.IOUserEthernet 1.0.0d1
com.apple.Dont_Steal_Mac_OS_X 7.0.0
com.apple.driver.ApplePolicyControl 3.2.11
com.apple.iokit.BroadcomBluetoothHCIControllerUSBTransport 4.0.9f33
com.apple.driver.AppleUpstreamUserClient 3.5.10
com.apple.driver.AppleMCCSControl 1.0.33
com.apple.GeForce 8.0.0
com.apple.driver.AppleIntelHDGraphics 8.0.0
com.apple.driver.AppleIntelHDGraphicsFB 8.0.0
com.apple.driver.SMCMotionSensor 3.0.2d6
com.apple.driver.AppleUSBTCButtons 235.4
com.apple.driver.AppleUSBCardReader 3.1.0
com.apple.driver.AppleUSBTCKeyboard 235.4
com.apple.driver.AppleIRController 320.15
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0d1
com.apple.BootCache 34
com.apple.iokit.SCSITaskUserClient 3.5.1
com.apple.driver.XsanFilter 404
com.apple.iokit.IOAHCIBlockStorage 2.2.2
com.apple.driver.AppleFWOHCI 4.9.6
com.apple.driver.AppleAHCIPort 2.4.1
com.apple.driver.AirPort.Brcm4331 602.15.22
com.apple.driver.AppleUSBHub 5.2.5
com.apple.iokit.AppleBCM5701Ethernet 3.2.5b3
com.apple.driver.AppleUSBEHCI 5.4.0
com.apple.driver.AppleSmartBatteryManager 161.0.0
com.apple.driver.AppleEFINVRAM 1.6.1
com.apple.driver.AppleACPIButtons 1.6
com.apple.driver.AppleRTC 1.5
com.apple.driver.AppleHPET 1.7
com.apple.driver.AppleSMBIOS 1.9
com.apple.driver.AppleACPIEC 1.6
com.apple.driver.AppleAPIC 1.6
com.apple.driver.AppleIntelCPUPowerManagementClient 196.0.0
com.apple.nke.applicationfirewall 4.0.39
com.apple.security.quarantine 2
com.apple.driver.AppleIntelCPUPowerManagement 196.0.0
com.apple.driver.AppleBluetoothHIDKeyboard 165.5
com.apple.driver.AppleHIDKeyboard 165.5
com.apple.driver.IOBluetoothHIDDriver 4.0.9f33
com.apple.driver.AppleMultitouchDriver 235.28
com.apple.iokit.IOSerialFamily 10.0.6
com.apple.kext.triggers 1.0
com.apple.driver.DspFuncLib 2.3.1f2
com.apple.iokit.IOAudioFamily 1.8.9fc10
com.apple.kext.OSvKernDSPLib 1.6
com.apple.driver.IOPlatformPluginLegacy 1.0.0
com.apple.driver.AppleSMBusPCI 1.0.10d0
com.apple.iokit.IOFireWireIP 2.2.5
com.apple.driver.AppleHDAController 2.3.1f2
com.apple.iokit.IOHDAFamily 2.3.1f2
com.apple.driver.IOPlatformPluginFamily 5.2.0d16
com.apple.iokit.IOSurface 86.0.3
com.apple.iokit.IOBluetoothFamily 4.0.9f33
com.apple.driver.AppleGraphicsControl 3.2.11
com.apple.driver.AppleBacklightExpert 1.0.4
com.apple.iokit.AppleBluetoothHCIControllerUSBTransport 4.0.9f33
com.apple.driver.AppleSMBusController 1.0.10d0
com.apple.nvidia.nv50hal 8.0.0
com.apple.NVDAResman 8.0.0
com.apple.iokit.IONDRVSupport 2.3.5
com.apple.iokit.IOGraphicsFamily 2.3.5
com.apple.driver.AppleSMC 3.1.4d2
com.apple.iokit.IOSCSIBlockCommandsDevice 3.5.1
com.apple.iokit.IOUSBMassStorageClass 3.5.0
com.apple.driver.AppleUSBMultitouch 235.7
com.apple.iokit.IOUSBHIDDriver 5.2.5
com.apple.driver.AppleUSBMergeNub 5.2.5
com.apple.driver.AppleUSBComposite 5.2.5
com.apple.iokit.IOSCSIMultimediaCommandsDevice 3.5.1
com.apple.iokit.IOBDStorageFamily 1.7
com.apple.iokit.IODVDStorageFamily 1.7.1
com.apple.iokit.IOCDStorageFamily 1.7.1
com.apple.iokit.IOAHCISerialATAPI 2.5.0
com.apple.iokit.IOSCSIArchitectureModelFamily 3.5.1
com.apple.iokit.IOFireWireFamily 4.5.5
com.apple.iokit.IOAHCIFamily 2.2.1
com.apple.iokit.IO80211Family 500.15
com.apple.iokit.IOUSBUserClient 5.2.5
com.apple.iokit.IOEthernetAVBController 1.0.2b1
com.apple.iokit.IONetworkingFamily 3.0
com.apple.iokit.IOUSBFamily 5.4.0
com.apple.driver.AppleEFIRuntime 1.6.1
com.apple.iokit.IOHIDFamily 1.8.0
com.apple.iokit.IOSMBusFamily 1.1
com.apple.security.sandbox 220
com.apple.kext.AppleMatch 1.0.0d1
com.apple.security.TMSafetyNet 7
com.apple.driver.DiskImages 344
com.apple.iokit.IOStorageFamily 1.8
com.apple.driver.AppleKeyStore 28.21
com.apple.driver.AppleACPIPlatform 1.6
com.apple.iokit.IOPCIFamily 2.7.2
com.apple.iokit.IOACPIFamily 1.4
com.apple.kec.corecrypto 1.0
Model: MacBookPro6,2, BootROM MBP61.0057.B0F, 2 processors, Intel Core i5, 2.4 GHz, 8 GB, SMC 1.58f15
Graphics: Intel HD Graphics, Intel HD Graphics, Built-In, 288 MB
Graphics: NVIDIA GeForce GT 330M, NVIDIA GeForce GT 330M, PCIe, 256 MB
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1067 MHz, 0x029E, 0x434D5341344758334D314131333333433920
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1067 MHz, 0x029E, 0x434D5341344758334D314131333333433920
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x93), Broadcom BCM43xx 1.0 (5.106.98.81.22)
Bluetooth: Version 4.0.9f33 10885, 2 service, 18 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: ST750LX003-1AC154, 750,16 GB
Serial ATA Device: MATSHITADVD-R UJ-898
USB Device: hub_device, 0x0424 (SMSC), 0x2514, 0xfa100000 / 2
USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0xfa130000 / 5
USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0237, 0xfa120000 / 4
USB Device: BRCM2070 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0xfa110000 / 3
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8218, 0xfa113000 / 7
USB Device: hub_device, 0x0424 (SMSC), 0x2514, 0xfd100000 / 2
USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd120000 / 4
USB Device: Built-in iSight, apple_vendor_id, 0x8507, 0xfd110000 / 3

Senast redigerat 2013-01-15 23:21

Kan du prova att ansluta något annat till USB-portarna? Minnen, skrivare eller nåt? Vad händer då?

Jag har en usb hubb med 4 st externa hårddiskar i just nu, ingenting händer, eller ja, jag kan använda hårddiskarna, men datorn krashar inte. Använde dessutom ett usb minne för att installera lion, och använde ett usb minne för ca 30 min sen för att installera win 7.

Inte är väl den datorn nyinstallerad? Du har ju både Parallels och Vmware i den, eller i alla fall drivrutiner från dem. Du har Osxfuse, du har nån paceap kext för Snow Leopard.

Du har iphonedisk installerat eller? Den fungerar inte post-Lion. Det står på deras sida i alla fall.

Om du testar med en reninstallation av ML så kan du se om det går bättre. Importera alltså inte din användare från din Lion-installation utan försök först kolla så att allt funkar som det ska med en "tom" användare

Jag installerade den vid 20 tiden ungefär, parallels installerade jag demo för att testa om det var bättre än vmware som jag brukar använda, men kom fram till nej så jag installerade vmware istället. osxfuse har jag ingen aning om vad det är, aldrig använt, inte paceap kext heller, inte ens hört talas om, går sånt att ta bort själv?

det som inte är nytt är sånt som jag lagt över på en extern hårddisk från min gamla, men det är bara logic, många gig samples och plugins till logic.

Jag har inte installerat iphonedisk, inte vad jag vet iallafall, jag har alltid bara kopplat in telefonen så har allt fungerat. Jag orkar tyvärr inte installera om datorn en gång till, har gjort det 3 gånger sedan söndags kväll och jag har spelning om två dagar så jag kommer behöva jobba i logic, så om det inte går att försöka fixa problemet utan en till ominstallation så får det vara så här ett tag, jag har iallafall googlat runt en del och det verkar vara många som har samma problem, och vad jag kunnat läsa mig till så verkar problemet vara med alla os x.

Senast redigerat 2013-01-15 23:47

OS X Fuse hade jag tagit bort, eller iaf uppdaterat.

Jag försöker söka efter os x fuse men den hittar ingenting med det namnet och det finns inte i program listan, har aldrig använt något program med det namnet.

Nu laddade jag ned installations filen från deras hemsida eftersom att programmet inte fanns som det skulle innan, jag installerade det, och sen tog bort det enligt wikin.

  • Medlem
  • Karlskoga
  • 2013-01-16 10:29
Ursprungligen av greken91:

Nu laddade jag ned installations filen från deras hemsida eftersom att programmet inte fanns som det skulle innan, jag installerade det, och sen tog bort det enligt wikin.

Och...? Kraschar den fortfarande?

var mitt uppe i en säkerhetskopiering så jag kunde inte testa, men nu krashar den inte, jag får upp nått meddelande om osx fuse är fel version, men det kanske är för att jag inte har startat om datorn efter att jag laddade ner det och tog bort det igen.

Du bör nog kolla efter kexts och launch agenter/demoner också.
Om du avinstallerat alla grejer som du inte behöver (typ Parallels, VMWare och osxfuse) kan du kolla så att de blev riktigt avinstallerade genom att titta i ~/Library/LaunchAgents, ~/Library/LaunchDaemons, /Library/LaunchAgents, /Library/LaunchDaemons (tryck cmd+shift+g i Finder och fyll i sökvägarna). Om där ligger något med Parallels, VMWare eller osxfuse där så plocka bort de filerna.
Eftersom du får fel med mobile_fs* så kolla i /System/Library/Extensions efter kexts med det i namnet (en hint: allt som inte börjar på com.apple.* brukar vara efterinstallerat)

Passa på att plocka väck Tunnelblick eller någon annan tredjeparts VPN-klient som du har installerad (dina kext foo.tun ochfoo.tap bör tillhöra en sån applikation).

Ursprungligen av suddgummi:

Du bör nog kolla efter kexts och launch agenter/demoner också.
Om du avinstallerat alla grejer som du inte behöver (typ Parallels, VMWare och osxfuse) kan du kolla så att de blev riktigt avinstallerade genom att titta i ~/Library/LaunchAgents, ~/Library/LaunchDaemons, /Library/LaunchAgents, /Library/LaunchDaemons (tryck cmd+shift+g i Finder och fyll i sökvägarna). Om där ligger något med Parallels, VMWare eller osxfuse där så plocka bort de filerna.
Eftersom du får fel med mobile_fs* så kolla i /System/Library/Extensions efter kexts med det i namnet (en hint: allt som inte börjar på com.apple.* brukar vara efterinstallerat)

Passa på att plocka väck Tunnelblick eller någon annan tredjeparts VPN-klient som du har installerad (dina kext foo.tun ochfoo.tap bör tillhöra en sån applikation).

Nu har jag varit runt där och letat, plockat bort lite saker, hittade inget till osxfuse där, men hittade annat iallafall! tack för hjälpen

1
Bevaka tråden