Färgfel på tvn när jag kopplat min macbook till den

Tråden skapades och har fått 14 svar. Det senaste inlägget skrevs .
1

Jag kopplar min macbook pro till tvn med en mini display ports kabel.
Bilden blir bra allt från 1min till 15min sen blir det helt plötsligt inverterade färger några minuter sen brukar det bli bra ett litet tag igen, och så håller det på.
Jag har läst i dom trådar som jag hittar om liknande problem men har inte lyckats komma fram till någon lösning själv.

Jag har datorläge aktiverat på datorn, jag har ändrat mellan alla upplösningar jag kan typ.
Kabeln fungerar helt fel fri när jag använder den till en annan tv.

Tacksam för alla förslag.

Jag har en philips 42pfl8654H/12

Vilken Macbook Pro har du?
Vilken version av OS X kör du? Lion? Funkar detta https://discussions.apple.com/thread/3382106 ?

Jag har exakt samma problem med min Philips 42" kombinerat med MBP 2011 och MBA 2012 (Lion och Mounatin Lion). Provat med två olika kablar. Samma kablar/datorer funkar perfekt på andra tvs/skärmar medans tex min flickväns MB fungerar på vår tv. Detta har drivit mig till vansinne och jag har inte hittat någon lösning förutom att köpa en Apple TV...

Jag har haft samma issue med min Philips 52pfl9606. Lösningen var den som keptang länkar.

Jag har en MBP 2011 intel core i5 med snow leopard

Ursprungligen av blomquist_87:

Jag har en MBP 2011 intel core i5 med snow leopard

Gör såhär (enligt länken i #2). Återkom med resultat om vad som hände!

det funkade efter den där guiden:) tack så jätte mycket för hjälpen

Fint!

Skönt att se en lösning på detta baserat på något en användare kan påverka! Felet ligger i TV:n och hur HDMI-chipet hanterar metadata, EDID vilket innebär att signalen matas in i fel färgsystem. En override får grafikkortet att ignorera TV:ns metadata.

Kan tillägga att detta är väldigt vanligt problem med Philips TV-apparater sedan flera år tillbaka, samt även en del Sony-modeller, sannolikt med samma eller snarlik kretsuppsättning på HDMI-anslutningen. För ett par år sedan hade Philips en roadshow där fenomenet uppstod hela tiden. Då sprang personalen runt och startade om TV-apparaterna med 10 - 20 minuters mellanrum.

  • Medlem
  • Neverland
  • 2013-01-05 16:43
Ursprungligen av Thomas Ytterberg:

Kan tillägga att detta är väldigt vanligt problem med Philips TV-apparater sedan flera år tillbaka, samt även en del Sony-modeller

Intressant. Jag som för närvarande funderar på att byta TV bör alltså undvika Philips och Sony?

Ursprungligen av filuren:

Intressant. Jag som för närvarande funderar på att byta TV bör alltså undvika Philips och Sony?

Problemet uppstår för vissa som kör Mac tydligen, lösningen finner du i inlägg #2 och #6.
Har aldrig haft några problem med detta med min Sony.

  • Medlem
  • Neverland
  • 2013-01-05 16:53
Ursprungligen av keptang:

Problemet uppstår för vissa som kör Mac tydligen, lösningen finner du i inlägg #2 och #6.
Har aldrig haft några problem med detta med min Sony.

Jo, så långt är jag med. Men jag tycker det känns osäkert att behöva förlita mig på tredjepartslösningar som kanske förlorar stöd eller funktion i de datorer jag kommer att ha under TV-apparatens hela livslängd.

Ursprungligen av filuren:

Jo, så långt är jag med. Men jag tycker det känns osäkert att behöva förlita mig på tredjepartslösningar som kanske förlorar stöd eller funktion i de datorer jag kommer att ha under TV-apparatens hela livslängd.

Det är nog ingen risk.
Det verkar vara ett OS X-problem som är enkelt fixat. Kanske till och med Apple orkar fixa det.

Men köp något annat du, det är ju fritt liksom.

Ursprungligen av filuren:

Intressant. Jag som för närvarande funderar på att byta TV bör alltså undvika Philips och Sony?

Du bör ha det i åtanke. Långt ifrån alla drabbas - annars skulle vi höra oftare om detta och skulle det vara vanligare, skulle problemet antagligen vara fixat vid det här laget.

  • Medlem
  • Uppsala
  • 2014-02-22 19:40
Ursprungligen av keptang:

Vilken Macbook Pro har du?
Vilken version av OS X kör du? Lion? Funkar detta https://discussions.apple.com/thread/3382106 ?

Jag använde den här lösningen på min fästmös MBA late 2013 och det fungerade nästan. Färgerna fungerar nu som de ska, men TV:n blinkar ändå till då och då. Den blinkar till ungefär lika ofta som den gjorde när den skiftade färgerna till grön/rosa fast det blir istället svart någon hundradels sekund och sedan kommer bilden tillbaka.

Några tips på hur detta går att lösa?

/ Jonas

1
Bevaka tråden