Varför syns ingen bild när jag kopplar MacBook till en TV?

Tråden skapades och har fått 9 svar. Det senaste inlägget skrevs .
1

Jag har en MacBook (den äldre vita plastmodellen) men OS Snow Leopard. Till detta har jag en minidvi till dvi-kabel som jag ansluter till min Panasonic-TV med hjälp av en dvi till hdmi-kabel. Med hjälp av denna anordning har jag under ca två veckors tid kunnat använda TV:n som bildskärm.

Nu till det märkliga problemet:
Det fungerar inte längre trots att jag har samma anslutningar som tidigare. Datorbilden dyker inte längre upp på TV:n som istället bara är svart. Jag har testat olika hdmi-ingångar på TV:n med samma resultat. Jag har också testat att ansluta min PS3:a till den hdmi-ingång jag använt för Macen och det fungerar utmärkt, så det är uppenbarligen inget fel på hdmi-kontakten på TV:n.

Men vänta, det blir märkligare:
Jag har också testat att ansluta Macbooken, med hjälp av samma sladd, till en annan TV. Det fungerar utmärkt. Glad över att det fungerade testade jag återigen på min Panasonic-TV. Det fungerade i någon minut innan bilden plötsligt försvann igen och var omöjlig att få tillbaka.

Det som händer när jag ansluter sladden till datorn är att bilden blir blå en stund för att sen komma tillbaka. Tidigare hände samma sak på TV:n, men nu händer absolut INGENTING! Bilden är svart.

Vad kan ha hänt? Det kan väl inte vara något med datorn eller sladden eftersom det funkar när jag kopplar in till en annan TV? Och det är uppenbarligen inte heller något fel på min TV eftersom det fungerar när jag kopplar PS3:an till samma hdmi-ingång! Kan det vara något med upplösningen? Jag har testat att ändra upplösning på macen under Systeminställningar, men felet kvarstår.

För mig känns det här oerhört märkligt och irriterade. Det tycks ungefär som om datorn och TV:n plötsligt kommit på att de inte gillar varandra...

Snälla hjälp!

  • Skribent
  • Sollentuna
  • 2012-09-17 10:35

Det påminner om problemet jag hade med en extern skärm till min gamla iMac med Snow Leopard. Efter en uppdatering av OS:et slutade den externa skärmen funka med den kabel som funkade innan. Samma kabel med annan skärm funkade, och min skärm funkade med samma kabel med en annan dator. Det verkade som om det var just den kombinationen av skärm och kabel som inte funkade.

Det enda som hjälpte för mig var att byta kabel. Testa det.

Edit: Byt ut alla delar av kabeln för säkerhets skull, inklusive adaptrar.

men vad kan ha hänt? jag har inte uppdaterat något utan plötsligt slutar det funka! Den där adaptern var ju skitdyr!

  • Skribent
  • Sollentuna
  • 2012-09-17 11:02
Ursprungligen av Erik Norbergh:

men vad kan ha hänt? jag har inte uppdaterat något utan plötsligt slutar det funka! Den där adaptern var ju skitdyr!

Kolla på ebay, det finns nog billigare adaptrar där.

Edit: $5 här t.ex.: http://www.ebay.com/itm/New-Mini-DVI-Male-to-HDMI-Female-Video-Adapter-Cable-for-iMac-Macbook-White-/170819612421?pt=US_Video_Cables_Adapters&hash=item27c5a46f05

Ursprungligen av Vassius:

Kolla på ebay, det finns nog billigare adaptrar där.

Edit: $5 här t.ex.: New Mini DVI Male to HDMI Female Video Adapter Cable for iMac Macbook White | eBay

Tack! Jag beställde en härifrån: Mini DVI Male to HDMI Female Video Adapter Cable for Macbook (Wh - Kablage - Hongkong Direkt

Blir billigare med frakt!

Ursprungligen av Erik Norbergh:

Tack för det tipset! Det blev en beställning på ett par olika adapters. Hoppas bara att kvaliteten är högre än vad priserna antyder.

  • Skribent
  • Sollentuna
  • 2012-09-17 21:34
Ursprungligen av Erik Norbergh:

Tack! Jag beställde en härifrån: Mini DVI Male to HDMI Female Video Adapter Cable for Macbook (Wh - Kablage - Hongkong Direkt

Blir billigare med frakt!

Berätta gärna hur det går sen.

Men jag har inte uppdaterat OS:et! Jag har inte uppdaterat någonting! Kan det då ändå vara kabeln?

glömde skriva att jag under Systeminställningar och Bildskärm får upp en ruta som heter just Panasonic-TV så det talar ju för att datorn känner av att TV:n är inkopplad även om bilden inte visas.

  • Skribent
  • Sollentuna
  • 2012-09-17 11:00

Kör du med utökat skrivbord? I så fall, kan du flytta muspekaren till skrivbordsytan som "ska" vara på tv:n? Så var det för mig. Den externa skärmen "fanns" i systemet, men visade ingen bild.

Att testa med en annan kabel är ett relativt billigt och enkelt sätt att felsöka. Testa det innan du sliter ditt hår för att inget annat funkar.

Kör du med skärmen uppe eller är den stängd? Är den stängd måste du ha nätsladden ikopplad annars blir det ingen bild! Hade själv det problemet i början

1
Bevaka tråden