Python - kom-igång-problem

Tråden skapades och har fått 4 svar. Det senaste inlägget skrevs .
1

Vet inte om man ska kalla det nybörjarfrågor eller kompabilitetsproblem?

Hur som helst kör jag en MBPR med OS X 10.8. Vi har satt igång och knacka lite python på universitetet där vi kör 2.X.X tänkte därför jag skulle installera sista version av 2 i stället för att köra 3. Har därför laddat ner följande:

  • Python 2.7.3 Mac OS X 64-bit/32-bit x86-64/i386 Installer (for Mac OS X 10.6 and10.7)

  • ActiveTcl 8.5.12 (for Mac OS X10.8)

Startar IDLE och testar några enkla rader kod och det fungerar finfint.
Men sen när jag ska gå in och ändra lite inställningar i menyn (Preferences) så kraschar det var enda gång utan undantag.
Andra problemet är att den tycks indentera koden lite fel ibland vilket resulterar i en icke korrekt kod.

Någon med erfarenheter av detta eller liknande problem? Skulle givetvis kunna posta den långa felrapporten som skapas..

Får du några felmeddelanden när det kraschar?

Är det inte typ python 2.7.2 som är default i 10.8 förresten?

  • Medlem
  • International user
  • 2012-09-07 13:15
Ursprungligen av rittfeldt:

Vet inte om man ska kalla det nybörjarfrågor eller kompabilitetsproblem?

Hur som helst kör jag en MBPR med OS X 10.8. Vi har satt igång och knacka lite python på universitetet där vi kör 2.X.X tänkte därför jag skulle installera sista version av 2 i stället för att köra 3. Har därför laddat ner följande:

  • Python 2.7.3 Mac OS X 64-bit/32-bit x86-64/i386 Installer (for Mac OS X 10.6 and10.7)

  • ActiveTcl 8.5.12 (for Mac OS X10.8)

Startar IDLE och testar några enkla rader kod och det fungerar finfint.
Men sen när jag ska gå in och ändra lite inställningar i menyn (Preferences) så kraschar det var enda gång utan undantag.
Andra problemet är att den tycks indentera koden lite fel ibland vilket resulterar i en icke korrekt kod.

Någon med erfarenheter av detta eller liknande problem? Skulle givetvis kunna posta den långa felrapporten som skapas..

Mountain Lion kommer med det mesta som behövs, bland annat Python 2.7.2. Jag har ingen lösning på ditt problem annat än att jag verkligen rekommenderar att du bytar editor, IDLE suger hårt. Själv kör jag TextMate + iPython (installleras med easy_install), och det finns många fler editors här: PythonEditors - PythonInfo Wiki

Sublime Text 2 och Smultron är också två mycket bra editorer. Sublime Text 2 finns dessutom till Windows också om du behöver använda sådana datorer ibland.

Oj, sorry allihopa! Dåligt av mig, men jag hade lyckats kryssa av trådbevakningen och därmed lyckats missa svaren

Fick inga felmeddelanden. Men har nu "löst det" eller snarare gått runt det genom att helt enkelt köra en annan editor. Kör nu textwrangler + iPython efter att ha utvärderat flera olika alternativ.

Tack för svaren!

1
Bevaka tråden