DHCP-server fungerar med Mac, iPhone, Android - men INTE med Windows

Tråden skapades och har fått 5 svar. Det senaste inlägget skrevs .
1

Hej!

Jag ansvarar för en del i ett nätverk på kontoret, som är ganska enkelt uppbyggt. En Mac mini med Snow Leopard Server är router/brandvägg och skapar ett undernät till vår avdelning i huset. Den skapar ett nytt 192-nät till vårt kontor i huset, och delar ut interna IP-nummer genom DHCP-servern. Allt fungerar fint, om man sitter på en Mac, en iPhone, iPad, eller en Android-telefon. Men med Windows (XP, Vista, 7) fungerar det inte alls. Då får man inget IP-nummer av DHCP-servern. Om man istället anger IP-adress, nätmask, router och DNS-uppgifter manuellt i varke Windows-burk, så fungerar det fint. Alltså riktas misstankarna direkt mot DHCP-servern.

Vi har kört den här konfigurationen länge nu, och det har varit otroligt stabilt. Problemet har uppkommit efter att vi flyttat till en annan lokal och nu lagt vårt nätverk som en under-nät i ett större nät i huset. Men det borde ju inte DHCP-servern bry sig om väl?

Någon annan förändring är i princip inte gjord, som kan förklara detta märkliga problem. Är det någon som har en idé om vad som kan vara problem här? OK, Mac är trevligare än Windows, men att DHCP-servern totalratar Windows så här bryskt känns ju lite väl hårt.

Tacksam för lite förslag på hur jag ska komma vidare!

Jens

Det låter väldigt konstigt i o m att DHCP är något som ska vara likadant oavsett OS.

Frågan är om det blir konflikt mellan er DHCP och DHCP på nätet utanför.

I o m att Mac mini bara har ett nätverkskort kan den ju inte agera brygga/gateway mellan näten. Vad har ni för typ av gateway mellan näten?

Hej!

Jo, jag har kompletterat med en USB-Ethernet-adapter (Apple, HUR svårt ska det vara med två ethernet-portar?!) så att den kan fungera som brygga. Den har fått ett IP-nummer från nätet den står i, som råkar vara ett 192-nummer, och sedan skapar den med NAT och DHCP ett nytt 192-nät under som vi har våra datorer och skivare i på vår avdelning. Det är ingen ortodox lösning, men efter mycket övervägande valde vi denna.

Men visst är det konstigt att alla möjliga enheter snyggt får IP-nummer av DHCP-servern, men inte Windows-burkarna. Se inte logiken i detta.

Ursprungligen av jensohlsson:

Hej!

Jo, jag har kompletterat med en USB-Ethernet-adapter (Apple, HUR svårt ska det vara med två ethernet-portar?!) så att den kan fungera som brygga. Den har fått ett IP-nummer från nätet den står i, som råkar vara ett 192-nummer, och sedan skapar den med NAT och DHCP ett nytt 192-nät under som vi har våra datorer och skivare i på vår avdelning. Det är ingen ortodox lösning, men efter mycket övervägande valde vi denna.

Men visst är det konstigt att alla möjliga enheter snyggt får IP-nummer av DHCP-servern, men inte Windows-burkarna. Se inte logiken i detta.

Testa att skapa ett A- eller B-nät (10... eller 172...) och se om det löser problematiken? Näten ska ju inte ha samma nätmask och den risken undviker ni ju helt om ni kör ett nät av en annan klass.

Tack! Ska prova!

  • Medlem
  • Karlskoga
  • 2012-06-19 22:43

Jag antar att du har testat IPCONFIG -RELEASE och IPCONFIG -RENEW på Windowsmaskinerna? De kan vara lite tröga att få att släppa konfigurationen ibland....

1
Bevaka tråden