Server med dynamisk ip, hur?

Tråden skapades och har fått 11 svar. Det senaste inlägget skrevs .
1
  • Oregistrerad
  • 2003-09-16 13:57

Jag har ett dynamiskt ip-nummer på en (usel) telia-lina och vill ha en server hemma. Jag har hört att det går att lösa med någon tjänst, men hur? Är det dyrt? (Blev erbjuden BBB 3 månader efter att jag skrev 12-månaders kontrakt med telia, tyck synd om mig )

  • Oregistrerad
  • 2003-09-17 01:22
Citat:

Skrevs ursprungligen av exzero
http://www.dyndns.org/

...det är gratis och fungerar utmärkt.

Sen får man fundera på hur tjänsterna i Macen hanterar dynamsik IP när den väl ändras.
Troligen bör du ha en NAT-router på framsidan som NAT:ar trafiken till en fast privat IP-adress på insidan.
Svensktillverkade brandväggen (med inbyggt ADSL-modem om man vill ha det) har dels stöd för automatisk inloggning och keep-alive hos alla svenska operatörer (inkl. Telia) samt har stöd för att vara DynDNS-klient.
Den har dessutom SIP-stöd om man är flitig användare av iChat AV.
Webmanagement har den också. Och numera kan man få den med ett trådlöst 802.11b-interface (AirPort) som ett "DMZ".

Precis så ja.
Men jag får det inte att fungerar trots att jag har en router som NAT:ar all trafik.
dyndns uppdateras som det ska med rätt IP-nummer från routern.
Port forwardingen pekas mot ett "fast" IP nummer på insidan.
Men när jag surfar mot min URL så går inte det. Ingen kontakt. Mot IP numret kan jag komma åt routerns admin del.
Men inget annat.

Vad gör jag för fel?

Min kedja är:
Netgear Rounter (tillika ADSL modem NG814 eller är det NB814) -> Airport (Äldsta modellen) -> iMac G4 (Apache påslaget kan surfa till den på LAN).

Jag har testat att portforwarda till Airporten och låta den för portforwardingen vidare till datorn. Det funkar inte. Har testat att slå av NAT i Airporten för att slippa två NATningar.
Men det hjälpte inte. Har testat lite allt möjligt faktiskt.

Men nej. Någon som har några tips?

Citat:

Skrevs ursprungligen av Mattias Hedman
Precis så ja.
Men jag får det inte att fungerar trots att jag har en router som NAT:ar all trafik.
dyndns uppdateras som det ska med rätt IP-nummer från routern.
Port forwardingen pekas mot ett "fast" IP nummer på insidan.
Men när jag surfar mot min URL så går inte det. Ingen kontakt. Mot IP numret kan jag komma åt routerns admin del.
Men inget annat.

Vad gör jag för fel?

Min kedja är:
Netgear Rounter (tillika ADSL modem NG814 eller är det NB814) -> Airport (Äldsta modellen) -> iMac G4 (Apache påslaget kan surfa till den på LAN).

Jag har testat att portforwarda till Airporten och låta den för portforwardingen vidare till datorn. Det funkar inte. Har testat att slå av NAT i Airporten för att slippa två NATningar.
Men det hjälpte inte. Har testat lite allt möjligt faktiskt.

Men nej. Någon som har några tips?

Om det är så att routern har management på port 80 och du försöker NAT:a port 80 till servern kanske den inte fattar det, och tror att det är en managementsession.
Kan du ändra managementport?
AirPorten bör du använda i bryggläge tillsammans med den andra. NAT på NAT blir aldrig bra.

Det funkar inte att komma åt din URL innifrån om du använder nat i din router för att hänvisa port 80 till din "interna" maskin. Skriver du din www adress hamnar du bara i din egen router.

För att NAT ska funka måste du gå genom två interface, trafiken måste alltså komma från internet genomdin router och ut på din locala interface.

Citat:

Skrevs ursprungligen av lilledanne
Det funkar inte att komma åt din URL innifrån om du använder nat i din router för att hänvisa port 80 till din "interna" maskin. Skriver du din www adress hamnar du bara i din egen router.

För att NAT ska funka måste du gå genom två interface, trafiken måste alltså komma från internet genomdin router och ut på din locala interface.

Helt riktigt! Jag tänkte inte på den fallgropen.
LITE lustigt att routern slänger upp sin managementsida dock, eftersom destinations-IP-adressen är dess yttre interface där den förhoppningsvis inte har management.
Men det är troligt vis detta som är problemet.

Ahh glömde skriva det att Admin delen får på en helt annan port så det är inte så att det krockar.
Den går på en valfri port som jag valt. För att vara extra övertydlig har jag inte valt port 80.

Nej NAT på NAT blir aldirg bra men jag har testat lite allt möjligt nu för att de ska gå igång.
Så nu låter jag Netgearen sköta allt. Inkl NAT och Portfowarding.

Netgearen sköter också om kontakten med dyndns. Den fungerar perfekt.

Visst fattar jag varför det funkar via LAN men det är just att få det att funka från vida världen som jag undrar över. Jag har satt upp dyndns tjänster på flera andra ställen och aldrig fått dessa problem. Men då har jag å andra sidan inte haft en Airport emellen... men det måste väl funka ändå?
Är det någon som kör så?

Jag har även provat att lägga till Portfowarding i Airporten med eller utan NATning men ingen skillnad.

Man skulle kunna säga att jag testat allt utom det rätta.

Mer hjälp tack!

  • Oregistrerad
  • 2003-09-17 16:22

Jag är glad över svar 1 och 2, sen fattar jag ingenting om vad ni snackar om..! Jag får testa på och sedan komma tillbaka hit och läsa mer!

Pontus...

  • Oregistrerad
  • 2003-09-18 21:30
Citat:

Skrevs ursprungligen av HankPank
...det är gratis och fungerar utmärkt.

Hej. Har skaffat dns.org. Har lite liknande problem som i den här tråden.
Dvs WebServern funkar som intranet men är inte sökbar från internet.

Info:
OSX10.2.6/Telia ADSL/ 2 datorer till en aktiv switch/ switchen till ADSL modemet.

Vad jag bl.a undrar, vilken IP ska jag egentligen regga på dns.org?

Ibland kommer jag nämligen till modemets "hemsida" istället för min sight. Jag har "styrt" modemets IP nr (utsida) till datorns IP (insida) i nätverksinställningar i modemet.
Är det bra?
Har ingen aktiv firewall igång i datorn.

Personal Websharing är på. Inget annat.

Någon som är bra på det här får gärna höra av sig. Det verkar som om det inte ska vara så -himla- svårt bara man fattar:)

Jag är tämligen ny på OSX (ett par veckor)

mvh
Lennart

1
Bevaka tråden