dela internet osx-->9.2

Tråden skapades och har fått 14 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • 2003-09-15 14:29

jag har problem. Jag försöker dela internet från en iMac G4 10.2.6 till en Lombard med 9.2. Jag får internet via airport med följande inst:

och har försökt läsa mig till hur man ställer in resten av datorn. Ethernetisnt ser ut så här:

på mottagardatorn ser tcp/ip-inst ut så här:

Resultatet blir att jag kan ansluta till Lombarden från iMacen, men Lombarden får inte tillgång till internet. Hur fasen gör man? Jag är väl medveten om att jag kan ha gjor grava fel i inst, men jag begriper inte bättre...

edit: varför fungerar inte bilderna i inlägget? Måste klicka på länkarna.

  • Medlem
  • Bollnäs
  • 2003-09-16 10:41

Jag har ingen airport själv, så jag vet inte exakt hur inställningarna för den ser ut. Men rent schematiskt är det mindre svårt att förklara.

Det du behöver göra är att ställa in airportbasstationen på att vara router. Alternativt som brygga om du har en annan router. Vad du än använder måste routern ha två ip-nummer. Dels det som du får av din internetleverantör, dels ett lokalt som du bestämmer själv. Jag ser att du använder 192.168.0.x serien, vilket är bra.

Sen måste routern konfigureras för »IP forwarding« (eller vad det nu heter i just din konfiguration), så att trafik slussas mellan routerns publika och interna IP.

Efter det ställer du in alla maskiner lokalt att använda den lokala IP-serien (192.168.0.x).

Exempel:
IP: 192.168.0.10
Delnätsmask: 255.255.255.0
Router: 192.168.0.1
DNS: 192.168.0.1

Alternativt kan du använda samma DNS lokalt som routern har inställt. Vissa routrar fixar inte »DNS forwarding« som de ska.

Se schemat nedan för en idé om hur jag menar.

  • Medlem
  • 2003-09-16 11:58

uff, det var en imponerande redogörelse. Men mitt system ser inte riktigt ut så. Jag har ingen basstation, utan sitter som klient i ett lokalt nät, där basstationen servar alla bredbandskunder i samma system. Basstationen sitter på ett vattentorn och är ootkomlig för mig.

Jag har en insignal via airport. Airportkortet motsvarar modemet i en "vanlig" uppkoppling. Datorn, en iMac G4, har förstås en ethernetkontakt, till vilken jag har kopplat en Lombard. Jag har inga routrar eller servrar eller annat.

Till saken hör att jag kan mounta Lombarden på iMacen men inte tvärtom. Lombarden får ingen kontakt med internet.

  • Medlem
  • Bollnäs
  • 2003-09-16 12:53

Principen är ändå densamma.

Datorn med airportkortet blir i ditt fall router. Det vill säga en dator med två nätverkskort, ett publikt och ett internt. Du kan göra på två sätt:

1. Låt inställningarna på airportkortet vara som de är (förutsatt att det funkar att surfa på den datorn). Koppla in en hubb i ethernetuttaget på samma dator. Slå igång internetdelning i Systeminställningarna. Koppla in alla övriga datorer som ska ha internet i hubben, och ställ in TCP/IP på DHCP-server.

2. Installera en routerprogramvara på en av datorerna som har både kontakt med internet och de lokala nätverket. Väljer du detta blir det genast lite joxigare, men inte oöverkomligt.

Varför du kan se alla datorerna lokalt, men inte har internet på alla beror på två finurliga saker. Dels Appletalk, dels Rendezvous.

  • Medlem
  • Gävle
  • 2003-09-16 13:09

Men 10.2.6 har ju inbyggd routerprogramvara.
I Systeminställningar, Fildelning finns "Internetdelning" använd den så borde det ju lösa sej.

  • Medlem
  • Bollnäs
  • 2003-09-16 14:17
Citat:

Skrevs ursprungligen av Creops
Men 10.2.6 har ju inbyggd routerprogramvara.

Som jag påpekade i mitt tidigare inlägg under punkt 1.

  • Medlem
  • Gävle
  • 2003-09-16 15:36
Citat:

Skrevs ursprungligen av Kalle W
Som jag påpekade i mitt tidigare inlägg under punkt 1.

Ahh, ledsen där, läste lite slarvigt. Hade precis fått 80 kontakter i mobilen raderade av iSynk.. fint program det där.. :-/

  • Medlem
  • 2003-09-16 16:11

jo, internetdelning är på, men det kvittar. Om det bara är en dator som ska få internet av "huvuddatorn" så ska väl ingen hub behövas?! Jag har bara en korsad kabel.

  • Medlem
  • Bollnäs
  • 2003-09-16 19:34

Koppla en sladd mellan datorn med internetdelning igång (nr 1) och datorn du vill ha delat internet på (nr 2). På dator nr 2 ser du till att ha DHCP igång. Kolla så att du får ett IP i serien 192.168.2.x tilldelat från nr 1.

Nu ska det bara vara att surfa på.

  • Medlem
  • 2003-09-17 11:41

Jag fattar inte. Vilka siffror ska in i vilka fält och vilka fält är ointressanta?

  • Medlem
  • 2003-09-17 11:42

och här:

Ändra i fliken "konfigurera" till DHCP så ska det funka. Du behöver inte fylla i något nånstans. På Lombarden alltså, anstar att det är den som kör OS 9.

  • Medlem
  • 2003-09-17 12:50

fungerar inte. Apples enkla lösningar på nätverk har i mitt fall alltid slutat med att det inte fungerar.

  • Oregistrerad
  • 2003-09-17 13:59

Försök igen, ska fungera. Lyckade med liknande häromdagen fast med modem i stället för Airport. Använde också korsad TP-kabel, ingen hub.

iMac:en
- 2 aktiva nätverksportar, airport samt ethernet.
- Internetdelning på för aktiv anslutning över Airport.
- Airport-inställningen ska vara som du har den (om det fungerar)
- Ethernet-inställningen ser ok ut förutom DNS-servrar? Lämna blankt eller ange 10.0.0.1 samt 10.0.0.2. Man kan aldrig ange routern som DNS vad jag vet?!?

Kalle W, vad menar du med "DNS forwarding"?

PowerBook:en
- TCP/IP. Anslut via: Ethernet. konfigurera: DHCP. Nameserveradress, här måste man ange samma som Airportens DNS vad jag förstår dvs 10.0.0.1 och 10.0.0.2 i ditt fall.

På PowerBook:en körde jag iofs OS X men OS 9 ska fungera även om DHCP är lite meckigare. Har dock för mig att jag inte fick samma subnät som iMac:ens ethernet-inställning men det spelar mindre roll. Gick hur bra som helst att surfa och maila via iMac:en fast barnen satt där och spelade...

  • Medlem
  • 2003-09-17 14:40

snart ger jag upp... Tack för att ni orkar bry er, men den här djävla skiten står mig upp i halsen (utan att fungera). Vaffan är detta?

1
Bevaka tråden