Problem med PMC 0.9.5.2 - crash @ startup

Tråden skapades och har fått 2 svar. Det senaste inlägget skrevs .
1

Har precis installerat Plexklienten 0.9.5.2 på min MBP, men kommer inte ens så långt att applikationen startar upp innan jag får en stackdump.

Senaste Flash, OSX Lion. Något annat som kan ställa till det hela?

Jag har ingen server installerad lokalt, men det var väl det som var hela vitsen med spliten i 0.9.5?

Googlande visar bara på att en del haft crashproblem med servern, men jag hittar inga liknande krascher för klienten...

Edit:
När jag istället installerar gamla 0.9.3.4 fungerar det som en dans...

MVH

/Jonas

******

Process: Plex [468]
Path: /Applications/Plex.app/Contents/MacOS/Plex
Identifier: com.plexapp.plex
Version: 0.9.5.2 (0.9.5.2-06ca164)
Code Type: X86 (Native)
Parent Process: launchd [114]

Date/Time: 2012-05-03 22:43:52.811 +0200
OS Version: Mac OS X 10.7.3 (11D50b)
Report Version: 9

Interval Since Last Report: 392047 sec
Crashes Since Last Report: 7
Per-App Interval Since Last Report: 16 sec
Per-App Crashes Since Last Report: 6
Anonymous UUID: F76395E7-88C9-4902-AFF0-D9658460DB20

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
objc[468]: garbage collection is OFF
abort() called

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 libsystem_kernel.dylib 0x935549c6 __pthread_kill + 10
1 libsystem_c.dylib 0x969fdf78 pthread_kill + 106
2 libsystem_c.dylib 0x969eebdd abort + 167
3 com.plexapp.plex 0x00030010 CApplication::FatalErrorHandler(bool, bool, bool) + 94
4 com.plexapp.plex 0x00030931 CApplication::Create() + 2159
5 com.plexapp.plex 0x004fb84f SDL_main + 1245
6 com.plexapp.plex 0x0041992e main + 1897
7 com.plexapp.plex 0x00010125 start + 53

Thread 1:
0 libsystem_kernel.dylib 0x9355483e __psynch_cvwait + 10
1 libsystem_c.dylib 0x969ffe21 _pthread_cond_wait + 827
2 libsystem_c.dylib 0x969b042c pthread_cond_wait$UNIX2003 + 71
3 com.plexapp.plex 0x003af6af void boost::condition_variable_any::wait<boost::mutex>(boost::mutex&) + 75
4 com.plexapp.plex 0x003af32d PlexMediaServerQueue::Process() + 143
5 com.plexapp.plex 0x00464a07 CThread::staticThread(void*) + 225
6 libsystem_c.dylib 0x969fbed9 _pthread_start + 335
7 libsystem_c.dylib 0x969ff6de thread_start + 34

Thread 2:: Dispatch queue: com.apple.libdispatch-manager
0 libsystem_kernel.dylib 0x9355590a kevent + 10
1 libdispatch.dylib 0x97395c58 _dispatch_mgr_invoke + 969
2 libdispatch.dylib 0x973946a7 _dispatch_mgr_thread + 53

Thread 3:
0 libsystem_kernel.dylib 0x9355502e __workq_kernreturn + 10
1 libsystem_c.dylib 0x969fdccf _pthread_wqthread + 773
2 libsystem_c.dylib 0x969ff6fe start_wqthread + 30

Thread 4:
0 libsystem_kernel.dylib 0x9355502e __workq_kernreturn + 10
1 libsystem_c.dylib 0x969fdccf _pthread_wqthread + 773
2 libsystem_c.dylib 0x969ff6fe start_wqthread + 30

Thread 5:
0 libsystem_kernel.dylib 0x9355502e __workq_kernreturn + 10
1 libsystem_c.dylib 0x969fdccf _pthread_wqthread + 773
2 libsystem_c.dylib 0x969ff6fe start_wqthread + 30

Thread 6:
0 libsystem_kernel.dylib 0x9355502e __workq_kernreturn + 10
1 libsystem_c.dylib 0x969fdccf _pthread_wqthread + 773
2 libsystem_c.dylib 0x969ff6fe start_wqthread + 30

Thread 0 crashed with X86 Thread State (32-bit):
eax: 0x00000000 ebx: 0x00890590 ecx: 0xbffff6dc edx: 0x935549c6
edi: 0xacba22c0 esi: 0x00000006 ebp: 0xbffff6f8 esp: 0xbffff6dc
ss: 0x00000023 efl: 0x00000246 eip: 0x935549c6 cs: 0x0000000b
ds: 0x00000023 es: 0x00000023 fs: 0x00000000 gs: 0x0000000f
cr2: 0x00711b60
Logical CPU: 0

<snip>

Senast redigerat 2012-05-03 23:03

Jag vet att det finns en tråkig bugg där klienten kraschar ifall ditt myPlex-konto har en tom kö.
Alltså, installera PlexIt, gå till Youtube (eller liknande) och lägg till en video i din kö.

0.9.5.3 löser problemet utan att man behöver använda sig av myPlex överhuvudtaget.

1
Bevaka tråden