iMac 27" visar en badboll och låser sig

Tråden skapades och har fått 19 svar. Det senaste inlägget skrevs .
1

Har en iMac 27" Late 2009. Den interna hårddisken kraschade 2011, ersatte den då med en SSD. Körde så i ett par månader och ersatte sen superdriven med en mekanisk HDD (skiftade SSD och HDD).

Har fungerat helt utan problem. Men nu ca två månader senare så börjar datorn badbolla, och när den gör det så låser sig systemet helt. Jag kan röra muspekaren och klicka på lite öppna fönster, men det enda som datorn svarar på är att stänga av den med Power-knappen.

Felet uppvisar sig nästan helt sporadiskt, ibland 5 minuter efter omstart, ibland en timme efter omstart. Inget speciellt program som belastar utan kan ske lite hur som helst.

Jag vill gärna tro att det är ett mjukvarufel då datorn inte har uppvisat några tendenser till fel tidigare.
Har provat att kontrollera skivbehörigheterna och reparerat dessa men det hjälpte inte.

Några mer tips innan jag installerar om Lion?

Ett enkelt grepp som kan hjälpa är att jucka lite på minneskretsarna och att eventuellt prova dem en och en. Om minnet är kaputt får man den här effekten. Hårddisk-paj ger också detta fenomenet.

Okej, minnena är en sak som är relativt enkel att prova. Hur är det med hårddiskarna, finns det något program som kan kontrollera dem?

Och om det nu är ett fel på hårddisken, innebär då det automatiskt att det är på systemdisken (SSD) det är fel på eller kan det även vara lagringsdisken?

Systemdisken är en Crucial M4 128GB SSD som jag bara haft i max 6 månader.
Lagringsdisken är en Seagate 2TB 5900RPM 3.5" och den har jag haft i max 2 månader.

Ursprungligen av radaradam:

Okej, minnena är en sak som är relativt enkel att prova. Hur är det med hårddiskarna, finns det något program som kan kontrollera dem?
Och om det nu är ett fel på hårddisken, innebär då det automatiskt att det är på systemdisken (SSD) det är fel på eller kan det även vara lagringsdisken?
Systemdisken är en Crucial M4 128GB SSD som jag bara haft i max 6 månader.
Lagringsdisken är en Seagate 2TB 5900RPM 3.5" och den har jag haft i max 2 månader.

Kan du se ett mönster i när dessa problem uppstår? T.ex. när du öppnar vissa filer som är lagrade på en speciell plats. I så fall kan du ju säkert få en större träffsäkerhet i vilken hårddisk som dras med problemet - om det beror på en av dina hårddiskar.

Alternativet är väl att du för över en exakt kopia av systemet från SSD till den mekaniska disken och startar upp från den för att se om problemet kvarstår. Även då har ju en större träffsäkerhet att se om problemet beror på en av dina hårddiskar.

Nu är jag ingen expert, men jag tror bestämt att systemet kan hänga sig oavsett vilken av diskarna som är behäftad med ett problem.

Ursprungligen av pmarriott:

Nu är jag ingen expert, men jag tror bestämt att systemet kan hänga sig oavsett vilken av diskarna som är behäftad med ett problem.

Det är mer än vad jag känner till, men utesluter inte att du har rätt.

Nej inget mönster alls. Uppstår när jag slösurfar och lyssnar på musik via spotify. Håller på och klonar systemdisken till en extern disk nu, sen boota från klonen, formatera SSD och klona tillbaka den. Om inte det funkar så provar jag en ominstallation av Lion.

Och om inte det funkar börjar jag med RAM-minnena.

  • Medlem
  • Stockholm
  • 2012-03-28 13:28

Har du kollat diskarna med Skivverktyg?

  • Medlem
  • Stockholm
  • 2012-03-28 13:08

Hur mycket RAM-minne har du? Badbollar brukar försvinna då man bygger ut internminnet. Om du har för lite RAM-minne använder din Mac hårddisken som virtuellt minne och den är mycket långsammare än RAM-minne, därav badbollar. Öppna programmet Aktivitetskontroll som ligger i Verktygsmappen. Klicka på Systemminne nertill. Då kommer du att se hur mycket virtuellt minne du använder. För en riktigt snabb Mac ska du inte ha något virtuellt minne alls. Bytte nyligen minne på en kompis MacBook till 8 GB. Badbollarna försvann.

Senast redigerat 2012-03-28 13:18
Ursprungligen av Joel:

Hur mycket RAM-minne har du? Badbollar brukar försvinna då man bygger ut internminnet.

Jag har 8GB, och det har jag haft sen 2009. Installerade 4GB själv samma dag jag fick datorn.

Det är inte bara som så att den badbollar, utan datorn hänger sig helt när badbollen visar sig. Och det enda som svarar är muspekaren som jag kan flytta runt. Ingen badboll har synts till innan det här uppstod (igår).

  • Medlem
  • Stockholm
  • 2012-03-28 13:26

Du kan också starta från orginal-installationsdisken som bör gå att starta i verktygsläge eller liknande (håll nere alttangenten direkt efter startljudet) där man kan göra en total hårdvarukoll.

Ska provas!

Ursprungligen av Joel:

Har du kollat diskarna med Skivverktyg?

Ja, inget lustigt där.

  • Medlem
  • Stockholm
  • 2012-03-28 13:41

Ok, om inte det löser sej med hårdvarukoll som jag vet att en Mac tekniker jag känner låter gå en hel natt, måste det vara fel på ditt system. För över hela din disk till en extern hårddisk, bygg upp ett helt nytt system och för över dina program och filer med Flyttassistenten. Den tar alla dina filer lösenord inställningar m.m. så du kommer att vara tillbaks i din egen miljö, men med ett friskt System.

http://www.99.se/macbook/262546-testa-ramminne-hur-i-osx-med-gui-tack.html

Denna tråden verkar beskriva exakt samma problem som jag upplever.

Jag vet inte om det kan vara något men en tanke.
När jag bootat från min klonade USB-disk och höll på att klona tillbaka till systemdisken (SSD) så unmountades plötsligt SSD-disken under kloningen.
Kan det vara som så att systemdisken tidigare plötsligt "disconnectats" och systemet då hängt sig?

  • Medlem
  • Stockholm
  • 2012-03-28 15:48

Jag brukade klona med CCC eller SuperDuper men Jag fick alltid mer problem än om jag gjorde en nyinstallation och använde Flyttassistenten för att föra över allt från min gamla hd.

Ursprungligen av Joel:

Jag brukade klona med CCC eller SuperDuper men Jag fick alltid mer problem än om jag gjorde en nyinstallation och använde Flyttassistenten för att föra över allt från min gamla hd.

Har gjort en backup med Time Machine och ska göra en ren ominstallation i morgon.

Streamade en hel fotbollsmatch utan att datorn låste sig. Men krävdes tre omstartarter för att skriva detta. Måttligt irriterande att jag inte kan se något mönster i det hela.

Har formaterat min SSD och installerat om Lion nu, använde mig av flyttassistenten för att föra tillbaka alla program, funkade mycket bra.
Återstår att se om det har botat felet.

Edit: Det gjorde det inte. Då är det dags att plocka ur ram-minnet.
Edit2: Har provat alla ramstickor, kört memtest på dem och de visar OK. Och datorn hänger sig ändå så inte där felet ligger.

Hur sjutton tar man reda på vilken hårddisk det är som felar?
Mar 29 17:54:12 Adams-iMac.local SMARTReporter[340] <Info>: Drive: 'ST2000DL003-9VT166 (2TB | 6YD1JC67 | disk1)' Status: SMARTOK (S.M.A.R.T. statusen ej överskriden, disken OK)
Mar 29 17:54:12 Adams-iMac.local SMARTReporter[340] <Info>: Drive: 'M4-CT128M4SSD2 (iMac | 0000000011240311F667 | disk0)' Status: SMARTOK (S.M.A.R.T. statusen ej överskriden, disken OK)

Senast redigerat 2012-03-29 17:57

Kan vara så att jag har hittat en lösning nu.

Visade sig att det fanns en bugg i Crucial M4 SSD som gjorde att hårddisken hängde sig efter 5184h uptime. Och därefter fortsätter att hänga sig en gång i timmen.

Ett jäkla jobb att plocka ur SSD ur iMacen, montera den i en vanlig PC-laptop, uppdatera firmware från 0002 till 0309. Återstår nu att se om det var lösningen.

Edit: För kännedom så verkar detta ha varit lösningen på problemet.

Senast redigerat 2012-03-30 17:13
1
Bevaka tråden