plex gör inte som jag vill

Tråden skapades och har fått 43 svar. Det senaste inlägget skrevs .
  • Medlem
  • 2012-03-24 15:06

förstår inte riktigt hur folk kan höja plex till höjderna..

när man gör en scanning så är det ofantligt många serier/filmer som får väldigt fel info (även fast de är med i t.ex tvdb)
och ändrar man infon manuellt så är det inte alltid det händer något (dvs att den ändrar sig)

och ibland lägger den upp två olika tv-serier t.ex (som just nu har jag t.ex 2st varianter av known universe och två varianter av death valley och två varianter av the river)
t.ex att avsnitt 1-6 ligger i den första och 7-12 i den andra.

och korrigerar jag allt manuellt så händer inte ett jota.. de ligger fortfarande kvar som två olika tv-serier

sen om man tar bort en film t.ex från disken så försvinner inte den automatiskt från listan efter nästa scanning utan får bara en gul triangel på sig istället. (boxee t.ex plockar bort sådant automatiskt som inte längre finns på disken)

och försöker man ta bort de filmer som har gula trianglar för att de inte finns längre så går det inte.. ibland försvinner de inte och ibland så är funktionen att ta bort gråmarkerad och går ej att klicka på.

någon som förstår sig på varför det är så och om det ens går att lösa eller är det bara så att plex är oerhört buggigt?

här är två exempel på dels en sak som inte försvinner fast den inte finns på disken längre samt ej går att ta bort manuellt samt två "versioner" av en serie med ett par avsnitt i den ena och resten i den andra (som efter manuell ändring fortfarande är två olika)

och fastän jag läser överallt att plex skall klara av BDMV (rena bluray "kopior") så får jag bara upp massvis av sådana här "ikoner" när jag gör en scanning. (detta är en enda film alltså)

la även märke till att den av någon anledning lägger till sample-filer också.
som t.ex a serbian movie la han till två "ikoner" av, den ena är filmen och den andra är sample som ligger i den mappen.

Senast redigerat 2012-03-24 21:23

Vad gäller att den styckar upp en serie, kika på vad filerna har för namn. Jag har för mig att det kan spöka, dock lite osäker så lyssna på någon annan om någon säger annat.

Gällande att den inte raderar sådant som inte finns kvar är det en inställning som du hittar under inställningar för Plex Media Server (hittar den i listen där uppe). Den heter "Empty trash automaticly after every scan" och finns under fliken "Library".

  • Medlem
  • 2012-03-24 20:41

alla filer heter exakt likadant (förutom t.ex episode-infon som e01s01 eller e02s01 osv)

ok, tack för infon ang raderingen.
kom dock på mig själv att den där "radera metadata-matchning" kanske inte är en radering av själva "ikonen". och om inte, hur raderar man isåfall?
har även provat att ställa in som du sa i inställningar men efter en ny "sökning"/syncning så tar han ändå inte bort ikonerna.. (tog bort en film nu från hårddisken för att prova)

hoppas någon mer vänlig själ har svar på alla de övriga frågorna i mitt första inlägg.

Senast redigerat 2012-03-24 21:27
  • Medlem
  • Karlskoga
  • 2012-03-25 22:24

Det ska nog vara s före e, men du kanske skrev fel? Eller det kanske inte spelar någon roll heller....
Har du lagt alla s01 i Season 1, och alla s02 i Season 2 också?
Jag har aldrig sett gula trianglar på min PLEX under de minst två åren jag har kört det. Och ändå är mitt biliotek runt 8 TB.

Oj vad struligt du verkar ha fått till det. Jag tror dock vi snabbt ska få ordning på de största frågetecknen.
Först och främst så är det så att om du tar bort något från disken så raderas ej själva objektet i Plex. Anledningen är enklare än du tror. Om Plex Media Server (PMS) skulle radera ett objekt varje gång som PMS inte hittar själva filen så skulle folk med filmerna på externa enheter/NAS bli väldigt frusterade. Ponera att du glömt koppla in din externa enhet, eller glömt montera upp ditt NAS... då skulle PMS automatiskt ta bort serien/filmen direkt. Det kanske inte låter som en tragedi direkt, men tänk på att all metadata (som du kanske manuellt lagt dit) och watched-status och liknande skulle försvinna. I långa loppet är det ohållbart.

Så, för att ta bort något från Plex så går du helt enkelt ut till din disk och tar bort filmen. Sedan så refreshar du din sektion som innehöll filmen/serien. Då kommer objektet få en gul triangel på sig i Plex. Den triangeln visar att den "fysiska" länken är bruten. Alltså, PMS hittar inte videofilen där den låg tidigare. Då du ser en sådan triangel och du vet att du raderat objektet så är det bara att gå in i din PMS-sektion och trycka på papperskorgen (som grabbarna ovan nämnde).
Jag tror att då du gör det så kommer de flesta av dina problem att lösa sig.

Jag vet inte vilka av dina problem som kommer kvarstå efter att du gör ovanstånde, och jag är sugen att invänta ord från dig på var som kvarstår, men här är några svar som kanske hjälper:

* Om du inte vill att sample-filer ska synas i Plex så måste sample-filen på disk innehålla order "sample".
* BluRay-stödet är inte helt perfekt. Det rekommenderas att du gör en mkv eller mp4-fil av den. Det kan du enkelt göra utan att tappa en enda gnutta kvalitet med t.ex. MakeMKV som du hittar om du googlar efter det.

  • Medlem
  • 2012-03-26 17:46

ja det har allt blivit en del strul sedan jag började prova på plex
tur det finns en vänlig guru här som ställer upp!

ja men det låter ju faktiskt vettigt att den inte plockar bort då.
och mycket riktigt så försvinner objekten från plex efter man gjort som du skrev.

dock löste det inga andra problem,

sample-filen heter t.ex sample, men ändå dyker den upp som en film

ser dock nu att den trodde att det var filmen "sample". men borde den inte inse att det är ett sample?
eller är det bara för att just den filen _bara_ heter sample och inget annat?

blu-ray filmerna blir flera olika objekt där någon får rätt info och resten blir "gråa" med namn som 00008 osv (och startar man filmen på den som ser rätt ut så är det oftast så att den startar mitt i filmen eller liknande) men om det är som du säger att blu-ray stödet inte är bra på plex så förklarar ju det saken. tyvärr är en "omkodning" eller liknande av filmen ej aktuellt för mig.

utöver det så är väl de två största irritationsmomenten just nu att:

den hittar inte filmer som finns på t.ex imdb (eller tror att det är en helt annan film och ger den den infon)
filmerna är då helt korrekt namngivna (och ingen skillnad på dem och de som blir rätt/hittas)

tv-serier får flera "objekt" som t.ex the river, death valley, alcatraz och known universe även fast de har helt korrekta namn
som t.ex The.River.S01E07.720p.HDTV.X264-DIMENSION (ursäkta om det är emot reglerna att skriva ett releasenamn)
så hamnar alltså t.ex avsnitt 1-6 i ett objekt och resterande avsnitt i den andra.

Ursprungligen av tqila:

ja det har allt blivit en del strul sedan jag började prova på plex
tur det finns en vänlig guru här som ställer upp!

ja men det låter ju faktiskt vettigt att den inte plockar bort då.
och mycket riktigt så försvinner objekten från plex efter man gjort som du skrev.

dock löste det inga andra problem,

sample-filen heter t.ex sample, men ändå dyker den upp som en film
[ATTACH="CONFIG"]32691[/ATTACH]
ser dock nu att den trodde att det var filmen "sample". men borde den inte inse att det är ett sample?
eller är det bara för att just den filen _bara_ heter sample och inget annat?

blu-ray filmerna blir flera olika objekt där någon får rätt info och resten blir "gråa" med namn som 00008 osv (och startar man filmen på den som ser rätt ut så är det oftast så att den startar mitt i filmen eller liknande) men om det är som du säger att blu-ray stödet inte är bra på plex så förklarar ju det saken. tyvärr är en "omkodning" eller liknande av filmen ej aktuellt för mig.

utöver det så är väl de två största irritationsmomenten just nu att:

den hittar inte filmer som finns på t.ex imdb (eller tror att det är en helt annan film och ger den den infon)
filmerna är då helt korrekt namngivna (och ingen skillnad på dem och de som blir rätt/hittas)

tv-serier får flera "objekt" som t.ex the river, death valley, alcatraz och known universe även fast de har helt korrekta namn
som t.ex The.River.S01E07.720p.HDTV.X264-DIMENSION (ursäkta om det är emot reglerna att skriva ett releasenamn)
så hamnar alltså t.ex avsnitt 1-6 i ett objekt och resterande avsnitt i den andra.

Du har så mycket fel så jag misstänker något grundläggande fel i din uppsättning. Och eftersom din sample-fil blir upplockad också så lutar det åt att du satt fel primär Metadata-agent eller fel Media Scanner. Skulle du kunna titta igenom en av mina howto-filmer som jag la upp för dryga året sedan? Den går igenom grunderna, och det är möjligt att du missförstått något. Just nu vet jag inte exakt vad du kan ha missförstått.
Här är videon (och försök att inte skratta ihjäl dig då du lyssnar på min brutna engelska )

Okänt videoformat "vimeo".

Om jag ska drista mig till en gissning så har du satt din filmsektion till att antingen använda "Plex video files scanner" som "Media Scanner", eller så har du satt din Primära Metadata-agent till "Personal Media". Båda två är fel i ditt fall.

Då det gäller dina tv-serier så skulle jag gissa att du har gjort fel i mappstrukturen. Skulle du kunna ta en screenshot som visar exakt hur HELA strukturen ser ut för en tv-serie som strular för dig?

PS: Du använder väl Plex 0.9.5.X-serien?

  • Medlem
  • 2012-03-27 18:43

förstod inte riktigt hur jag ska ändra primär metadata-agent då videon tar upp en version som är äldre och ej heller har samma GUI i menyerna.

ah, hittade nog nu, men som du ser så verkar det vara rätt även där.

så här ser det iallafall ut i min meny för agenterna (allt är som du ser ikryssat och så även på de andra två, samt att några av dem är "greyed out" men ikryssade även dem)
ska väl tillägga att jag kört allt "standard" vid installation och inte modifierat något/lagt till något/tagit bort något.

så här ser min mappstruktur ut i en av tv-serierna som får två "objekt" i plex.

och ja, jag använder den versionen av plex.

Tack för det. Dock så visar du nu bara bottenlagret i mappstrukturen då det gäller tv-serier. Hur ser de tidigare lagren ut? Vad ligger de där filerna i för mapp? Och mappen innan?

Då det gäller filmer så ser allt korrekt ut. Det hela känns väldigt underligt. Hmm. Har du provat döpa om sample-filen så den heter till exempel: "<filmnamnet>-sample.mkv" och kört en forced refresh av sektionen? Du hittar info om hur du gör en forced refresh genom att titta här: PlexNine PMS MediaManager - Plex

  • Medlem
  • 2012-03-28 18:44
Ursprungligen av Daniel Eriksson:

Tack för det. Dock så visar du nu bara bottenlagret i mappstrukturen då det gäller tv-serier. Hur ser de tidigare lagren ut? Vad ligger de där filerna i för mapp? Och mappen innan?

Då det gäller filmer så ser allt korrekt ut. Det hela känns väldigt underligt. Hmm. Har du provat döpa om sample-filen så den heter till exempel: "<filmnamnet>-sample.mkv" och kört en forced refresh av sektionen? Du hittar info om hur du gör en forced refresh genom att titta här: PlexNine PMS MediaManager - Plex

oj, sorry. här kommer en bättre skärmdump

det konstiga är att jag har fler sample's som bara heter sample i filnamnet, så varför just denna ska ha fått ett objekt i plex förstår jag inte
(dock verkar detta vara enda sample som har ett ! i slutet, kanske är det?)

provar en tvingad omsökning nu så återkommer när den är klar och säger resultatet
edit: nu försvann sample-objektet från plex.

Senast redigerat 2012-03-28 19:22
  • Medlem
  • Karlskoga
  • 2012-03-28 17:30

Varför har S01E01, S01E02 och S01E08 egna mappar? Har du subtitles där?

  • Medlem
  • 2012-03-28 18:47
Ursprungligen av kenjon:

Varför har S01E01, S01E02 och S01E08 egna mappar? Har du subtitles där?

stället där jag.. ehm, köper filmer/serier har som regel att man inte får lägga filmer/serier i mappar när man gör dem tillgängliga för.. köp
(med andra ord de vill inte ha massa skräp, samples,nfo.. whatever utan bara en filmfil (och då döpt rätt osv))

men av någon anledning så bestämde väl sig någon att lägga just dessa tre avsnitt i mappar iallafall.
så dessa ser alltså ut som en standard scene-release med en filmfil och nfo döpt enligt deras regler samt en mapp med sample enligt deras regler och även en .srt/subtitle-fil som jag själv lagt dit.

med andra ord ingen skillnad på dessa mappar emot vad om inte 100% så 90% av vad de flesta har.

men som du säger så är det just dessa tre avsnitt som ligger i ett av "objekten" i plex, dvs dubletten..
men varför det blir så på just dessa vet jag inte, för de är långt i från de enda som jag har så.. och ingen av de andra serierna som har det så har blivit så.

  • Medlem
  • 2012-03-29 19:00

har ett tillägg till min tråd och det är frågan om hur man sorterar objekten i plex?

många objekt ligger väldigt fel i bokstavsordningen, men det verkar bara vara sådana filmer/serier som börjar på "A", "An" eller "The", är det så att plex bortser från de orden i titlar när den sorterar?

och när jag ändå har din uppmärksamhet, du råkar inte ha någon insider-info om det är så att det kommer bli bättre stöd för blu-ray inom kort? (så att det listas rätt och inte blir dubletter på massa av filerna i blu-ray kopian)

jag menar boxee box har ju ett riktigt bra stöd för blu-ray så att inte plex skulle kunna få det "ganska lätt" låter ju orimligt

Ursprungligen av tqila:

har ett tillägg till min tråd och det är frågan om hur man sorterar objekten i plex?

många objekt ligger väldigt fel i bokstavsordningen, men det verkar bara vara sådana filmer/serier som börjar på "A", "An" eller "The", är det så att plex bortser från de orden i titlar när den sorterar?

och när jag ändå har din uppmärksamhet, du råkar inte ha någon insider-info om det är så att det kommer bli bättre stöd för blu-ray inom kort? (så att det listas rätt och inte blir dubletter på massa av filerna i blu-ray kopian)

jag menar boxee box har ju ett riktigt bra stöd för blu-ray så att inte plex skulle kunna få det "ganska lätt" låter ju orimligt

Ja, Plex plockar bort de orden vid sortering. Det är "by design" som man säger i USA.

Det är mycket möjligt att bättre stöd för BluRay-strukturen kommer dyka upp i framtiden. Men det är inget som är prioriterat just nu. Det som officiellt stödjs är en BluRay-ripp som ligger i en fil, eller i filer som är korrekt namngivna (part1, cd1, osv). Så vill du behålla max-kvalitet så rekommenderar jag att du gör en MKV eller mp4 av den (utan att komprimera). Det är hursomhelst 2000ggr smidigare än att sitta på en mappstruktur som är så osmidig som den faktiskt är.

Då det gäller dina avsnitt som dyker upp som dubletter så ska det normalt inte hända. Jag har massor med undermappar på just det sätt som du har. Det som kan skilja dock är att namngivningen inne i mapparna är galna. På den senaste screenshotten så visar du tyvrr inte hela mappnamnet, så teoretiskt så kan det vara mappnamnet som ställer till det också.
Det finns inget officiellt stöd för just den strukturen, men å andra sidan så fungerar det om man gjort allt rätt (funkar för mig iaf)

  • Medlem
  • 2012-03-30 22:01

ok, jag har dock bestämt mig för att skrota plex då jag inte accepterar att den kör transcode.

men tack för all hjälp!

ska ge mig på xbmc nu också, men ser inte ljust ut där heller..

så i nuläget ser det ut som om jag kommer gå tillbaka till boxee box.
av mina erfarenheter och tester så är det just boxee box som dels har fungerat bäst.
men även varit lättast att konfigurera och få att fungera lättast.
och att boxee box spelar upp precis ALLT utan massa löjlig transcode eller utan tråkga problem med blu-ray är en sak som jag gillar

Ursprungligen av tqila:

ok, jag har dock bestämt mig för att skrota plex då jag inte accepterar att den kör transcode.

men tack för all hjälp!

ska ge mig på xbmc nu också, men ser inte ljust ut där heller..

så i nuläget ser det ut som om jag kommer gå tillbaka till boxee box.
av mina erfarenheter och tester så är det just boxee box som dels har fungerat bäst.
men även varit lättast att konfigurera och få att fungera lättast.
och att boxee box spelar upp precis ALLT utan massa löjlig transcode eller utan tråkga problem med blu-ray är en sak som jag gillar

Absolut, lycka till med Boxee. Men att kalla transcode:ing löjligt innebär nog att du inte förstår vad det är.
För er andra som undrar, transcode:ing görs bara till de enheter som inte kan visa upp det format som du har videofilen i. Så använder du en dator som Plexklient så blir det ingen transcode:ing. Själva processen är egentligen inte så förstörande. Därmot så kan det ta ganska mycket kraft av den dator som har PMS installerat på sig.

  • Medlem
  • 2012-12-01 15:13

ok, då kanske man ska ge sig på plex igen då till sin mac mini när man slipper transcode

men frågan är om man ska ha PMS på servern (windows-burk) eller om man ska ha PMS på mac mini.
filmerna ligger på servern, men har PMS på mac mini nu och det verkar ju funka bra. men kanske är bättre att ha den på servern?

(kommer ju bara använda PMS när jag använder Plex och det finns bara på mac mini)

Jag tycker att du borde köra PMS på din mini då PMS är mer utvecklat till OSX än till Windows.

  • Medlem
  • 2012-12-01 15:46

ok bra, då slipper jag göra om allt då

  • Avstängd
  • Bangkok Thailand
  • 2012-12-01 18:56

Jag har testat både Plex och XBMC och XBMC vinner alla dagar i veckan.
Man kan köra det som det är men föredrar att installera ett skin tex Aeon Nox för att få mer funktionalitet.

  • Medlem
  • 2012-12-01 19:06

jo jag hade hellre kört xbmc men har inget val då jag inte får rätt ljud från xbmc (bara multichannel) och det har blivit korrupt eller något på min mac mini så inte alltid det går att starta.

och har ingen som kan hjälpa mig och hittar inget fel, så får köra på plex tillsvidare..

  • Avstängd
  • Bangkok Thailand
  • 2012-12-01 19:08
Ursprungligen av tqila:

jo jag hade hellre kört xbmc men har inget val då jag inte får rätt ljud från xbmc (bara multichannel) och det har blivit korrupt eller något på min mac mini så inte alltid det går att starta.

och har ingen som kan hjälpa mig och hittar inget fel, så får köra på plex tillsvidare..

Det måste vara en inställning i förstärkaren som ställer till det.
När jag spelar upp i förstärkaren blir det det ljudformat som filen har men väljer jag i förstärkaren att skicka vidare ljudet till Tv´n så blir det stereo.
Har du ingen manual på svenska på din förstärkare där du kan fördjupa dig i inställningarna?

  • Medlem
  • 2012-12-01 19:15

men för att ta rätt saker i rätt trådar så har jag ytterligare ett problem
hur jag än försöker så vägrar plex identifiera the amazing spider-man
söker med cine21/freebase.. how come?

  • Avstängd
  • Bangkok Thailand
  • 2012-12-01 19:16
Ursprungligen av tqila:

men för att ta rätt saker i rätt trådar så har jag ytterligare ett problem
hur jag än försöker så vägrar plex identifiera the amazing spider-man
söker med cine21/freebase.. how come?

Kan du inte ställa in att PLEX söker på IMDB?

  • Medlem
  • 2012-12-01 19:18
Ursprungligen av lappen71:

Och du har i XBMC ställt in i inställningarna att du har en DTS,DD kompatibel förstärkare?
Jag glömde det och då skickade den bara ut PCM

jo det är inställt (hade också glömt det igår först ). men av någon anledning så slutade det bara funka idag igen..
har sjukt störande problem med ljudet, tillkommer nya saker hela tiden som inte fungerar. och finns liksom inte mycket i förstärkaren som går att ändra som skulle kunna påverka resultatet..

Ursprungligen av lappen71:

Kan du inte ställa in att PLEX söker på IMDB?

det tror jag inte?

  • Avstängd
  • Bangkok Thailand
  • 2012-12-01 19:21
Ursprungligen av tqila:

jo det är inställt (hade också glömt det igår först ). men av någon anledning så slutade det bara funka idag igen..
har sjukt störande problem med ljudet, tillkommer nya saker hela tiden som inte fungerar. och finns liksom inte mycket i förstärkaren som går att ändra som skulle kunna påverka resultatet..

det tror jag inte?

Det är inte så att du har en billig HDMI-kabel som ställer till det?

  • Medlem
  • 2012-12-01 19:12

jo jag har manual och jag kan inte hitta att det skulle vara inställt på något annorlunda sätt (har fungerat felfritt med ALLT annat hittills)

  • Avstängd
  • Bangkok Thailand
  • 2012-12-01 19:15
Ursprungligen av tqila:

jo jag har manual och jag kan inte hitta att det skulle vara inställt på något annorlunda sätt (har fungerat felfritt med ALLT annat hittills)

Och du har i XBMC ställt in i inställningarna att du har en DTS,DD kompatibel förstärkare?
Jag glömde det och då skickade den bara ut PCM

  • Medlem
  • 2012-12-01 19:27

det är mycket möjligt. det är den kabel som följde med boxee box. men om det nu var så borde det inte strulat med alla andra enheter också då? allt annat har ju som sagt fungerat felfritt när det gäller ljud.

  • Avstängd
  • Bangkok Thailand
  • 2012-12-01 19:28
Ursprungligen av tqila:

det är mycket möjligt. det är den kabel som följde med boxee box. men om det nu var så borde det inte strulat med alla andra enheter också då? allt annat har ju som sagt fungerat felfritt när det gäller ljud.

Det där är ett problem som är väldigt svårt att lösa genom internet utan man skulle vara på plats och se sakerna.
Många gånger man försökt guida folk genom internet eller telefon och det varit omöjligt men när man är på plats var det en simpel sak.
Hoppas verkligen det löser sig för dig.

Bevaka tråden