Problem med USB port som stängts av, behöver lite mac-expertis råd.

Tråden skapades och har fått 5 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Skövde
  • 2011-12-26 19:49

Skulle gärna behöva lite hjälp här.
Lite klantigt av mig när jag kom hem igår efter lite julfirande och kopplade upp min MBP och andra saker så lyckades jag att förväxla två strömadaptrar en 12v som skulle in i en extern HDD och en 5v som skulle in en USB hub.

12v flög in i usb hubben som sedan sattes in i min MBP, allt funkade bra förutom att när jag tryckte in mitt externa tangentbord i usb hubben så var tangentbordet dött, jag tänkte att det kanske bara gått sönder då det hade några år på nacken för andra USB enheter funkade ju.

Idag så köpte jag snabbt ett billigt tangentbord och när det kopplades in i hubben så funkade inte det heller.
Skummt, jag tänkte att strömadaptern kanske till hubben kanske hade gett sig och det inte var tillräckligt med kräm i den.
Så jag ryckte ur strömförsörjningen till hubben och reagerade på att MBP som då var bootad i windows bara dog.

Eftersom jag inte såg skärmen helt så tänkte jag att det var väl en bsod och startade den igen i windows.
Denna gång så funkade inte en enda usb enhet i windows, jag ryckte ur alla usb enheter ur hubben och tryckte in dem igen. Inga enheter anslöts. Ryckte ur ström adaptern igen och datorn dog igen. Va i hela... tänkte jag och ryckte ur alla enheter ur dator och hubb och började genast kolla strömadaptrarna och såg att de var förväxlade. Bytte snabbt tillbaka och bootade om i Snow Leopard utan några usb kablar inkopplade, där jag möttes av följande medelande.

"Because a USB device was drawing too much power from your computer, one or more of your USB devices have been disabled

To prevent damaging your computer, the USB device drawing too much power has been disabled. Other devices may have also been disabled. When you disconnect the device drawing too much power, your other USB devices will be enabled again."

Inga av usb uttagen funkade först ej i osx, men efter att jag satte i rätt ström adapter i hubben och testade båda uttagen så funkar nu det ena av dem (det som hubben inte satt i med fel adapter.) Det andra verkar inte villa hoppa igång alls.

Startade om flertalet gånger och gjorde en SMC reset, but no luck. Jag undrar jag om inte det övre uttaget blev rökt.

MBP'n är av första Unibody modellen och skaffad i dec 08, så har väl ingen garanti kvar på den misstänker jag.
Är ju heller inte så sugen på att betala enorma summor och skicka den i veckor till apple heller. Men att bara ha en USB port är aningen jobbigt.

Det som irriterar mig är ju att det låter ju på medellandet som att usb-uttaget är intakt men bara avstängt.

Någon som har något förslag på något jag själv kan göra för att kanske få igång det igen?

  • Medlem
  • Karlskoga
  • 2011-12-26 22:56

Nej, jag tror den är kass nu. Att mata en 5V-enhet med 12 V är inget bra, som du har märkt, det är ju över dubbla spänningen. Så mycket marginal är det nog få elektroniska enheter som har.
Var glad att den ena funkar i alla fall. Och det hade förstås inte gått på garantin om du hade haft den kvar.

  • Medlem
  • Skövde
  • 2011-12-26 23:12

tackar, då är det som jag misstänkte då!, det lite knepiga är ju dock att jag körde ju på i närmare 15h med fel adapter utan problem med externa diskar anslutna via den, vilket får mig att tro på sätt och vis att min usb hub inte körde ut riktigt 12v, men antaligen kom det väl en spik när jag drog ur strömadaptern som sabbade något.

  • Medlem
  • Fränninge, Skåne
  • 2011-12-27 19:48

Frågan är om inte en återställning av SMC eller PRAM kan göra skillnad? För precis som det står så kan datorn själv stänga av portarna för att skydda datorn...

  • Medlem
  • Skövde
  • 2011-12-28 17:57

återställning av smc har jag gjort (om jag inte failade då) och det hjälpte inte, PRAM får jag prova och återkoma med. Det som slagig mig såhär i efterhand är ju att de två usb portarna bör ju ligga på samma buss, vilket är knepigt att den inte slagit av både portarna. och det får mig att tro att det skulle kunna

Om man ska tyda texten så står det ju att den ska aktiveras igen såfort man dragit ur enheten som drar för mycket ström... vilket får mig att tro att datorn fortfarande tror att porten används, vilket i och för sig skulle kunna på bero på att någon komponent har gått åt fanders, eller att den alldrig fått signalen om att porten inte har något anslutet till sig.

  • Medlem
  • Helsingborg
  • 2011-12-29 11:30

Den inbyggda webcamen använder sig av USB internt som ex.
Finns flera saker som ansluts via USB i en laptop inte bara utanför den.

Vanliga saker som webcam eller bluetooth.

1
Bevaka tråden