Problem med behörigheter m.m. efter flytt till ny dator

Tråden skapades och har fått 30 svar. Det senaste inlägget skrevs .

Hej,

Ja har då som rubriken säger, flyttat via flyttassistenten (via ethernet) allt från min minimac till min nya imac. Och nu tjorvar allting. Jag kan inte skapa nya företag i mitt redovisningsprogram för jag har inet behörighet att skriva överallt som det verkar. Jag måste in med lösenordet jämt och ständigt, om jag bara byter namn på en fil. Dokument (word, excel) måste öppnas skrivskyddade för de ändras av mej själv (på min gamla dator).Parallels krånglar, jag kan inte scanna dokument, att skriva ut tar evigheter innan skrivaren startar. Vad gör jag för att få allt bra igen????

- Tråden flyttad till rätt forumdel - detta är inte en iMac-hårdvaru-fråga.
- Trådens rubrik ändrad. Tänk på att rubriken tydligt ska visa vad tråden handlar om.

/Mod

  • Medlem
  • Karlskoga
  • 2011-10-10 18:18

Använde du samma namn på din nya dator som på den gamla (ditt användarnamn/lösenord)?

Jag tycker att det är helskumt, för när jag markerar HD och tar fram info så står det att:
Du har anpassad åtkomst
system - kan läsa och skriva
wheel - kan läsa och skriva
everyone - kan bara läsa.

Försöker jag lägga till något (via plusknappen) händer ingenting.

Försökte ändra på hd att alla skulle läsa och skriva och att det skulle inkluderas för alla objekt - då stod datorn och tuggade i ages, och när jag sen startade om den så startade den inte. Jag startade om och återskapar från en time machine kopia jag gjorde idag. Nu är jag lätt desperat över hur jag ska få det att fungera. Datorn använder jag i mitt företag som redoviningskonsult och det är frustrerande att lägga all tid på att försöka hitta fel. Irriterande när datorn inte ens är en vecka och krånglar så mycket.

jag är SÅÅÅÅ tacksam för all hjälp jag kan få för jag har inte en aning om vad jag ska göra.

Senast redigerat 2011-10-10 19:25

Ja, jag tror att det följde med när jag använde flyttassistenten. Sen bytte jag lösenord på den nya.

  • Medlem
  • Karlskoga
  • 2011-10-10 20:29

Funkade det innan du bytte lösenord på den nya?
Testat behörigheterna med Skivverktyg?

Det vet jag inte eftersom jag bytte lösenord bland det första jag gjorde. Jag har reparerat skivbehörigheterna flera gånger utan skillnad.

  • Medlem
  • Karlskoga
  • 2011-10-10 20:43

Eftersom datorer inte gör som man vill att de ska göra, utan gör som de blir tillsagda att göra, så skulle jag testat utan att byta lösenord först. Men det hjälper ju inte dej nu
Har du samma namn på "huset" som du hade på den andra dator (din hemmamapp)?

Skivbehörigheter har inget med rättigheter på din användare att göra. Testa detta:

Öppna Terminal (i Verktygsprogram). Ta bort alla ACL:er genom att skriva:
sudo chmod -R -N /Users/användarnamn (där du ersätter "användarnamn" med namnet på din hemkatalog), tryck enter och ange ditt lösenord.

Skriv sedan:
sudo chown -R användarnamn:staff /Users/användarnamn
Tryck enter.

Starta om datorn.

Senast redigerat 2011-10-10 21:36
  • Medlem
  • Malmö
  • 2011-10-10 20:59
Ursprungligen av Mattias A:

Skivbehörigheter har inget med rättigheter på din användare att göra. Testa detta:

Öppna Terminal (i Verktygsprogram). Ta bort alla ACL:er genom att skriva:
chmod -R -N /Users/användarnamn (där du ersätter "användarnamn" med namnet på din hemkatalog), tryck enter och ange ditt lösenord.

Skriv sedan:
chown -R användarnamn:staff /Users/användarnamn
Tryck enter.

Starta om datorn.

Fan vad jag digger dessa äss som likt Mattias A bara kommer in och förkastar reparationsprogram och andra grafiska UI för att istället bara dominera med lite terminalkommandon och oftast är biffen löst direkt efter det

You FTW!

Ursprungligen av zinned:

Fan vad jag digger dessa äss som likt Mattias A bara kommer in och förkastar reparationsprogram och andra grafiska UI för att istället bara dominera med lite terminalkommandon och oftast är biffen löst direkt efter det

You FTW!

Vi ska väl inte ropa hej innan vi är över bäcken, men funkar det så är det ju bra.

Det finns ett GUI som gör samma sak: Batchmod och som vanligt ska man förespråka försktighet när man labbar med rättigheter och sånt.

Det värsta är ju att jag blir så nervös när jag ska in i terminal och greja..... men jag provar det här imorgon!!!

Jahapp, gick inge vidare ..... Får svaret" Failed to clear ACL on file -N/users/Lena: No such file or directory"

Ursprungligen av Greta723:

Jahapp, gick inge vidare ..... Får svaret" Failed to clear ACL on file -N/users/Lena: No such file or directory"

Okej...

Är du helt säker på att du skrev rätt? Jag testade precis med ett slask-konto på min burk och det funkar:
sudo chmod -R -N /Users/test

Kopiera raden här och ersätt bara "test" med ditt eget namn.

nåt sudo stod inte i originalinstruktionerna.
Törs jag prova med det eller??? I O F sej så beror väl problemen på de os jag hade så det löser kanske ingenting.

Ursprungligen av Mattias A:

Okej...

Är du helt säker på att du skrev rätt? Jag testade precis med ett slask-konto på min burk och det funkar:
sudo chmod -R -N /Users/test

Kopiera raden här och ersätt bara "test" med ditt eget namn.

Ursprungligen av Greta723:

nåt sudo stod inte i originalinstruktionerna.
Törs jag prova med det eller??? I O F sej så beror väl problemen på de os jag hade så det löser kanske ingenting.

Utan sudo kan du inte köra kommandot som det skall köras, så ja.

Ursprungligen av Greta723:

nåt sudo stod inte i originalinstruktionerna.
Törs jag prova med det eller??? I O F sej så beror väl problemen på de os jag hade så det löser kanske ingenting.

Japp, sudo måste stå med. Jag la till det i efterhand, glömde det till en början, sorry. Det ska fungera även om du har Lion.

Gjorde om det och nu blev det så här: (varför kan inte

skärmavbildning spara till jpg???)

Ursprungligen av Greta723:

Gjorde om det och nu blev det så här...

Du gör ju samma fel som påpekades här redan i inlägg #17. Du måste ta åt dig av de tips och råd som du får.

Ursprungligen av Greta723:

...varför kan inte skärmavbildning spara till jpg?

Den kan spara i nästan vilket format som helst (JPG, TIF, PNG, GIF, osv). Men det är en fråga för en annan tråd.

Se här t.ex: http://www.google.se/search?q=file+format+screenshot+mac

Ursprungligen av Greta723:

Jahapp, gick inge vidare ..... Får svaret" Failed to clear ACL on file -N/users/Lena: No such file or directory"

Ser nu att det inte är mellanslag mellan "N" och "/", kan det vara där du har missat?

Inte för att det är svaret på ditt problem, men jag har alltid varit skeptisk till att göra sådana här flyttar, har alltid haft problem de få gånger jag gjort något. Skriver detta för de som funderar på att göra en migration till en ny dator.

Jag har alltid gjort en clean install/nystart, det tar längre tid men är värt det.

  • Medlem
  • Stockholm
  • 2011-10-11 12:35
Ursprungligen av LCR:

Inte för att det är svaret på ditt problem, men jag har alltid varit skeptisk till att göra sådana här flyttar, har alltid haft problem de få gånger jag gjort något. Skriver detta för de som funderar på att göra en migration till en ny dator.

Jag har alltid gjort en clean install/nystart, det tar längre tid men är värt det.

Jag håller inte med. Gör man på rätt sätt så fungerar det i stort sätt alltid. I alla fall om man inte har en massa strul innan. Har gjort det minst 100 gånger och det har fungerat 99% av gångerna.
Jag har haft mitt Mac OS X sedan Mac OS X 10.4 och det fungerar fint.

Skulle vilja påstå att alltid formatera och installera är en liten störning hos folk som mäter avståndet mellan sina pennor på skrivbordet.

Ursprungligen av acke:

Skulle vilja påstå att alltid formatera och installera är en liten störning hos folk som mäter avståndet mellan sina pennor på skrivbordet.

Måhända att jag alltid gör en 100% clean install oavsett när jag gör en större förändring som att gå upp till nästa version, men att mina pennor skulle komma in i bilden köper jag inte!!

http://www.99.se/allt-om-mac/46884-ta-bild-ditt-skrivbord-108.html#post1948987

Ursprungligen av Mattias A:

"the virtual machine is corrupted" indikerar att din Windows-installation är trasig.

Är inte det standard...

Ja, det är säkert bättre, men många gånger är det ett himla stök med att få över alla program etc. Fick det inte att bli bra den gången jag gjorde en nystart heller....!!

Har nu tillbringat 2 timmar med att prata med apple support, och förmodligen beror det på att jag flyttat från os 10.5.8 till os lion. Trots att det står att man kan flytta från 10.5.3 och jag har dessutom gjort en uppdatering av flyttassistenten som skulle lösa det..... Nu är jag SÅÅÅÅÅ arg på att det inte går att ladda ner snöleopard från nätet så nu sitter jag i sjön och kan inte göra nåt.

Provade med ett sudo i början och fick till svar:
chmod: illegal option -- -
usage: chmod [-fhv] [-R [-H | -L | -P]] [-a | +a | =a [i][# [ n]]] mode|entry file ...
chmod [-fhv] [-R [-H | -L | -P]] [-E | -C | -N | -i | -I] file ...

Kan ju lugnt säga att jag fattar absolut ingenting....

Ursprungligen av Greta723:

Provade med ett sudo i början...

Ange kommandot här, exakt så som du skrev det, så är det lättare för någon att berätta vad du gjorde fel.

Du måste ha ett mellanslag innan /users/Lena.

Heureka, nu verkar det som att det är rätt. Åtminstone står det överallt när jag tittar på info att jag kan läsa och skriva. Även om det fortfarande är anpassad åtkomst. Dock kan jag inte längre öppna parallels för "the virtual machine is corrupted"

Att det står Anpassad åtkomst är normalt. "the virtual machine is corrupted" indikerar att din Windows-installation är trasig.

Bevaka tråden