Router bakom router hittar inte Internet

Tråden skapades och har fått 22 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Stockholm
  • 2011-08-31 18:46

Hi.

Router 2 är ansluten till Router 1 via kabel och ingår i Router 1s nätverk. Router 2 kommer i kontakt med nätverk Router 1 och alla enheter som ingår i nätverket, men man kommer inte ut på Internet.

Hur får jag det att fungera även till Internet? Vad är det jag har missat?

Tacksam för hjälp!

  • Medlem
  • Karlskoga
  • 2011-08-31 20:14

Om dina routrar kör NAT är det inte en bra idé att lägga dem efter varandra.
Varför måste du köra två routrar?

  • Medlem
  • Stockholm
  • 2011-08-31 20:22

Ett av rummen i den aktuella lägenheten tycks vara en Faradays bur, inga signaler släpps in.

För att få täckning även i detta rum står Router2 i detta rum, och är ansluten till Router1 via en kabel.

Vilken av routrarna får inte ha NAT aktiverat?

Kan det vara något annan konfiguration som jag har gjort fel?

Testa att dra en kabel från en av router 1s LAN-portar och skicka in den i en LAN(istället för WAN) port på router 2.
Slå även av DHCP på router 2. Förhoppningsvis kommer router 2 då endast fungera som en switch/trådlös AP.

eller konfigurera routern som en enkel Access Point?

Är det ett måste att det skall vara trådlöst i rummet? eller är det en dator/tv/konsol som skall kopplas in?? isåfall kan du slänga ett öga på LAN över strömnätet istället.

Ursprungligen av KAPTENRODSKAGG:

Är det ett måste att det skall vara trådlöst i rummet? eller är det en dator/tv/konsol som skall kopplas in?? isåfall kan du slänga ett öga på LAN över strömnätet istället.

Känns lite konstigt att börja rekommendera andra lösningar, tycker jag. Han har ju redan den utrustning som behövs. Det handlar bara om att göra rätt inställningar i router 2 så kommer det ju att funka.

  • Medlem
  • International user
  • 2011-08-31 22:16
Ursprungligen av Jesper Ohlsson:

Känns lite konstigt att börja rekommendera andra lösningar, tycker jag. Han har ju redan den utrustning som behövs. Det handlar bara om att göra rätt inställningar i router 2 så kommer det ju att funka.

Även fast det är en uppenbart smidigare lösning?

För övrigt svårt att rekommendera inställningar utan information om vad det är för produkter.

Ursprungligen av zappee:

Även fast det är en uppenbart smidigare lösning?

Vi vet ju inte användningsområdet (t.ex vilka apparater det är som ska ansluta till nätverket). Så att avgöra vad som är smidigast i just det här fallet är nog lite svårt utan mer information.

Och varför ska man behöva köpa nya prylar när det förmodligen bara handlar om att stänga av vissa funktioner i router 2?

Ursprungligen av zappee:

För övrigt svårt att rekommendera inställningar utan information om vad det är för produkter.

Att stänga av DHCP i router 2 - vilket förmodligen är det enda som behövs - skiljer sig inte så mycket åt mellan olika modeller. Det kan han nog hitta utan att vi behöver veta exakt vilken router-modell det är.

Ursprungligen av Jesper Ohlsson:

Vi vet ju inte användningsområdet (t.ex vilka apparater det är som ska ansluta till nätverket). Så att avgöra vad som är smidigast i just det här fallet är nog lite svårt utan mer information.

Och varför ska man behöva köpa nya prylar när det förmodligen bara handlar om att stänga av vissa funktioner i router 2?

Att stänga av DHCP i router 2 - vilket förmodligen är det enda som behövs - skiljer sig inte så mycket åt mellan olika modeller. Det kan han nog hitta utan att vi behöver veta exakt vilken router-modell det är.

Jag skulle vilja lösa det så hemma, men på min D-Link DIR655 så fungerar det inte att göra så. Den sitter som router nummer två och verkar inte få något IP-nummer av router ett. (Nu snor jag tråden, sorry för det) Någon som har tips på vad som ställer till det? (Router ett är en Dovado 4GR)

Ursprungligen av Stefan Strandberg:

Jag skulle vilja lösa det så hemma, men på min D-Link DIR655 så fungerar det inte att göra så. Den sitter som router nummer två och verkar inte få något IP-nummer av router ett. (Nu snor jag tråden, sorry för det) Någon som har tips på vad som ställer till det? (Router ett är en Dovado 4GR)

Jag har liknande uppsättning hemma.
Har någon modem/router från comhem som första router och en dlink som andra router.
Jag har gjort på så sätt att jag stängt av NAT på router nummer 1, router 2 får då IP direkt från comhem.
Jag har valt detta för att man med dlink:en kan styra brandväggen bättre och den har bättre trådlös täckning.
Från router 1 har jag dragit en kabel från en LAN-port till router 2s WAN port.
Router 2 har jag ställt in att den får ip via DHCP. Eftersom jag stängt av NAT på router 1 får jag ett ip av min ISP.
Sen delar router 2 ut ip till alla datorer NAS telefoner etc etc i lägenheten.
Router 1 fungerar alltså bara som ett modem.
Detta tycker jag fungerar bar för mig.

Ursprungligen av Stefan Strandberg:

Jag skulle vilja lösa det så hemma, men på min D-Link DIR655 så fungerar det inte att göra så. Den sitter som router nummer två och verkar inte få något IP-nummer av router ett. (Nu snor jag tråden, sorry för det) Någon som har tips på vad som ställer till det? (Router ett är en Dovado 4GR)

En fråga till
Vill du använda dlink som router eller som trådlös AP/switch?
Vill du använda den som router så gör du så som jag svarade dig.
Vill du använda den som trådlös AP/switch så gör du som jag skrev i mitt första inlägg i den här tråden.

lycka till.

Om man kan ställa router 2 i bryggningsläge är det bästa lösningen. Man får då den "bron" som TS efterfrågar (routern blir en switch) och man blir en del i hela nätverket och inte två separata nät som jag antar TS har nu.
Att ha två NAT:ade routrar efter varann ska inte vara ett problem. Det man måste se till i så fall är att de har olika subnät (om router 1 har adresser i 10.0.0.x serien så får inte router 2 ha adresser i samma nät).

Tack för svaren men det vill inte fungera. Jag vill använda min D-Link som accesspunkt på övervåningen. Men jag får inget IP från router ett, försöker jag sätta ett eget IP så verkar den vilja ha ett externt IP (dvs. utanför 192.168.X.X)

Tacksam för förslag!

Har du testat att göra så som jag skriver i inlägg #4 i den här tråden?
http://www.99.se/natverk-sakerhet/289354-router-bakom-router-hittar-internet.html#post2015956

Ursprungligen av Stefan Strandberg:

Tack för svaren men det vill inte fungera. Jag vill använda min D-Link som accesspunkt på övervåningen. Men jag får inget IP från router ett, försöker jag sätta ett eget IP så verkar den vilja ha ett externt IP (dvs. utanför 192.168.X.X)

Tacksam för förslag!

Vart är det du sätter IP under "Internet" eller "Network settings"?
Om du ska köra den som endast AP och gör som jag skrivit i mitt första inlägg i den här tråden så behöver du inte sätta något IP under "Internet" för du kommer inte använda den porten(WAN).
Under "network settings" så sätter du ett IP under "Router IP address" detta IP ska vara på samma subnät(192.168.1.x tex) som router ett men sätt IP över eller under DHCP-skopet i router 1, annars riskerar du IP-krock.

Kolla även så att NAT och DHCP är påslaget på router 1.
Om du kopplar in en dator direkt i en LAN-port på router 1 vad får du för IP då?

Jag får IP 192.168.0.131 på min dator om jag kopplar in den med TP-kabel eller via Homeplug i ruter ett. Har testat flera olika IP i router två under "Networks Settings" utan resultat. Har testat att sätta TP-kabeln i både WAN och LAN porten på router två. Morr..

Efter att ha brutit strömmen på allt för 3 - 4 gången så kickade det igång! Stort tack för hjälpen, nu måste jag bara ta reda på varför jag inte kommer åt min dreambox från det nya nätet. (Försöker köra Dreambox Live på min iPad 2, men det vill inte fungera.)

  • Medlem
  • International user
  • 2011-09-03 17:13
Ursprungligen av Stefan Strandberg:

Efter att ha brutit strömmen på allt för 3 - 4 gången så kickade det igång! Stort tack för hjälpen, nu måste jag bara ta reda på varför jag inte kommer åt min dreambox från det nya nätet. (Försöker köra Dreambox Live på min iPad 2, men det vill inte fungera.)

Den kanske inte är i samma subnät?

Samma subnät, kommer åt alla andra resurser men inte dreamboxen. Kommer åt den via router ett men inte två. Mycket konstigt!

Problemet löst! Dreamboxen satt bakom en trådlös brygga, flyttade den till en homeplug så började det fungera. Tack för all hjälp!

  • Medlem
  • Stockholm
  • 2011-09-05 20:26

Tack alla som bidragit med sin kunskap!

Min syster får access av sin hyresvärd ner till sitt rum via el-lan/homeplug:

Enhet A är okänd enhet som hon inte har fysisk tillgång till.

Hennes gubbe har försökt ”allt” med tre olika routrar (B) för att åstadkomma följande:

utan att lyckas. Dvs att använda router B som trådlös AP/switch.
Han kom fram till att det var omöjligt, eftersom det gick via el-lan/homeplug. (what?)

Tänkte själv göra ett försök, så om man sammanfattar föregående talare:
B skall ha DHCP avstängt,
B skall ha NAT avstängt eller köra annat subnät
B skall endast använda LAN portar, ingen sladd i WAN

B är en simpel D-Link 624 anno 2004.
Tror inte den har något ”bryggningsläge”.

Min fråga, har jag missat nånting? Visst skall det fungera?

  • Medlem
  • Karlskoga
  • 2012-03-26 19:56

Om A har DHCP påslaget och inte har eget subnät på B, alternativt att du kör med fasta IPadresser. Då borde det funka.

1
Bevaka tråden