Fildelning i Mac OS X Lion

Tråden skapades och har fått 12 svar. Det senaste inlägget skrevs .
1

Ni får ursäkta om det finns en befintlig och lämplig tråd (jag hittar ingen som jag finner lämplig sett till att det verkar specifikt beröra nya versionen Lion). Jag motiverar en ny tråd med att jag tror att funktionen "Sharing only" i User & Groups är ny och därmed ger enkelheten med en ny tråd.

Jag sitter och försöker få en fungerande nätverksdelning i Mac OS X Lion. För att försöka begränsa åtkomsten något så har jag skapat ett separat konto med Sharing Only som kontotyp. Sedan har jag lagt till det i på den mapp jag vill dela och tilldelat rättigheterna "Read Only". Och nu uppstår problemet...

När jag försöker ansluta via \\192.168.0.10\Movies så fungerar det inte att ange kontot som inloggningsnamn. Den vill helt enkelt inte släppa igenom det till min Mac. Är det någon som har en idé om varför det blir så?

  • Medlem
  • Sollentuna
  • 2011-08-22 03:37

Vad får du för felmeddelande?

Ursprungligen av frazze:

Vad får du för felmeddelande?

Ingenting annat än att det angivna användarnamnet och lösenordet är felaktigt.

Ursprungligen av Tobias Schelin:

När jag försöker ansluta via \\192.168.0.10\Movies så fungerar det inte att ange kontot som inloggningsnamn. Den vill helt enkelt inte släppa igenom det till min Mac. Är det någon som har en idé om varför det blir så?

Var ligger Movies någonstans? Och du använder backslash, är det SMB det gäller?

Vad händer om du bara skriver IP-numret och inget mer (alltså inte "Movies")?

Ursprungligen av marcushedenstrom:

Var ligger Movies någonstans? Och du använder backslash, är det SMB det gäller?

Vad händer om du bara skriver IP-numret och inget mer (alltså inte "Movies")?

Movies ligger i min hemkatalog, men vad jag förstår så ska det inte vara något problem när man sätter in det specifika användarkontot i fältet för vilka som ska ha tillgång via nätverket.

Backslash är i stort sett nödvändigt, och innebär att gå via SMB-implementeringen i Mac OS X vad jag vet.

Det är samma resultat om jag bara använder ip-numret.

Ursprungligen av Tobias Schelin:

Movies ligger i min hemkatalog, men vad jag förstår så ska det inte vara något problem när man sätter in det specifika användarkontot i fältet för vilka som ska ha tillgång via nätverket.

Backslash är i stort sett nödvändigt, och innebär att gå via SMB-implementeringen i Mac OS X vad jag vet.

Det är samma resultat om jag bara använder ip-numret.

Är den andra datorn en PC? URLen bör även börja på smb:// om du ska använda samba, det räcker inte med att vända på slashen. Jag tycker inte det ser rätt ut med Movies direkt efter IP-nummer. Det ska vara en absolut sökväg i filsystemet.

Ursprungligen av marcushedenstrom:

Är den andra datorn en PC? URLen bör även börja på smb:// om du ska använda samba, det räcker inte med att vända på slashen. Jag tycker inte det ser rätt ut med Movies direkt efter IP-nummer. Det ska vara en absolut sökväg i filsystemet.

När du ansluter via Finder till en server based på Windows så behöver du skriva smb://. När du ansluter från ett system med Windows till en Mac (vilket jag försöker att göra) så behöver du inte ange det eftersom Windows försöker använda protokollet som standard. Då räcker det med att du har aktiverat fildelning med SMB i Mac OS X. Detta borde stärkas av att det faktiskt fungerar smärtfritt om jag använder mitt vanliga kontonamn och lösenord när jag försöker ansluta från Windows 7.

Tänkte jag kanske kunde lära mig något av den här tråden och ställer därför några korkade motfrågor: Heter alltså kontot Movies? Och jag antar att du inte försöker ansluta med en annan Mac, eftersom du inte går via Finder?

  • Medlem
  • Örnsköldsvik
  • 2011-08-22 20:27

@fitinghoff, Den så kallade Sharen (utdelade katalogen) heter Movies.

Tobias, har du aktiverat SMB på det nya kontot? "Options" i delningsinställningarna.

  • Medlem
  • Stockholm
  • 2011-08-22 21:06

Har vagt men bestämt (hm) för mig att Sharing only bara funkar med afp.

Edit: Se denna artikel. Men den infon kanske är föråldrad.

Ursprungligen av marcushedenstrom:

Tobias, har du aktiverat SMB på det nya kontot? "Options" i delningsinställningarna.

Det har jag inte ens tänkt på. Inser nu att det går att göra! Jag ska testa det i morgon och återkomma.

... tänk vad enklare det vore om man hade en iMac som man ska dela ut till via AFP.

Ursprungligen av marcushedenstrom:

Tobias, har du aktiverat SMB på det nya kontot? "Options" i delningsinställningarna.

Tack! Det fungerar utmärkt nu!

1
Bevaka tråden