Kommer inte åt min Network Space 2 utifrån?

Tråden skapades och har fått 12 svar. Det senaste inlägget skrevs .
1

Hej å hå!

Har ett smärre problem här..

Jag har en Network Space 2 inkopplad till min router (D-LINK DIR-655) och allt fungerar prima internt.

Men jag kommer inte åt den externt. Jag har aktiverat FTP funktionen i den och port forward är aktiverat på port 21 och 80. (FTP och HTTP) Detta för att komma åt disken och att kunna använda webgränssnittet för torrentsnedladdning.

FTP:n kommer jag åt, men när jag skriver in användarnamn och lösen så tar det stopp?
HTTP:n är ännu klurigare.. Kommer bara till en sida där det står: "this site is running Teamviewer, free port 80"? Jag har avinstallerat teamviewer, men texten kommer ändå upp?

WTF!?

Jag hoppas att forumets eminenta medlemmar skall ha en lösning på detta problem

Tack på förhand!

  • Medlem
  • Karlskoga
  • 2011-08-18 10:10

Om du ska köra ftp bör du ange passiv i ditt ftp-program. Detta för att det räcker inte med port 21, när du har loggat in öppnas en random port, och den har du inte portforwardat. Så därför måste din ftp-server välja porten (passiv) istället för din ftp-klient (aktiv).
Det sätter du i din ftp-klient när du skapar din connection.

OJ! Det där var lite överkurs för mig..?

När jag skall logga in externt så använder jag mig inte av nåt ftp-program, utan jag skriver bara in "ftp://mitt ip nummer" Så kommer det upp en ruta "anslut till server" där man ska fylla i användarnamn och lösenord. (Jag har skapat olika konton i ftp:n) Men när jag försöker logga in så går det inte?

Och när jag försöker att ansluta med "http://mitt ip nummer" så säger webläsaren bara "this site is running Teamviewer, free port 80"

Jag vill alltså komma åt ftp:n via port 21 och FTP:ns torrent gränssnitt via port 80

Klurigt... Jag fattar inte?

Tråden flyttad till rätt forumdel. Detta är inte en hårddisk- eller lagringsfråga, utan det handlar ju snarare om nätverksinställningar.

/Mod

  • Medlem
  • Karlskoga
  • 2011-08-18 23:20

Var skriver du in ditt "ftp...."? I en webbläsare (Safari t ex)?
Jag tror inte de stödjer passiva uppkopplingar. Så börja med ett riktigt ftp-program, t ex Cyberduck.
Vad är en Network Space 2?

Jag antar att en Network Space 2 är något slags NAS?

Vill du komma åt portar på interna datorer - bakom en NATad router (flera datorer delar en anslutning till internet), behöver du göra en vidarebefordran av portar i din router. På Port Forwarding Guides Listed by Manufacturer and Model - PortForward.com har de exempel på hur man gör för många routrar.

Tänket är liknande detta:
Internet -> Router (port 80) -> Port forwarding till intern dators IP-adress port 80

Vad som är bra att tänka på om man ska göra portforwarding är att sätta fasta IP-adresser eller låta DHCP-servern tilldela samma IP-adress till din Network Space 2 vid varje anslutning. Hur man gör det senare står ofta i manualen till routern.

kenjon, passiv FTP används oftast som standard hos webbläsare nuförtiden (hur Safari gör vet jag inte). Vid aktiv FTP ansluter klienten och skickar en IP-adress och port dit servern kan skicka data. Vid passiv FTP frågar klienten om en IP-adress och port dit den ansluta för dataöverföring. Detta medför att man kan köra FTP även genom de flesta brandväggar.

För att ändra hur Finder gör passiva eller aktiva anslutningar finns under System Preferences -> Network -> Proxies -> Use Passive FTP Mode (PASV) (heter väl något liknande Systemegenskaper -> Nätverk -> Proxy -> Använd passiva FTP anslutningar (PASV) på svenska).

Kenjon: Jag skriver in "ftp://mitt ipnummer" i adressfältet i safari eller "http://mitt ipnummer"
En Network Space 2 är en: LaCie is the premier manufacturer of high quality digital storage.

suddgummi: Jag har vidarebefodrat port 21 och port 80 i min router. Jag har även gett min Network Space ett fast ipnummer; 192.168.0.106
Passiva FTP anslutningar är påslagit i FINDER..

Om du har UPnP på DLinken kan du ju testa det. LaCies screencast: LaCie is the premier manufacturer of high quality digital storage.

Du tar alltså väck de manuella portforwardingarna i routern och låter din Network Space konfigurera routern själv.
Jag antar att du läst bruksanvisningen? Det står mycket bra beskrivet i den tycker jag. Nästan så jag blir sugen på en själv Riktigt bra att man kan stänga av status-LEDen

Det borde stå i systemloggen i din NS2 vad som händer, om den lyckats med konfigureringen osv.

Men angående ditt problem med TeamViewer som verkar ligga och lyssna på port 80 så verkar det ju som om den inte blivit korrekt avinstallerad. Har du då UPnP aktivt i routern tar TeamViewer och konfigurerar en portforward för dig.

  • Medlem
  • Karlskoga
  • 2011-08-21 15:19

Och eftersom Teamviewern svarar på port 80 kommer anropet aldrig fram till NASen....
Ftp borde funka dock.

Hej igen.

suddgummi: Jag testade att göra som videon visade, vilket jag tänkte att jag skulle slippa och det fungerade, typ.. men det är inte s å jag vill ha det. Jag vill ju som sagt bara kunna koppla upp direkt till disken via ftp://mitt ip nummer.
Jag vet inte hur jag skall kunna avinstallera teamviewer på annat sätt än att slänga SKITEN i papperskorgen..

kenjon: Anropet verkar komma fram när jag skriver ftp://mitt ip nummer.. jag kommer då till en anslutningsruta (anslut till server, där jag skall fylla i mitt användarnamn och lösenord) Men sedan tar det stopp! Den säger bara att jag skall kontrollera ipnummer och lösenord, vilket jag vet stämmer!
"this site is running teamviewer" dyker bara upp när jag försöker med http://mitt ip nummer... dvs när jag vill igenom port 80.

Jag skall testa med ett ftp program nu oxå... HAHA! Vi får väl se...

Jag satt länge och funderade på om jag skulle erkänna detta, men here it goes..

Jag hade vänt på de sista fyra siffrorna i mitt ip-nummer.. AHHH!!! Hur kan jag vara så puckad?!

I vilket fall fungerar allt galant nu och jag har lärt mig mycket om min router och min network space 2 på köpet

Åter igen ett stort tack till er underbara själar som har försökt å hjälpa mig!

MVH!

  • Medlem
  • Karlskoga
  • 2011-08-21 21:54

Schysst att du hade modet att skriva vad som var fel
Grattis!

  • Medlem
  • Örnsköldsvik
  • 2011-08-22 20:24

Jaja, det är lätt att göra fel på IPv6-adresser..

(eller var det kanske IPv4?)

1
Bevaka tråden