Kan inte starta flera systemprogram

Tråden skapades och har fått 3 svar. Det senaste inlägget skrevs .
1

Jag har tyckt att min 2010 Air varit lite väl kraschbenägen ibland, den kunde hänga sig även om jag bara hade en browser och inget annat igång (eller liknande), det verkar inte ha något att göra med belastning / värme. Jag klickade runt lite i System Preferences för att se om jag kunde se något konstigt, och märkte då att jag inte kan starta "Accounts" preference pane. Jag får upp en alertruta med texten: "Preferences Error - Could not load Accounts preferences pane". I systemloggen ser jag följande:

2011-04-25 19.16.50	System Preferences[278]	[NSPrefPaneBundle instantiatePrefPaneObject] (/System/Library/PreferencePanes/Accounts.prefPane): principalClass is nil.

Någon som vet vad detta fel innebär? Jag började misstänka att jag behövde reparera disk permissions eller liknande, så jag startade Disk Utility.. Som inte heller kunde starta. Jag får upp en ruta med standard-texten "Disk Utility could not be opened because of a problem". What!? Jag kollade loggarna igen, men blev inte direkt klokare.

2011-04-25 19.08.22	[0x0-0x1f01f].com.apple.DiskUtility[270]	dyld: Symbol not found: _OBJC_CLASS_$_XSAction
2011-04-25 19.08.22	[0x0-0x1f01f].com.apple.DiskUtility[270]	  Referenced from: /System/Library/PrivateFrameworks/ServerKit.framework/Versions/A/ServerKit
2011-04-25 19.08.22	[0x0-0x1f01f].com.apple.DiskUtility[270]	  Expected in: /System/Library/PrivateFrameworks/ServerFoundation.framework/Versions/A/ServerFoundation
2011-04-25 19.08.22	[0x0-0x1f01f].com.apple.DiskUtility[270]	 in /System/Library/PrivateFrameworks/ServerKit.framework/Versions/A/ServerKit
2011-04-25 19.08.22	com.apple.launchd.peruser.501[90]	([0x0-0x1f01f].com.apple.DiskUtility[270]) Job appears to have crashed: Trace/BPT trap
2011-04-25 19.08.23	ReportCrash[272]	Saved crash report for Disk Utility[270] version 11.5.2 (298.4) to /Users/erik/Library/Logs/DiagnosticReports/Disk Utility_2011-04-25-190823_MacBook-Air.crash

Kollade även kraschloggen men där står ganska exakt samma sak. Jag börjar tro att det kan vara något med SSD:n som är paj.. Jag har inte mycket installerat på min Air, bara några enstaka program samt webläsare/filmspelare, och alla har jag även på min iMac utan minsta bekymmer. Jag har svårt att se vad som skulle ha kunna orsakat detta. Är det någon som har något tips på hur jag går vidare och felsöker? Eller är det installera om OS X som är nästa steg?

Kan även tillägga att jag startat om datorn med "D" intryckt och kört hårdvarutestet, det gick igenom utan anmärkningar.

All hjälp mottages tacksamt!

  • Oregistrerad
  • 2011-04-25 20:35

Vad händer om du kör en

ls /System/Library/PrivateFrameworks/ServerFoundation.framework/Versions/A/ServerFoundation

i terminalen?

Det ser ut som din disk faktiskt saknar filer. Antagligen har dom blivit raderade (av misstag) eller är det fel på din SSD av någon konstig anledning verkar det som iaf. någon annan kanske har andra tips?

Filerna finns där, och de har samma storlek som motsvarande filer på min iMac. Jag ska se om jag kan hitta några problem med filrättigheterna, men det blir ju betydligt knivigare då jag inte kan köra Dsik Utility heller Håller iaf på att köra ett "extended" test med Apple Hardware Test så får man se om det ger någon ledtråd.

En liten uppdatering.. Jag kontrollerade alla filer den klagade på, och hittade inget fel på dem (datum, namn, storlek, permissions osv). Jag använda USB-driven som kom med datorn för att boota OS X-installern där man kan hitta Disk Utility också. Där körde jag Repair Disk och Repair Permissions, men efter en reboot var problemen kvar.

Jag bestämde mig för att köra en OS X-installation över mitt gamla OS (dvs att jag har kvar apps, inställningar mm, men den skriver om systemfilerna). Installationen gick halvvägs innan den avbröts (!). Fick upp ett meddelande i stil med "Can't install OS X, can't write preference files to disk. Reboot and try again." eller nåt åt det hållet. Jag gjorde det, och den här gången gick det bra..

Efter installationen försvann problemen. Jag har kört Disk Utility och Disk Warrior, och de hittar inga problem med disken nu. Däremot är jag inte säkert på att det är fixat, de gamla problemen uppstod väldigt sporadiskt utan något egentligt sätt att återskapa dem. Jag får installera uppdateringarna som finns och köra så här ett tag, och hålla tummarna att problemet är löst antar jag..

1
Bevaka tråden