Problem med NAS

Tråden skapades och har fått 20 svar. Det senaste inlägget skrevs .
1

Köpte min första NAS igår och det dök upp lite hinder, men jag lyckades ta mig över dem till slut. Dock har det dykt upp ett nytt problem som jag inte vet hur man löser.

Jag har en APE som Mac Minin och NASen är kopplad till, och externa diskar kopplade till Minin. När jag ska föra över filer och mappar från de externa till NASen vill inte allt föras över. Ibland hoppar den över enstaka filer, och ibland förs det över mappar utan innehåll.
Inga felrutor kommer upp, det känns som den tror att jag inte ser vad den håller på med...

NASen är en D-link DNS-320, med senaste FW, och allting är kopplat med tråd.

Vad är felet? NASen, Minin, routern eller kanske någon inställning?

MVH Hugo

Bör vara Minin som ställer till det.

Prova från en annan dator.

Kan du gå in via SSH till NAS:en? Isåfall kan du gå in och kolla om filerna verkligen saknas eller inte.

Här är folk som har samma problem från Mac till Home Server: Windows Home Server Forums • View topic - Missing files after copy - MediaSmartServer.net

edit: Verkar inte vara ett helt ovanligt fel, oavsett vad man kopierar till.
http://www.google.se/search?q=mac+copy+files+to+nas+missing+files

Ursprungligen av keptang:

Bör vara Minin som ställer till det.

Prova från en annan dator.

Kan du gå in via SSH till NAS:en? Isåfall kan du gå in och kolla om filerna verkligen saknas eller inte.

Här är folk som har samma problem från Mac till Home Server: Windows Home Server Forums • View topic - Missing files after copy - MediaSmartServer.net

edit: Verkar inte vara ett helt ovanligt fel, oavsett vad man kopierar till.
mac copy files to nas missing files - Sök på Google

Har också sett att det är fler än jag som har samma problem, lite betryggande iaf. Filerna syns inte från min Macbook heller så de finns nog inte. Mappar som innehåller filer på ca 4GB tar bara 1 sekund att föra över så jag är rätt säker på att filerna inte överförs.

Hur går man in via SSH/vad är SSH?

Något annat jag stör mig på är att min NAS kommer upp som två enheter under Delat i findern. En som heter dns-320 och har PC-skärm som ikon, och en DNS-320-1 och har en ACD som ikon.
Varför detta och går det att lösa?

Tack för svara än så länge!

  • Oregistrerad
  • 2011-04-06 11:19

Ansluter du till din NAS med SMB eller AFP?

Ursprungligen av studiox:

Ansluter du till din NAS med SMB eller AFP?

Det vet jag faktiskt inte, hur ser man det? Är lite smågrön på det här med nätverk och nasar.

Vad bör jag använda och hur ställer jag in det?

Ett nytt och jobbigare problem har dykt upp. När datorn startar får jag upp felmeddelandet: Anslutningen misslyckades...kontrollera servernamn eller IP-adress.

Har använt NASen några dagar utan problem, varför kommer detta upp nu? Jobbigt eftersom jag kör Plex och nu hittas ju inte filerna. Kommer åt dem via Findern.

  • Medlem
  • Karlskoga
  • 2011-04-10 23:16
Ursprungligen av h.cewers:

Ett nytt och jobbigare problem har dykt upp. När datorn startar får jag upp felmeddelandet: Anslutningen misslyckades...kontrollera servernamn eller IP-adress.

Har använt NASen några dagar utan problem, varför kommer detta upp nu? Jobbigt eftersom jag kör Plex och nu hittas ju inte filerna. Kommer åt dem via Findern.

Har du statiskt eller dynamiskt IP på den? Jag tycker det är enklast att ha statiska på servers, skrivare och NASar...

Statisk.

Fyller på med en fråga till. Varför dyker nasen upp två gånger i finder, och går det att fixa?

Bara två gånger;) Min Netgear ReadyNAS dyker upp tre gånger (såsom ReadyNAS, ReadyNAS (afp) och ReadyNAS (cifs)). Efter vad jag förstår så är den designad på det sättet.

Ja, en gång / protokoll som används för utdelning bör det vara.

  • Oregistrerad
  • 2011-04-18 12:32
Ursprungligen av keptang:

Ja, en gång / protokoll som används för utdelning bör det vara.

Naje, det är faktiskt så att det finns en (default) utdelning på NetGear + en för varje protokoll, så delar du ut en share med AFP/CIFS så får du tre..

Ursprungligen av studiox:

Naje, det är faktiskt så att det finns en (default) utdelning på NetGear + en för varje protokoll, så delar du ut en share med AFP/CIFS så får du tre..

Ja, så är det med alla NAS tror jag.

NAS:en i sig och en per protokoll.

  • Oregistrerad
  • 2011-04-18 13:29
Ursprungligen av keptang:

Ja, så är det med alla NAS tror jag.

NAS:en i sig och en per protokoll.

Ok, jag har bara haft Netgear, har ingen annan erfarenhet. Det är dock konstigt att default sharen inte innehåller dom shares man delat ut, utan andra..

Ok, tack för dem svaren! Verkar inte som man kan göra så mycket åt det då.

Nu återstår problemet att nasen inte hittas vid uppstart av datorn. Jag kan lätt lösa det genom att i findern välja "en" av nasarna, logga ut som admin, och istället logga in som gäst. Hade varit trevligt om det skedde automatiskt.
Från min macbook är det inga problem att komma åt nasen direkt.

  • Medlem
  • Karlskoga
  • 2011-04-19 13:42
Ursprungligen av h.cewers:

Ok, tack för dem svaren! Verkar inte som man kan göra så mycket åt det då.

Nu återstår problemet att nasen inte hittas vid uppstart av datorn. Jag kan lätt lösa det genom att i findern välja "en" av nasarna, logga ut som admin, och istället logga in som gäst. Hade varit trevligt om det skedde automatiskt.
Från min macbook är det inga problem att komma åt nasen direkt.

AppleScript?

AppleScript?

  • Medlem
  • Karlskoga
  • 2011-04-20 15:17
Ursprungligen av h.cewers:

AppleScript?

Ja, om du vill att det ska ske automatiskt, det du nu gör manuellt.

Ursprungligen av kenjon:

Ja, om du vill att det ska ske automatiskt, det du nu gör manuellt.

Nu har jag googlat mig till det, men syftade på att jag inte visste vad applescript är för nåt.
Tycker det måste finnas något lättare sätt att fixa detta, eller är det lätt att skriva ihop ett skript?

Tack för hjälpen iaf!

  • Medlem
  • Karlskoga
  • 2011-04-22 09:41

OK då missförstod jag dej
AppleScript har varit en del av MacOS väldigt länge...
Det finns en autofunktion för att skapa scripten, kallad Automator. Jag tror den kom i 10.5...
Jag har själv aldrig använt den, men man startar programmet och "spelar in" de åtgärder du gör med mus/tangentbord. Den skapar ett script som du sedan kan lägga i LoginItems under ditt konto i Systeminställningar. Då borde det ske automatiskt.

Ursprungligen av kenjon:

OK då missförstod jag dej
AppleScript har varit en del av MacOS väldigt länge...
Det finns en autofunktion för att skapa scripten, kallad Automator. Jag tror den kom i 10.5...
Jag har själv aldrig använt den, men man startar programmet och "spelar in" de åtgärder du gör med mus/tangentbord. Den skapar ett script som du sedan kan lägga i LoginItems under ditt konto i Systeminställningar. Då borde det ske automatiskt.

Ok, tack så mycket! Ska testa Automator direkt!

1
Bevaka tråden