Problem att installera Xcode 4 från App Store

Tråden skapades och har fått 14 svar. Det senaste inlägget skrevs .
1

Jar har köpt Xcode4 men har problem med att installationen inte går helt klar. Allt verkar dock installerat och körklart men jag har varit tvingad att Tvångsavsluta Installern efter lång tid. Andra med dessa erfarenheter?
Gunnar

  • Medlem
  • I skogen utanför Umeå
  • 2011-03-10 11:42

Japp, samma problem här.

Edit: iMac 27" i7 2,8 GHz 4GB OS 10.6.6. Alla andra uppdateringar från Apple också.

Senast redigerat 2011-03-10 12:16
  • Medlem
  • Täby
  • 2011-03-10 12:11

Lite mer info kanske...

Datormodell? (typ, årgång)
GB minne?
OSX 10.?

Ursprungligen av kainen:

Lite mer info kanske...

Datormodell? (typ, årgång)
GB minne?
OSX 10.?

OSX lär ju vara version 10.6.6 eller hur?

Jag har en iMac i7 2.8GHz med 8GB primärminne och använder 10.6.6. Dessutom massor med hårddisk-utrymme.
Såg ett inlägg där enperson hade lyckats att (om)installera och fått det att gå klart genom att lämna AppStore aktiverad. Provat även detta men fått samma resultat som i tidigare försök.

  • Medlem
  • Sollentuna
  • 2011-03-10 12:29

Kanske beror på hög belastning på Apples servrar nu när iOS 4.3 är släppt. Jag har själv problem med att logga in på utvecklarportalen: ingen respons efter att ha klickat på login-knappen efter id och lösenord.

Ursprungligen av frazze:

Kanske beror på hög belastning på Apples servrar nu när iOS 4.3 är släppt. Jag har själv problem med att logga in på utvecklarportalen: ingen respons efter att ha klickat på login-knappen efter id och lösenord.

Jag tror också att det beror på detta.
Hade lite "problems" med att uppdatera något program sent igår natt.

  • Medlem
  • Hillared
  • 2011-03-10 16:14

Har också problem att installera XCode4 från Mac App Store, den laddar ner till c:a 219MB, sedan stoppar den till och hoppar tillbaka till 209MB och börjar ladda ner igen. Detta gör den några gånger innan den säger att det blev något fel med installationen. Väljer man att prova igen så blir det samma sak.
Igår när det köptes så laddade den ner c:a 3,5GB innan det bröt. Men nu är den fast i slingan som jag nämnde ovan.
Förhoppnignsvis är det pga belastning och inget annat som krånglar.

Mac Pro 1,1
MacOSX 10.6.6

Har även provat på min Macbook Pro 6,2 med samma resultat.

Senast redigerat 2011-03-10 16:37
  • Medlem
  • I skogen utanför Umeå
  • 2011-03-11 10:32

Efter tips från Apples supportforum kunde jag få installationen att slutföra.

Ursprungligen av mkeriksson :

I successfully installed it this way.

So go to Applications-folder. Find "Install Xcode".

Right-click and choose "Show Content" (or something, swedish language activated).

Go to Contents > Resources and doubleclick Xcode and iOS SDK.mpkg.

Then you're good to go with the installation.

I'll leave the "install xcode" file be in Applications folder.

  • Skribent
  • Sollentuna
  • 2011-03-12 11:38
Ursprungligen av MatsOlov:

Efter tips från Apples supportforum kunde jag få installationen att slutföra.

Funkade för mig, tackar!

  • Medlem
  • Hillared
  • 2011-03-11 17:03

Någon som vet vart / hur man kan ladda ner installationspaketet för XCode4 och sedan köra det manuellt?
Verkar inte som att det kommer någon snabb fix för nedladdningsproblemet inom det närmaste :/

Man är inte ensam iaf: Apple - Support - Discussions - Xcode 4 fails to download ...

Installationspaket kommer med nedladdningen från App Store

  • Medlem
  • Hillared
  • 2011-03-12 11:36

En del har rapporterat (se tråden jag länkade till ovanför) att om man ändrar till Google's DNS'er (8.8.8.8 samt 8.8.4.4) så har de kunnat ladda ner Xcode4 från MAS. Jag tänkte testa detta med (jag lyckades ladda ner det via mitt mobila bredband på en dator, sedan kopierade jag över installationsfilen till den andra datorn och körde utan problem), men det verkar vara lögn i helsike att få MAS att förstå att code är av installerat (har kört avinstallationsscriptet för Xcode, tagit bort mappar mm för både Xcode samt MAS. Men den envisas med att säga att Xcode fortfarande är installerat).

Uppdatering: Xcode sågs som en installerat när jag väl tagit bort "Install Xcode" appen från Downloadmappen och tömt papperskorgen. Nu testar jag hela kedjan med att ladda ner och installera igen.

Senast redigerat 2011-03-18 07:41
  • Medlem
  • Hillared
  • 2011-03-12 12:45

Japp, nu fungerar både nedladdning och installation efter byte av DNS. Skumt, men problemet är löst

Allt löste sig med hjälp av tipsen här och i support tråden!

Senast redigerat 2011-03-17 23:52
1
Bevaka tråden