Koppla PSU direkt på batteri kontakterna - PBG4 HRDL

Tråden skapades och har fått 6 svar. Det senaste inlägget skrevs .
1

Jag har en PowerBook G4 1.67GHz Hi-res Dual-layer DVD där DC-in kortet verkar ha dött, eller rättare sagt ström-in porten för både USB och ljud-ut biten fungerar.

1. Finns det något som kan vara reparerbart eller brukar det alltid vara kretskortet som går pajar?

2. Går det att löda PSU kablarna direkt på terminalerna som går till batteriet? I så fall vilka?

Tänkte ha den som musikspelare i och med att den har digitalt ljud ut så spelar varken batteri eller utseende någon roll, och ingen verkar ha ett DC-in kort...

1. Problemet är att själva kontakten brukar lossa från DC-in kortet (om allt annat funkar så är det säkert det).
Jag har reparerat min ena Powerbook (av samma modell som din). Den laddar visserligen inte batteriet eftersom det har gått en säkring på logikkortet och den sitter på undersidan. Jag ska byta säkringen nån dag tänkte jag och se ifall den funkar med laddning igen. Jag följde denna guiden: Powerbook G4 Power Connector Replacement : Screaming Light Studios : Exclusive Technical Photography : Las Cruces, New Mexico : El Paso, Texas samt nån guide från iFixIt som visade hur man monterade ur DC-in kortet.

Det är lite fix att få datorn att förstå att det är en 65W laddare inkopplad. Jag tog bilder på hur jag lödde fast kablarna och noterade vilket motstånd det skulle vara för att trixa till så att Macen fattar att den har en 65W (annars blir det 45W den rapporterar). Det ska sitta ett motstånd mellan Vsense och jord, se Technical Q&A QA1266: Power adapter Sensing for the 17" PowerBook
Glöm de 400kΩ som det står på nätet, det funkar inte med denna modell.

Vill du så kan jag leta upp bilderna och värdet på motståndet, jag är tillbaka hemma på måndag eller tisdag.

Komponenterna till DC-inkopplingen köpte jag på Kjell & C:o, motståndet hade jag liggandes. Har för mig att hela lagningen kostade under 50 kr.

2. Ingen aning - har sett tredjepartsladdare som laddar batterierna separat.

Får du inte fixat den så säg vad du vill ha för den, så tar jag den

Ursprungligen av suddgummi:

1. Problemet är att själva kontakten brukar lossa från DC-in kortet (om allt annat funkar så är det säkert det).
Jag har reparerat min ena Powerbook (av samma modell som din). Den laddar visserligen inte batteriet eftersom det har gått en säkring på logikkortet och den sitter på undersidan. Jag ska byta säkringen nån dag tänkte jag och se ifall den funkar med laddning igen. Jag följde denna guiden: Powerbook G4 Power Connector Replacement : Screaming Light Studios : Exclusive Technical Photography : Las Cruces, New Mexico : El Paso, Texas samt nån guide från iFixIt som visade hur man monterade ur DC-in kortet.

Det är lite fix att få datorn att förstå att det är en 65W laddare inkopplad. Jag tog bilder på hur jag lödde fast kablarna och noterade vilket motstånd det skulle vara för att trixa till så att Macen fattar att den har en 65W (annars blir det 45W den rapporterar). Det ska sitta ett motstånd mellan Vsense och jord, se Technical Q&A QA1266: Power adapter Sensing for the 17" PowerBook
Glöm de 400kΩ som det står på nätet, det funkar inte med denna modell.

Vill du så kan jag leta upp bilderna och värdet på motståndet, jag är tillbaka hemma på måndag eller tisdag.

Komponenterna till DC-inkopplingen köpte jag på Kjell & C:o, motståndet hade jag liggandes. Har för mig att hela lagningen kostade under 50 kr.

2. Ingen aning - har sett tredjepartsladdare som laddar batterierna separat.

Får du inte fixat den så säg vad du vill ha för den, så tar jag den

Mycket intressant svar.

Jag skruvar isär den i morgon och kollar lödningarna.

Jag har letat rätt på mina bilder nu och det är egentligen de två bifogade som är intressanta.

De visar hur jag kopplat motståndet. Det går mellan den pinne som är jord i kontakten till den pinne på DC-inkortet som är Vsense ("skölden" på originalkontakten). Min kontakt var defekt och jag ersatte den därför med ett eget strömintag. Motståndet du ser på bilden är på 150kΩ och ger mig en spänning över motståndet som ligger överkant utav specarna enligt QA1266 (har för mig att jag låg på 2.3V).

Eftersom jag har tillgång till PSpice simulerade jag mig fram till vad motståndet skulle vara (och kollade i min låda efter vilka motstånd jag hade hemma).

Viktigt är oavsett att man mäter spänningen över motståndet så det ligger inom specarna enligt Apples QA.

Övriga anslutningar på DC-inkortet är bara jord och +24V (jorden har jag kopplat så den del av kontakten som är "naken" är i chassiet).

Har inte tagit tag i detta ännu men råkade titta på min to-do lista och såg att detta fanns kvar.

Jag ser tyvärr inte riktigt på bilderna exakt var du lött och var går de gula och röda kablarna ?

Man kan säga att kontakten som sitter som standard har 5 ben i kretskortet.
Tre längst bak (där jag satt gul som jord och röd som +). Det är bara de två längst ned i bild som används.
Sedan sitter det två i skärmen på kontakten. I det ena har jag lött fast motståndet i och andra delen av motståndet går till jord.

För att ha något att löda i (som inte har coating på sig) klippte jag av benen en bit ovanför kretskortet och friserade dem så att de gick att löda fast nåt i dem.

Det ger sig när du öppnar datorn.

Jag återkommer när jag får 5 minuter att titta närmare...

1
Bevaka tråden