Kan inte ansluta med SMB till 10.6 server i ADt

Tråden skapades och har fått 4 svar. Det senaste inlägget skrevs .
1

Hej

Vi har en Xserve med 10.6.6 som är kopplad som en "domain member" till vårt AD.

Om jag ansluter till en delningspunkt från en Mac med mitt AD konto så kopplas delningen upp perfekt med rätt behörigheter.

Om jag ansluter till samma delning via SMB med samma konto får jag Fel användarnamn eller lösenord.
Provar jag från en PC poppar bara inloggningsrutan upp hela tiden.

Anger jag uppgifter till admin konto så fungerar det via SMB.

I Access>services är det satt "Allow all users and groups" så det är inte det som är felet.

Jag får en fellog enligt följande:

[2011/02/02 08:59:48, 2, pid=44682] /SourceCache/samba/samba-235.5/samba/source/lib/module.c:do_smb_load_module(64)
Module '/usr/lib/samba/auth/odsam.dylib' loaded
[2011/02/02 08:59:48, 0, pid=44682] /SourceCache/samba/samba-235.5/samba/source/auth/auth_odsam.c:opendirectory_ntlmv2_auth_user(334)
dsDoNodeAuth gave -14090 [eDSAuthFailed]
[2011/02/02 08:59:48, 0, pid=44682] /SourceCache/samba/samba-235.5/samba/source/auth/auth_odsam.c:opendirectory_smb_pwd_check_ntlmv2(450)
opendirectory_ntlmv2_auth_user gave -14090 [eDSAuthFailed]
[2011/02/02 08:59:48, 0, pid=44682] /SourceCache/samba/samba-235.5/samba/source/auth/auth_odsam.c:opendirectory_opendirectory_ntlm_password_check(526)
opendirectory_smb_pwd_check_ntlmv2 gave -14090 [eDSAuthFailed]
[2011/02/02 08:59:48, 0, pid=44682] /SourceCache/samba/samba-235.5/samba/source/auth/auth_odsam.c:opendirectory_ntlmv2_auth_user(334)
dsDoNodeAuth gave -14090 [eDSAuthFailed]
[2011/02/02 08:59:48, 0, pid=44682] /SourceCache/samba/samba-235.5/samba/source/auth/auth_odsam.c:opendirectory_smb_pwd_check_ntlmv2(450)
opendirectory_ntlmv2_auth_user gave -14090 [eDSAuthFailed]
[2011/02/02 08:59:48, 0, pid=44682] /SourceCache/samba/samba-235.5/samba/source/auth/auth_odsam.c:opendirectory_opendirectory_ntlm_password_check(557)
opendirectory_smb_pwd_check_ntlmv2 gave -14090 [eDSAuthFailed]
[2011/02/02 08:59:48, 0, pid=44682] /SourceCache/samba/samba-235.5/samba/source/auth/auth_odsam.c:opendirectory_ntlmv2_auth_user(334)
dsDoNodeAuth gave -14090 [eDSAuthFailed]
[2011/02/02 08:59:48, 0, pid=44682] /SourceCache/samba/samba-235.5/samba/source/auth/auth_odsam.c:opendirectory_smb_pwd_check_ntlmv2(450)
opendirectory_ntlmv2_auth_user gave -14090 [eDSAuthFailed]
[2011/02/02 08:59:48, 0, pid=44682] /SourceCache/samba/samba-235.5/samba/source/auth/auth_odsam.c:opendirectory_opendirectory_ntlm_password_check(572)
opendirectory_smb_pwd_check_ntlmv2 gave -14090 [eDSAuthFailed]
[2011/02/02 08:59:48, 2, pid=44682] /SourceCache/samba/samba-235.5/samba/source/auth/auth.c:check_ntlm_password(319)
check_ntlm_password: Authentication for user [adkonto04] -> [adkonto04] FAILED with error NT_STATUS_WRONG_PASSWORD

Har någon några tips?

Mer skummt,

Om jag ansluter till vår OSX server med smb:// från en mac bunden i ADt så började det fungera sedan jag lade gruppen från ADt i posix.
Men det fungerar fortfarande inte från PC, varesig de är bundna i ADt eller inte.

Problemet löst..

AD DNS gav servern "fel" namn.. DNS strikes again..

Kul att det löste sig, men att DNS:en skulle ge servern fel namn låter konstigt.
DNS:er delar inte ut namn utan namn registreras i DNS:en.
Här kommer tre vanliga exempel på hur namn registreras i DNS

1. Har du en server som du döpt till 99-server så säger denna till dns:en att den heter 99-server och nås på ip xxx.xxx.xxx.xxx så registrera DNS:en detta.

2. Om man använder dhcp kan man även låta dhcp servern registrera namn i DNS:en, det går då till så att den delar ut ett ip till en klient, frågar vad denna heter i vårt exempel så skulle så svarar servern 99-server, DHCP-server säger då till DNS:en att registrera namnet 99-server mot ip-numret den gav till 99-server.
3. Man kan även registrera manuellt, alltså handknacka in att 99-server nås på ip-nummer xxx.xxx.xxx.xxx .

Sen finns det ju massa andra saker som kan gått fel men DNS:er delar vanligtvis inte ut namn.

  • Oregistrerad
  • 2011-02-24 20:27
Ursprungligen av nicke30:

Problemet löst..

AD DNS gav servern "fel" namn.. DNS strikes again..

Hur menar du? Din xserves hade fel namn?

1
Bevaka tråden