iWork - Pages - Hur ändra "kr" till "SEK"?

Tråden skapades och har fått 8 svar. Det senaste inlägget skrevs .
1

Använder Pages för fakturor. Men den skriver "kr" (som vi övergav för 20 år sen) i stället för "SEK".
Hur/var kan jag ändra detta?

(Har Mac OS 10.5.8 och Pages 08, version 3.0.3.)

  • Medlem
  • Finland
  • 2011-01-16 22:52

10.5: Set custom number and currency formats - Mac OS X Hints

Skriv in det här i Terminalen

defaults write -g AppleICUNumberSymbols -dict 8 'SEK'

Sen gär du till Preferences > International > Language & Text > Formats så borde SEK vara som "symbol" Svenska kronor. Jag har engelskt system men du fattar säkert vart du ska gå i system inställningarna

Jag tar naturligtvis inget ansvar vad du ändrar i systemet, ett litet tillägg bara.

Ursprungligen av Peppe:

10.5: Set custom number and currency formats - Mac OS X Hints

Skriv in det här i Terminalen

defaults write -g AppleICUNumberSymbols -dict 8 'SEK'

Sen gär du till Preferences > International > Language & Text > Formats så borde SEK vara som "symbol" Svenska kronor. Jag har engelskt system men du fattar säkert vart du ska gå i system inställningarna

Jag tar naturligtvis inget ansvar vad du ändrar i systemet, ett litet tillägg bara.

Funkar i Preferences, men slår inte igenom i Pages. Där har jag fortfarande "kr", trots bl.a. omstart.

Edit: Förresten, snubben som skrivit det där du länkade till i MacOS Hints har också lagt till en brasklapp:

[robg adds: This worked as described, and seems to be the only way to customize the number formats -- the International System Preferences panel includes a Customize button for Dates and Times, but not for Numbers. I don't know if this only works in 10.5, but the hint was submitted that way, so I've left it marked as such.]

Han fick det alltså inte att funka i Numbers och då verkar det ju dessutom vara något som är programspecifikt...

Senast redigerat 2011-01-17 08:21
  • Medlem
  • White Beach, Puerto Galera
  • 2011-01-16 23:22

He he...perfekt. Tackar.

  • Medlem
  • Finland
  • 2011-01-17 09:22

En annan sak jag kan komma på nu är att i "Preferences" > "Auto Correction" göra en ny regel för "kr" som ändras till "SEK".
Jag hoppas du förstår vad jag menar.

Ursprungligen av Peppe:

En annan sak jag kan komma på nu är att i "Preferences" > "Auto Correction" göra en ny regel för "kr" som ändras till "SEK".
Jag hoppas du förstår vad jag menar.

Tack men tyvärr. Jag testade det innan jag startade tråden (glömde skriva det, sorry).

Har letat igenom hela datorn efter något dokument som styr detta. Öppnat Pages (Package contents), gått igenom alla tänkbara plistfiler, men hittar inget alls.

Man har en snygg, funktionell fakturamall. Åsså står det "kr" som man slutade med 1974 eller nåt. Suck..

  • Medlem
  • Borgholm
  • 2011-01-17 22:42

Från granskaren väljer du Celler och sedan Cellformat -> Välj sedan Anpassa.. -> Anpassa formatet som du vill ha det följt av texten SEK.

Ursprungligen av BengtE:

Från granskaren väljer du Celler och sedan Cellformat -> Välj sedan Anpassa.. -> Anpassa formatet som du vill ha det följt av texten SEK.

Tack, men jag kan inte göra detta. Verkar inte ens ha de möjligheterna. Jag kör Pages 3.0.3 och du kanske har en annan version? (Jag har förresten engelskt gränssnitt)

Men nöden är uppfinningarnas moder. Jag skapade helt enkelt en kolumn före summorna där jag skrivit in "SEK". Och cellerna för summorna har jag ändrat från "Currency" till "Numbers" och därmed försvinner valutaförkortningen.

  • Medlem
  • Borgholm
  • 2011-01-25 08:20

> Jag kör Pages 3.0.3 och du kanske har en annan version?
Jag kör "senaste" Pages (Kallas Pages 9 men versionsnummret är 4.x någonting).

1
Bevaka tråden