99mac 4.06: Buggar och osnyggheter feedback-tråd

Tråden skapades och har fått 62 svar. Det senaste inlägget skrevs .

Idag släpper vi 99mac 4.06 som främst består av efterlängtade buggfixar.

Denna vecka har vi börjat jobba med en ny medlem i utvecklarteamet - Klara eller klarabara som hon kallas för här på 99mac har hoppat in som designer och hjälper till att dra riktlinjerna för nästa lite större uppdatering 99mac 4.10 som släpps nästa fredag.

Lite trist att behöva fokusera på buggfixar istället för nya funktioner men det måste göras...
Vi har haft mycket problem med gamla Internet Explorer versioner som beter sig helt annorlunda än moderna webbläsare vilket tagit många timmar men nu borde det mesta fungera.

Detta är fortsättningen på 99mac 4.04 buggar & osnyggheter tråden och målet är att vi trampat sönder dom flesta buggarna under dom första två veckorna 2011 med version 4.05 och 4.06.

Nya funktioner

  • 99store är tillbaka igen på99.se/store/och finns återigen i bruna menyraden.

  • 99store inloggningen fungerar för alla webbläsare.

Förbättringar för Internet Explorer användare

Förbättringar av sajten

  • Sidorna visas korrekt vid citering och "snabbsvar".

  • Länkarna till RSS prenumerationer är uppdaterade.

  • Bilagor till inlägg presenteras bättre.

  • Annonser i inlägg krockar inte längre med innehåll.

  • Svarta menyraden är något större och lättare att klicka på med iPad.

  • "Vad är på gång" längst ner på forumsidan är justerad så att inloggade medlemmar fyller hela sidbredden.

Förändringar i forumupplägget

  • Forumet för utveckling heter nu "Utveckling för Mac & IOS enheter".

  • Rapporteringstexten för foruminlägg är uppdaterad.

  • Funktionen för att skicka tips via email om intressanta trådar är fixad.

Ett antal buggar (och önskemål om kommande funktionalitet) har uppmärksammats och ligger planerade för kommande uppdateringar:

  • Facebook Connect registrering av nya medlemmar är tillfälligt avstängd.

iPad/iPhone specifika buggar har en egen feedback-tråd:
http://www.99.se/feedback/283034-feedback-99mac-4-0-4-01-ipad.html

Senast redigerat 2011-01-14 12:28

Vi fick lite problem vid uppdateringen men nu är vi tillbaka igen med 99mac 4.06!

Ursprungligen av Björnström:

Vi fick lite problem vid uppdateringen men nu är vi tillbaka igen med 99mac 4.06!

Jag tror jag beställde en dator innan allt funkade helt och hållet. Hoppas beställningen kommer fram till Digital Inn, särskilt med tanke på att betalningsbiten funkade så pass bra att rätt summa drogs från mitt bankkonto. Jag har inte fått nåt bekräftelsemail ännu...

Till detta har jag också en buggrapport (som jag inte kan verifiera längre pga tomt på bankkontot ): SSL-certifikatet gäller för 99.se och inte 99mac - Förstasidan. Jag struntade i varningarna och gick vidare och det såg ut att gå bra, så ingen stor fara på taket även om det fortfarande behövs ett nytt cert, men den som inte förstår den tekniska innebörden av felmeddelandet kanske blir rädd.

Ursprungligen av tageborg:

Till detta har jag också en buggrapport (som jag inte kan verifiera längre pga tomt på bankkontot ): SSL-certifikatet gäller för 99.se och inte 99mac - Förstasidan. Jag struntade i varningarna och gick vidare och det såg ut att gå bra, så ingen stor fara på taket även om det fortfarande behövs ett nytt cert, men den som inte förstår den tekniska innebörden av felmeddelandet kanske blir rädd.

Tack för tipset - beror på att vi flyttat från store .99.se till www .99.se. Beställer ett nytt certifikat och installerar senast måndag!

Ursprungligen av Björnström:

Tack för tipset - beror på att vi flyttat från store .99.se till www .99.se. Beställer ett nytt certifikat och installerar senast måndag!

Certifikatet beställt - borde komma inom någon timme. Då installerar jag direkt!

Ursprungligen av Björnström:

Certifikatet beställt - borde komma inom någon timme. Då installerar jag direkt!

Nu är SSL certifikatet installerat och felmeddelandet när man går till kassan i /store/ är nu fixat!

http://www.99.se/store/kontakta_oss/ saknas... finns länkad till från alla sidor på Digital Inn AB

Liksom http://www.99.se/villkor.html (som likaledes är länkad till på alla sidor i affären)

Ursprungligen av tageborg:

http://www.99.se/store/kontakta_oss/ saknas... finns länkad till från alla sidor på Digital Inn AB

Liksom http://www.99.se/villkor.html (som likaledes är länkad till på alla sidor i affären)

Tack - har markerat som bugg och fixas snarast!

Det visade sig att en fix ledde till en annan bugg, har det hänt förut? Jag hade jobbat med "posthead" (det grå fältet överst i varje inlägg) för att på flera ställen blivit problem med att texten i inlägget bara blev en smal spalt (bland annat i IE7 och eller när man t.ex. klickade på Redigera-länken). Jag fixade de problemen, men sen visade det sig att i Safari så blev inte posthead så bred som den skulle (såg utmärkt ut i Firefox och andra webbläsare). För att göra en lång historia kort, till er som hann se detta: Nu är det löst

Var är alla glädjetjut från IE7-användare?

  • Medlem
  • Skövde
  • 2011-01-14 16:34
Ursprungligen av Adrian B:

Var är alla glädjetjut från IE7-användare?

Vänta, jag börjar inte jobba förrän ikväll

  • Medlem
  • Skövde
  • 2011-01-14 23:09
Ursprungligen av Adrian B:

Var är alla glädjetjut från IE7-användare?

Tjohoo! Det fungerar! IE8 XP

  • Medlem
  • International user
  • 2011-01-14 18:29

Bara för mig alla inlägg blev förskjutna neråt?
Se bild.

Kör FF

Ursprungligen av zappee:

Bara för mig alla inlägg blev förskjutna neråt?
Se bild.

Kör FF

Samma här. Den där gråa raden förskjuten under handle och avatar i alla inlägg. FF.

Ursprungligen av zappee:

Bara för mig alla inlägg blev förskjutna neråt?
Se bild.

Kör FF

Wtf... Jag har testat i både FF/win och FF/mac och såg aldrig det där (och kan inte återskapa det nu heller). Det kanske är en självklarhet, men har du testa att ladda om en extra gång?

Vilken version av Firefox kör du?

  • Medlem
  • International user
  • 2011-01-15 00:57
Ursprungligen av Adrian B:

Wtf... Jag har testat i både FF/win och FF/mac och såg aldrig det där (och kan inte återskapa det nu heller). Det kanske är en självklarhet, men har du testa att ladda om en extra gång?

Vilken version av Firefox kör du?

Jo, har testat ladda om och jag verkar inte vara ensam.

3.6.13

Ursprungligen av zappee:

Jo, har testat ladda om och jag verkar inte vara ensam.

3.6.13

Skumt, det är ju precis samma version som jag kör. Och här ser allt bra ut.

Hmm... en tanke: det kanske har något att göra med att jag har adminrättigheter och därför ser "posthead" annorlunda ut för mig. Det är den enda skillnaden jag kan komma på. Ska testa och återkommer.

  • Medlem
  • Umeå
  • 2011-01-15 11:52
Ursprungligen av zappee:

Jo, har testat ladda om och jag verkar inte vara ensam.

3.6.13

Jag har också FF 3.6.13 och har inte dessa problem

"Utveckling för Mac & IOS enheter" är inte riktigt rätt rent språkligt. Det borde stå "Utveckling för Mac & iOS-enheter", tycker jag.

Ursprungligen av gabriel.fjellander:

"Utveckling för Mac & IOS enheter" är inte riktigt rätt rent språkligt. Det borde stå "Utveckling för Mac & iOS-enheter", tycker jag.

Det tycker jag med, så jag har ändrat nu. Martin är lite "internationell" med sina stora bokstäver på månader, särskrivningar mm, men jag brukar städa upp det

Ursprungligen av Adrian B:

Det tycker jag med, så jag har ändrat nu. Martin är lite "internationell" med sina stora bokstäver på månader, särskrivningar mm, men jag brukar städa upp det

I framtiden kommer alla skriva som jag

Ursprungligen av Björnström:

I framtiden kommer alla skriva som jag

Vissa förändringar är sunda och kommer att ske, andra inte. Annars blir det blir jobbigt när du ska besöka en sjuk gymnast, beställa lite kyckling lever i affären och låser in dina pengar i kassa skåp...

FF 3.6.13/Win:

  • Medlem
  • Hillared
  • 2011-01-15 12:24

Kan inte vara så att det är något tillägg som spökar för er?

  • Medlem
  • International user
  • 2011-01-15 13:56
Ursprungligen av Drakfot:

Kan inte vara så att det är något tillägg som spökar för er?

Kan mycket väl vara något på min dator, men det kom i samband med 4.06. Så någon förändring lär ju hänt där.

Edit: Testade med en helt ny profil i FF och då fungerade. Något skumt i min FF-profil som spökar då... suck.

Ursprungligen av zappee:

Kan mycket väl vara något på min dator, men det kom i samband med 4.06. Så någon förändring lär ju hänt där.

Edit: Testade med en helt ny profil i FF och då fungerade. Något skumt i min FF-profil som spökar då... suck.

Men du är inte ensam om problemet, så det måste vara någonting som gör att vissa ser det. Vad sjutton det nu är.

  • Medlem
  • International user
  • 2011-01-15 15:29
Ursprungligen av Adrian B:

Men du är inte ensam om problemet, så det måste vara någonting som gör att vissa ser det. Vad sjutton det nu är.

Du kan avskriva mig i alla fall, jag la lite tid på att fixa en ny profil. Behövs alltid rensas

Ursprungligen av Adrian B:

Men du är inte ensam om problemet, så det måste vara någonting som gör att vissa ser det. Vad sjutton det nu är.

Jag vet inte om ni gjort något, men problemet är fixat nu. Har inte, vad jag vet, gjort några inställningar på min bläddrare.

  • Medlem
  • International user
  • 2011-01-16 09:23

Hm, nya problem.

När man tryckte på "Fler" ovanför varje inlägg kunde man dubbelcitera/multicitera. När jag trycker på fler nu så öppnas en dropdown, men den syns inte fullt ut. Den går bara ner till kanten av den lilla ramen

  • Medlem
  • Hillared
  • 2011-01-16 09:42
Ursprungligen av zappee:

Hm, nya problem.

När man tryckte på "Fler" ovanför varje inlägg kunde man dubbelcitera/multicitera. När jag trycker på fler nu så öppnas en dropdown, men den syns inte fullt ut. Den går bara ner till kanten av den lilla ramen

Jag upptäckte precis att jag har samma problem, drop downmenyn stannar inom ramen förmenyn där "Fler" finns och visas inte utanför det lagret. Safari 5.0.3.

Bevaka tråden