Bara grå skärm efter HD-byte?

Tråden skapades och har fått 9 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Stockholm
  • 2010-11-18 19:15

Jag fick för ett par dagar sedan strul med min HD på min min MPpro 13". Köpte en ny idag och tog ur den gamla. Det var inga direkta problem där. Men sen när jag skulle installera OSX på den nya så hittade den inte någon HD. Inte heller i Skivhanteraren. Har bytt på andra innan och har för mig att man hittar disken, men får formatera den i Skivhanteraren. Misstänkte därför att det var något problem med min nya HD och åkte tillbaka till butiken. De sa att man först måste aktivera den. De satte in den i en sladd till datorn och fixade det. Dock ingen formatering då de hade en Windowsdator.

Stoppade sedan in den i min dator och nu går det över huvud taget inte att starta någonting. Inte installeringsskivan genom att trycka på C vid uppstart, inte gå in i target mode med T, inte välja uppstart med alt och inte heller få ur installeringsskivan med mustryck. Jag får bara upp en ljus skärm, dvd-spelaren snurrar igång och hackar lite och sedan står allt stilla. Samma sak händer oavsett vad jag trycker på.

Vet någon vad som kan ha gått galet? Finns det något annat man kan försöka med? Är det något ytterligare hårdvarufel som man måste lämna in för. Den är ca. 1 år gammal så jag är inte helt säker på att det finns någon garanti kvar.

  • Medlem
  • Lund
  • 2010-11-18 19:22

Har du kollat så att det verkligen var fel på din ursprungliga HD, genom att sätta den i en annan dator, eller åtminstone koppla in den till annan dator? Det kan ju vara så att felet inte låg i HDn utan i logikkortet på din MBP!?

  • Medlem
  • Stockholm
  • 2010-11-18 20:09

HDn bör det ha varit fel på. Datorn låste sig plötsligt. Försökte kolla och reparera den med Skivhanteraren. Den hittade fel men kunde inte fixa det. Körde datorn i targetmode och försökte fixa den från min andra dator. Inte heller den lyckades. Men efter ett par försök dök åter HDn upp i Finder. Lyfte över det jag ville ha kvar till en annan extern HD. Lyckades flera gånger att starta från skiva, köra i targetmode och välja var den skulle boota. Men helt plötsligt funkar inte det längre och jag får bara en vit/grå skärm.

Kan det vara logikkortet trots att hårddisken betedde sig som den gjorde? Går det/är det lönt att byta logickortet eller är det bara att hiva datorn?

  • Medlem
  • Stockholm
  • 2010-11-18 20:11

Jag kan lägga till att jag får det där "doingljudet" som man får vid uppstart. dvd-spelaren letar, snurrar och läser på skivan i typ 40s och sedan är allt tyst.

  • Medlem
  • Stockholm
  • 2010-11-18 20:27

Nu har jag testat lite ytterligare. Tar jag ur den nya HDn går det att få ut skivan och starta i targetmode. Stoppar jag i den gamla gäller samma sak. Jag ser gamla hårddisken över FW från min andra dator, men bara i Skivverktyg. Stoppar jag i den nya HDn blir den lika död som tidigare.

När jag först testade efter att ha köpt HDn startade den från skivan, men den hittade inte någon HD i installationsprogrammets Skivhanterare. Jag gick tillbaka och de "aktiverade" den (kommer inte på vad det igentligen heter) och efter det låses hela datorn om den sitter i.

Hårddisken är en Seagate Momentus 720 500GB (om nu det skulle betyda eller hjälpa något).

  • Medlem
  • Stockholm
  • 2010-11-18 20:51

Har nu testat med att starta från installationsskiva, men utan HD instoppad. När programmet är startat trycker jag in sladden i min nya HD. Skivverktyg hittar inte min HD utan bara DVD. Är det därför att den inte satt i från start? När de i affären stoppade in den i en satakabel dök den direkt upp i windows variant av Skivverktyg (eller vad det var) där han i affären initierade den (eller vd det heter), partionerade inte. Kan det vara fel på min HD? Blev det fel när han i affären initierade den? Eller kan det fortfarande vara mitt logickort?

Ibland undrar man varför man ger sig in i saker man inte förstår. Men efteråt känns det oftast rätt bra då man förmodligen har lärt sig något nytt.

  • Medlem
  • Lund
  • 2010-11-19 00:30

Att filstrukturen var korrupt på den första HDn och att skivverktyg inte kunde reparera den, betyder inte att den var kass i sig. Efter att du tagit back-up på allt kunde du formatterat om den och installerat nytt os. Om detta inte var görbart, kan det betyda att den delen av logikkortet som hanterar HDn (SATA-controllern) kan vara kass. En ny hårddisk behöver normalt inte aktiveras, men däremot formateras och partioneras om den skall vara startskiva i OS X. Synd att du bor 60 mil härifrån, annars hade jag kommit förbi och hjälpt dig. Det blir litet svårare när man inte har grejorna framför sig.

  • Medlem
  • Stockholm
  • 2010-11-19 07:45

Försökte formatera den min gamla HD med sivverktyget i installationsprogrammet men datorn står då bara och snurrar med badbollen.

  • Medlem
  • Stockholm
  • 2010-11-19 08:00

Kand det vara logikkortet som är paj om datorn kommer åt den ena hårddisken men inte den andra?

  • Medlem
  • Sundsvall
  • 2010-11-19 10:11

Gå in på Kjell.com. Sök på 68261. Köp en sådan, bra att ha!
Stoppa in din nya HD i den. Koppla till datorn. Starta från DVD:n. Välj Skivverktyg. Formatera skivan enligt konstens alla regler. Installera MacOSX på HD:n. Stäng av datorn. Sätt in HD i datorn. Starta om med "alt" intryckt. Välj din HD och tryck retur. Sätt in din gamla HD i kabinettet. Reparera med Skivverktyg eller om det inte fungerar använd DiskWarrior (Alsoft, Inc. Makers of DiskWarrior. The Disk Utility for Mac Disk Repair, Mac Directory Repair, Mac Disk Recovery and Mac Data Recovery) eller DriveGenius (Data Recovery Software, Hard Drive Data/File Recovery Software - Windows/Mac). De gör lite olika saker så båda är nästan nödvändiga i en Macägares "portfolio". För över det du vill ha kvar från din gamla HD, antingen med Flyttassistenten eller manuellt.

Får jag betalt av Alsoft och ProSoft varje gång jag nämner ovanstående program? I wish...

1
Bevaka tråden