Extern skärm fungerar inte efter uppdatering till 10.6.5

Tråden skapades och har fått 35 svar. Det senaste inlägget skrevs .
  • Skribent
  • Sollentuna
  • 2010-11-12 23:48

Jag har en 21,5" iMac (mid 2010) med en extra skärm (BenQ 21,5"). Efter uppdateringen till 10.6.5 slutade den externa skärmen funka. Den syns fortfarande i inställningarna, och skrivbordet är utökat över två skärmar, men den är helt svart. Den tycks få signal också, för om jag rycker kabeln så klagar den på att den inte får nån signal längre.

Det funkade utmärkt innan och under uppdateringen, det var vid omstarten den blev svart.

Några idéer? Jag är mac-noob, så det kan hända att jag har missat nån felsökningsväg. Hur som helst verkar det väldigt osannolikt att skärmen skulle gå sönder precis i samband med omstarten efter uppdateringen.

  • Medlem
  • International user
  • 2010-11-12 23:57
Ursprungligen av Vassius:

Jag har en 21,5" iMac (mid 2010) med en extra skärm (BenQ 21,5"). Efter uppdateringen till 10.6.5 slutade den externa skärmen funka. Den syns fortfarande i inställningarna, och skrivbordet är utökat över två skärmar, men den är helt svart. Den tycks få signal också, för om jag rycker kabeln så klagar den på att den inte får nån signal längre.

Det funkade utmärkt innan och under uppdateringen, det var vid omstarten den blev svart.

Några idéer? Jag är mac-noob, så det kan hända att jag har missat nån felsökningsväg. Hur som helst verkar det väldigt osannolikt att skärmen skulle gå sönder precis i samband med omstarten efter uppdateringen.

Byt upplösning på externa skärmen. Eller så kanske har du skärmspegling aktiverat. Kan vara något av båda.

//Rob

  • Skribent
  • Sollentuna
  • 2010-11-13 00:03
Ursprungligen av Robo-X:

Byt upplösning på externa skärmen. Eller så kanske har du skärmspegling aktiverat. Kan vara något av båda.

//Rob

No luck. Har testat att slå av och på alla möjliga inställningar.

  • Skribent
  • Sollentuna
  • 2010-11-13 01:15

Efter tips på apples supportforum angående andra grafikrelaterade problem i samband med uppdateringen provade jag att installera uppdateringen manuellt med skärmen urkopplad.

Efter att ha kopplat in den igen kan jag konstatera: Still no luck.

Senast redigerat 2010-11-15 13:05
  • Skribent
  • Sollentuna
  • 2010-11-13 01:47

Nu har jag även testat en SMC-reset (enligt instruktioner från Intel-based Macs: Resetting the System Management Controller (SMC)) utan framgång.

Edit: Och för att utesluta hårdvarufel har jag kopplat in skärmen med samma kabel (minus mini-displayport->hdmi-adaptern) till min bärbara pc. Det funkar utmärkt.

Senast redigerat 2010-11-15 13:05

Ovanstående 5 inlägg har brutits ut och flyttats hit från en annan tråd.

Ett specifikt problem mår bättre av en egen tråd, än att gömmas i en sådan allmän tråd.

/Mod

  • Medlem
  • Lund
  • 2010-11-15 16:28

Har du provat skärmen med någon annan dator, så att du kan utesluta att det faktiskt inte är skärmen som är stekt?

Har samma problem med extern LCD TV - fungerade igår på 10.6.4 - idag ingen bild efter upppgrd. 10.6.5. Samma som ovan att signalen verkar nå fram till skärmen. Man kan ställa in utgående upplösning osv. Dock ingen bild alls på den externa. Har provat allt möjligt...

downgrade enda sättet?
siter på senaste iMac 27" som skall ge både ljud och bild via MDP. använder i detta fall en MDP > HDMI skarv från Apple.

Idéer någon? Vassius..har du lyckats lösa det hela?

mvh /D

  • Skribent
  • Sollentuna
  • 2010-11-17 12:01

Det är definitivt inget hårdvarufel, för skärmen funkar när jag startar iMacen från installationsskivan som följde med. Med OS X 10.6.5 startat funkar det när jag kopplar in frugans skärm. Men min egen är helt svart fortfarande.

Edit: Tack Jesper!

Prova med att återställa PRAM.

Återställa Mac-datorns PRAM och NVRAM

  • Skribent
  • Sollentuna
  • 2010-11-17 12:52
Ursprungligen av Jesper Ohlsson:

Prova med att återställa PRAM.

Återställa Mac-datorns PRAM och NVRAM

Har redan testat det utan framgång, men ska testa igen med lite olika varianter när jag kommer hem.

Är det fler saker du redan har provat, utan att berätta för oss?

Så att vi slipper slösa ännu mer tid (för dig, men framför allt för oss) på att tipsa om sådant du redan har provat...

Prova att installera 10.6.5-uppdateringen igen, men använd "Combo"-versionen av uppdateringen. Det brukar kunna fixa lite konstiga fel ibland.

Mac OS X v10.6.5 Update (Combo)

  • Skribent
  • Sollentuna
  • 2010-11-17 14:26
Ursprungligen av Jesper Ohlsson:

Är det fler saker du redan har provat, utan att berätta för oss?

Så att vi slipper slösa ännu mer tid (för dig, men framför allt för oss) på att tipsa om sådant du redan har provat...

Sorry, sitter på jobbet och har mest jobb i huvet. Tänkte inte på att det vore lämpligt att redogöra för det jag har provat.

Har testat combo-uppgraderingen också, det var den jag syftade på i mitt tredje inlägg (insåg inte att det var skillnad på combo och den vanliga; Mac-noob som sagt).

Det enda ytterligare jag kommer på att jag har provat är att radera /Library/Preferences/com.apple.windowserver.plist

Ursprungligen av Vassius:

...insåg inte att det var skillnad på combo och den vanliga...

Combo = innehåller alla 10.6-uppdateringar, och kan alltså uppdatera alla versioner (10.6, 10.6.1, 10.6.2, 10.6.3, 10.6.4) till 10.6.5

"den vanliga" (brukar kallas Delta, tror jag) = kan bara uppdatera från 10.6.4 till 10.6.5

  • Skribent
  • Sollentuna
  • 2010-11-17 16:58

Har fortfarande inte fått det att funka. För att vara riktigt grundlig kombinerade jag de tips jag har fått och utförde följande på raken:

1. Koppla ur skärmen
2. Radera /Library/Preferences/com.apple.windowserver.plist
3. Reparera skivbehörigheter
4. Resetta SMC
5. Resetta PRAM
6. Installera combo
7. Reparera skivbehörigheter

Det vill fortfarande inte funka, och det börjar bli väldigt frustrerande. En av poängerna med att köra Apple-prylar är ju att allt bara ska funka, trodde jag iaf.

När jag kopplade in skärmen efter ovanstående (eller ungefär då iaf) fick jag följande meddelande i Systemmeddelanden:

2010-11-17 16.43.50	com.apple.WindowServer[72]	Wed Nov 17 16:43:50 Markus-iMac.local WindowServer[72] <Error>: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.

Vet inte om det har nån relevans dock.

  • Medlem
  • Göteborg
  • 2010-11-18 13:04

Har du testat att döda strömmen till skärmen? alltså itne bara stänga av den, utan dra ur strömsladden.

Jag hade problem med att en skärm vägrade ge mig rätt upplösning som löstes av att dra ur strömmen, låta den vara ur en stund så inget minne finns lagrat kvar, sen koppla in den igen.

låter simpelt men kan funka!

  • Skribent
  • Sollentuna
  • 2010-11-18 17:47
Ursprungligen av albinn:

Har du testat att döda strömmen till skärmen? alltså itne bara stänga av den, utan dra ur strömsladden.

Hade den urdragen i över en timme. Funkar fortfarande inte.

  • Medlem
  • International user
  • 2010-11-19 00:17

Har du bytt upplösningen på skärmen? Jag tror att Macen provar på en upplösning som skärmen inte klarar av och därför är den svart.

//Rob

  • Skribent
  • Sollentuna
  • 2010-11-19 11:48
Ursprungligen av Robo-X:

Har du bytt upplösningen på skärmen? Jag tror att Macen provar på en upplösning som skärmen inte klarar av och därför är den svart.

//Rob

Den är inställd på 1920x1080, vilket är skärmens nativeupplösning. Har testat lägre upplösningar också, utan framgång.

  • Medlem
  • International user
  • 2010-11-19 11:56

Har du provat att byta till lägre upplösning för att se om den kommer igång?

//Rob

  • Skribent
  • Sollentuna
  • 2010-11-19 16:47
Ursprungligen av Robo-X:

Har du provat att byta till lägre upplösning för att se om den kommer igång?

//Rob

Ja, som sagt.

  • Medlem
  • International user
  • 2010-11-19 17:09

Hur kopplar du in den? Kan du växla mellan digital och analog? Kanske är det fel på kabeln eller så har Apple ha byggt in en bugg i senaste versionen av grafik drivisar.

//Rob

  • Skribent
  • Sollentuna
  • 2010-11-19 19:02
Ursprungligen av Robo-X:

Hur kopplar du in den? Kan du växla mellan digital och analog? Kanske är det fel på kabeln eller så har Apple ha byggt in en bugg i senaste versionen av grafik drivisar.

//Rob

Jag kör MDP->hdmi-adapter och en hdmi->dvi-kabel.

Den externa skärmen får bild när jag startar datorn från installationsskivan med 10.6.4, så det är definitivt inget hårdvarufel.

När jag kopplar in frugans skärm får den bild utan problem.

  • Medlem
  • Lund
  • 2010-11-19 19:38

Riktigt skumt. Har du för skojs skull provat att skapa ett nytt användarkonto, för att se om det blir samma sak där?

  • Skribent
  • Sollentuna
  • 2010-11-19 21:39
Ursprungligen av Korsriddaren:

Riktigt skumt. Har du för skojs skull provat att skapa ett nytt användarkonto, för att se om det blir samma sak där?

Testade nu, utan resultat. Den externa skärmen ska ju tändas innan man kommer till inloggningsrutan, vilket den inte gör.

  • Skribent
  • Sollentuna
  • 2010-11-19 22:56

Nu har jag testat allt jag kan testa från den här listan:
Blank screens and improper resolution for external displays after installing 10.6.3 | MacFixIt - CNET Reviews

D.v.s. allt utom annan adapter och återställning av backup.

Vet inte om det har nån relevans, men jag är ganska säker på att min externa skärm blev tilldelad en profil med exakt samma namn som modellnamnet på skärmen första gången jag kopplade in den. Nu efter uppdateringen finns det inga modellspecifika profiler alls, bara en handfull generiska som det ser ut. Det känns inte som en felaktig icc-profil ska kunna sabba skärmen helt, eller..?

Hade det varit Windows skulle jag helt enkelt ha installerat om drivrutinerna för grafikkortet, och förmodligen hade det hjälpt. Eftersom ingen har föreslagit en sån lösning antar jag att det inte går att göra motsvarande på Mac. Eller har jag fel?

  • Skribent
  • Sollentuna
  • 2010-11-24 20:18

Nu har jag haft tid att testa lite mer.
Genomförde följande steg i ordning:

- Koppla ur skärmen
- PRAM-reset
- Starta i säkert läge
- Reparera behörigheter
- Rensa boot cache och annat med OnyX
- Installera combo-update
- Starta om i normalläge och koppla in skärmen

Resultat: Fortfarande svart skärm.

Kopplade in frugans Dell-skärm, vilket funkar utmärkt. Startade om med den ikopplad. Funkar fortfarande. Bytte till min egen skärm. Fortfarande svart.

Det har gått så långt att jag överväger att reklamera min iMac. Det här är ju helt galet.

Ursprungligen av Vassius:

Jag kör MDP->hdmi-adapter och en hdmi->dvi-kabel.

Ursprungligen av Vassius:

Kopplade in frugans Dell-skärm, vilket funkar utmärkt.

Använde du exakt samma kombination av adapters och kablar när du kopplade in Dell-skärmen?

Har du provat någon annan koppling, t.ex att gå direkt från MDP till DVI, utan att gå omvägen via HDMI?

  • Skribent
  • Sollentuna
  • 2010-11-25 10:53
Ursprungligen av Jesper Ohlsson:

Använde du exakt samma kombination av adapters och kablar när du kopplade in Dell-skärmen?

Har du provat någon annan koppling, t.ex att gå direkt från MDP till DVI, utan att gå omvägen via HDMI?

Jag använde samma adapter, och en motsvarande hdmi->dvi-kabel, men inte exakt samma kabel. Ska testa det när jag kommer hem bara för att vara säker.

Har inte testat en annan adapter än. För 279:- vill jag helst vara säker på att det kommer att hjälpa.

Edit: Det visade sig att en kollega har en adapter att låna ut, så jag kan förhoppningsvis testa imorn.

Ursprungligen av Robo-X:

Nu är jag ingen expert på DHCP och externa skärmar men kan det vara så att din skärm inte stödjer DHCP signalen och Apple kräver det i 10.6.5? Som jag sa så vet jag inte vad det kan bero på men någon kombination av signal/upplösning/kabeladaper som inte fungerar med din skärm och 10.6.5.

Antar att du menar HDCP. Min skärm ska stödja det enligt specen. Efter en snabb googling verkar det som att det bara är ett problem om man ska spela upp DRM-skyddat material. Men klart värt att undersöka vidare!

Citat:

TS, har du föresten varit i kontakt med skärmtillverkaren och hört om de fått in fler sådana rapporter om felet du beskriver? De kanske har en lösning till dig.

Ska kolla det.

Senast redigerat 2010-11-25 11:07
Bevaka tråden