Problem med för tidigt ljud vid videouppspelning.

Tråden skapades och har fått 15 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Östhammar
  • 2010-10-27 20:43

Hallå!

Nyligen så har jag fått problem med videouppspelning på min mac mini. Det är (tror jag om jag inte missat en uppdatering) förra generationens mini som kör 10.6.4, 2gb minne.
Jag har den kopplad direkt till min tv samt min tvåkanals-förstärkare(Det bör inte var något fel här. Det har fungerat tidigare och jag har inte ändrat något i den konfigurationen).
Problemet är detta: Ljudet kommer innan bilden. Beroende på vad för fil och vilket program jag använder så blir fördröjningen mellan ljuder och bilden från ca 0.25s. Använder jag vlc för t.e.x. avi-filer så ligger det runt dessa tider. Använder jag plex vid uppspelningen är det flera sekunder, så pass mycket att kompenseringsverktyget i plex inte klarar av att styra upp det. Hur som är det jävligt irriterande att behöva pilla med ljudet varje gång man ska kolla på något. En sak att notera är att startar jag om datorn så blir fördröjningen mindre, stoppar jag filmen och startar den igen, alternativt spelar framåt långa sekvenser blir det mer påtagligt. Jag har inte installerat någon ny mjukvara senaste tiden vad jag kan komma ihåg.
Någon som har någon idé om vad som kan vara fel och vad jag kan göra för att styra upp det här? En ominstallation vore ju det självklara att prova, tyvärr ligger mina skivor hemma hos mina föräldrar. Skulle vilja lösa problemet innan torsdag då jag får hem mitt nya ljudsystem.

Vore mycket tacksam för hjälp!
mvh

(Jag var lite osäker på om jag skulle placera tråden här eller någon annanstans, men i och med att problemet uppträder i flera olika program, visserligen i varierande grad, så tror jag att det är något med os x som är galet.)

Det ligger troligtvis i din TV. Har du möjlighet att justera ljudfördröjningen in din förstärkare?

  • Medlem
  • Östhammar
  • 2010-10-27 21:15

Hm, tvn spelar ju inte upp något ljud ö.h.t. som det ser ut nu, allt går direkt till förstärkaren. Nej, det har jag tyvärr inte... Är en vanlig simpel 2.0-stärkare, en NAD av något slag. Och som sagt, det har ju fungerat tidigare med samma konfiguration. Samt att det blir bättre vid omstart av datorn, vilket jag tycker tyder på någon form av mjukvaruproblem. Eller är jag ute och cyklar?

Det är vanligt att TV/projektor tar tid att processa bilden. Spelar du upp ljudet i extern enhet så måste du fördröja ljudet för att få synk.

  • Medlem
  • Östhammar
  • 2010-10-28 04:41

Ah, då är jag med på ditt resonemang.

Men! Hur kan det komma sig att det här uppenbarar sig nu? Jag har kört såhär över två år, lite drygt ett år med minin och ett år med en gammal sleten macbook. Alltid utan några som helst problem. Och hur kommer det sig att fördröjningen är olika mellan t.e.x. vlc och plex? Det är här jag inte riktigt förstår.

Men okej, vi antar att det nu mystiskt blivit något fel med tvn. Hur styr jag upp en synkronisering av bilden mjukvarumässigt, i och med att jag inte har möjlighet att göra det på förstärkaren? Visserligen kanske det finns möjlighet att göra det på nya förstärkaren... Hm.

Hur synkar det om du spelar upp det på enbart datorn ut utan tv eller förstärkare inkopplat?

  • Medlem
  • Östhammar
  • 2010-10-28 08:32

Det har jag tyvärr ingen möjlighet att prova, använder tvn som primär skärm och har ingen annan i närheten. :/ Fan jag blir inte klok på det här.

VLC och Plex är ju vitt skilda program med vitt skilda förutsättningar.. VLC kan ju spela upp allt från senap till knäckebröd men det är ju sällan en optimal upplevelse och hänger sig gärna när man spolar osv..
Vad är för typ av filer du kör och vilken upplösning?
Får du fördröjning även om du kopplar ur högtalarna och kör på minins interna alternativt hörlurar?
Hur har du kopplat, är det DVI, HDMI eller VGA?
Vad kör du i så fall för adapter och kablage?

  • Medlem
  • Östhammar
  • 2010-10-28 09:27
Ursprungligen av InPezonator:

VLC och Plex är ju vitt skilda program med vitt skilda förutsättningar.. VLC kan ju spela upp allt från senap till knäckebröd men det är ju sällan en optimal upplevelse och hänger sig gärna när man spolar osv..
Vad är för typ av filer du kör och vilken upplösning?
Får du fördröjning även om du kopplar ur högtalarna och kör på minins interna alternativt hörlurar?
Hur har du kopplat, är det DVI, HDMI eller VGA?
Vad kör du i så fall för adapter och kablage?

Där har du en poäng. I vlc kör jag avi-filer, 480p, alternativt 720p mkv, och i plex blir det 1080p mkv oftast. Kan det vara att burkjäveln blivit seg som sirap och helt enkel inte orkar längre? Minst fördröjning är det faktiskt när jag kör avi-filerna.. Det med högtalarna har jag faktiskt inte provat. Angående kablaget så är det mini displayport till en dp->hdmi-adapter och sen in i tvn. Märke är något no-name. Ljudet går 3.5mm->RCA in i förstärkaren.

Edit: just fan, kom på en sak nu! När jag först märkte av problemet hade jag just köpt en ny extern hårddisk. Hade sedan tidigare en 500gb usb 2.0, och köpte en ny 1tb med usb 2.0. Och usb ska ju inte vara allt för snällt mot processorn, kan det här vara boven? Fan att jag inte är hemma och kan prova >_<

Ursprungligen av Enkan:

Där har du en poäng. I vlc kör jag avi-filer, 480p, alternativt 720p mkv, och i plex blir det 1080p mkv oftast. Kan det vara att burkjäveln blivit seg som sirap och helt enkel inte orkar längre? Minst fördröjning är det faktiskt när jag kör avi-filerna.. Det med högtalarna har jag faktiskt inte provat. Angående kablaget så är det mini displayport till en dp->hdmi-adapter och sen in i tvn. Märke är något no-name. Ljudet går 3.5mm->RCA in i förstärkaren.

Edit: just fan, kom på en sak nu! När jag först märkte av problemet hade jag just köpt en ny extern hårddisk. Hade sedan tidigare en 500gb usb 2.0, och köpte en ny 1tb med usb 2.0. Och usb ska ju inte vara allt för snällt mot processorn, kan det här vara boven? Fan att jag inte är hemma och kan prova >_<

Känns som du har flera möjligheter till felkälla här..
Om du kör filmerna från extern media är det inte alls konstigt att du får problem, vidare förstår jag inte riktigt vadan de dubbla adaptrarna.
Testa att lägga en film lokalt på datorn så får du nästan säkert ett helt annat resultat...

  • Medlem
  • Östhammar
  • 2010-10-28 11:09
Ursprungligen av InPezonator:

Känns som du har flera möjligheter till felkälla här..
Om du kör filmerna från extern media är det inte alls konstigt att du får problem, vidare förstår jag inte riktigt vadan de dubbla adaptrarna.
Testa att lägga en film lokalt på datorn så får du nästan säkert ett helt annat resultat...

Det är förvisso sant, men de har fungerat klockrent från den äldre disken, och den nya är betydligt kvickare. Såg nu att jag skrev lite rörigt angående adaptrarna. Jag går från mini display till dvi, och från dvi i till hdmi. Det gör jag för att jag inte hittade någon adapter som gick direkt från mini dp till hdmi, och min tv har inte någon dvi-ingång. Jag har provat att köra från interna, men det blir samma problem där

Ursprungligen av Enkan:

Det är förvisso sant, men de har fungerat klockrent från den äldre disken, och den nya är betydligt kvickare. Såg nu att jag skrev lite rörigt angående adaptrarna. Jag går från mini display till dvi, och från dvi i till hdmi. Det gör jag för att jag inte hittade någon adapter som gick direkt från mini dp till hdmi, och min tv har inte någon dvi-ingång. Jag har provat att köra från interna, men det blir samma problem där

Den nya verkar inte vara kvickare, eventuellt på pappret men det kanske är något fel på disken.. Kan du testa disken hos en vän/släkting/granne och spela upp media?
Annars är det eventuellt ditt system som börjar bli lite trött..

  • Medlem
  • Östhammar
  • 2010-10-28 11:41
Ursprungligen av InPezonator:

Den nya verkar inte vara kvickare, eventuellt på pappret men det kanske är något fel på disken.. Kan du testa disken hos en vän/släkting/granne och spela upp media?
Annars är det eventuellt ditt system som börjar bli lite trött..

På pappret vet jag faktiskt inte hur det ser ut, utan det är i praktiken den är kvickare. T.e.x. Packa upp en 8gb-fil går ~25% fortare, föra över filer från externa till interna går drygt på uppskattningsvis 30% kortare tid osv. Nej, tyvärr kan jag inte det, inte innan nästa vecka i alla fall. Bor ute i skogen utan körkort ;P

Okej, om du bara testar att vanlig ominstallation då, utan att formatera disken då menar jag..
Att bo i skogen har sina nackdelar, mer fördelar dock

  • Medlem
  • Östhammar
  • 2010-10-28 13:39

Jo, jag är hemma om dryga timmen, tänkte börja med att koppla ur diskarna, hjälper inte det får far komma förbi med skivorna helt enkelt. Håller er uppdaterade

Precis, det är grymt skönt men drygt utan körkort.

Håller tummarna!
Du kan få låna mitt körkort om du vill, jag använder det så sällan i vilket fall..

1
Bevaka tråden