Problem med sortering av ÅÄÖ i Excel

Tråden skapades och har fått 12 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • 2010-08-26 19:14

När jag försöker sortera en kolumn i bokstavsordning kommer AÅÄ och OÖ intill varandra på min nya iMac. På gamla G5an och en pc fungerade det OK.
Någon inställning i Excel som ska ändras??

Ursprungligen av goran:

När jag försöker sortera en kolumn i bokstavsordning kommer AÅÄ och OÖ intill varandra på min nya iMac. På gamla G5an och en pc fungerade det OK.
Någon inställning i Excel som ska ändras??

Jag har inte märkt det förrän nu, men du har ju rätt. Du kan i alla fall enkelt åtgärda det genom att gå på menyn Excel>Alternativ>Anpassade listor och där göra en egen alfabetisk lista (ett tecken på varje rad) som du sen använder för sortering

Ursprungligen av Richard Rönnbäck:

Du kan i alla fall enkelt åtgärda det genom att gå på menyn Excel>Alternativ>Anpassade listor och där göra en egen alfabetisk lista (ett tecken på varje rad) som du sen använder för sortering

Jag provade detta men får det inte att fungera.

Jag har gjort en anpassad lista med:
A
B
C
osv

Det fungerar att sortera efter den listan om kolumnen som jag ska sortera bara innehåller A, P, Å, Ö, osv

Men det fungerar inte om kolumnen innehåller hela ord - typ Andersson, Åhlund, Pettersson, Östergren. Då kommer Å direkt efter A.

Ursprungligen av Jesper Ohlsson:

Jag provade detta men får det inte att fungera.

Jag har gjort en anpassad lista med:
A
B
C
osv

Det fungerar att sortera efter den listan om kolumnen som jag ska sortera bara innehåller A, P, Å, Ö, osv

Men det fungerar inte om kolumnen innehåller hela ord - typ Andersson, Åhlund, Pettersson, Östergren. Då kommer Å direkt efter A.

Det är nog ganska logiskt att Excel tolkar listorna ordagrant. Om man kunde använda Wild Cards uppstår lätt konflikter mellan olika listor. T.ex. skulle januari sorteras efter februari.

Ursprungligen av M. Sundbom:

Det är nog ganska logiskt att Excel tolkar listorna ordagrant. Om man kunde använda Wild Cards uppstår lätt konflikter mellan olika listor. T.ex. skulle januari sorteras efter februari.

Ja, visst är det logiskt att det fungerar så.

Men Richard sa att det skulle fungera.

För mig sorterar Excel fortfarande svenska tecken, både gemener och versaler, rätt (Mac Pro 3,1 Svensk Mac OS X 10.6.4, senaste uppdateringen av Office 2008).

2008 har dock ett annat problem med svenska tecken (som inte finns i 2004). Funktioner, t.ex. SUMMA(), kan matas in som summa(), SUMMA(), sUmMa() etc. Excel är inte skiftlägeskänslig när det gäller funktionsnamn, såvida de inte innehåller svenska tecken som måste skrivas med versaler. MÅNAD() och mÅnad() är ok, medan månad() genererar ett felmeddelande.

Ursprungligen av goran:

...Någon inställning i Excel som ska ändras??

Förmodligen inte i Excel men kanske i Mac OS X. Se mina inställningar, Svenska under "Ordning för sorterade listor!"

Bröt ut ovanstående fyra inlägg från nedanstående tråd:

http://www.99.se/microsoft/208941-tycker-ni-om-mac-office-2008-a-6.html

/Mod

Om man kör med engelska som språk i OSX så blir det så här, även om man har valt "Svenska" i "Ordning för sorterade listor" (se bilden i inlägg #4). Det verkar som om Excel struntar i den inställningen och går enbart efter operativsystemets inställda språk.

Någon som har hittat en lösning på problemet?

Excel 2008 sorterar i ordningen "aåäbc…oöpq…xyz" för mig (i stället för "abc…opq…xyzåäö".

Omständigheter:
• Excel -> Verktyg -> Språk… är inställt på "Svenska"
• Systeminställningar -> Språk och text -> Språk -> "Ordning för sorterade listor:" är inställd på "svenska"
• För hela systemet så ligger "Svenska" på första plats över föredragna språk (men listan är längre än så).
• Mac OS X 10.6.5

Att lägga upp en egen sorteringsordning ("abc…zåäö") i Excel funkar inte eftersom det är hela ord som ska sorteras.

Ursprungligen av eliashedberg:

Någon som har hittat en lösning på problemet?

Ja, att uppgradera till Office 2011. Där fungerar det.

Senast redigerat 2011-02-15 21:25
Ursprungligen av Jesper Ohlsson:

Ja, att uppgradera till Office 2011. Där fungerar det.

Hos mig fungerar sorteringen av svenska tecken även i Excel 2008.

Elias, prova att ta bort alla andra språk (du kan lägga tillbaka dem sen) och stäng Systeminställningar.
Prova att byta till annat språk för "Ordning för sorterade listor" och stäng inställningarna. Öppna igen och byt tillbaka till svenska.
Ev knas med preferences-filen kan fixas mha dessa åtgärder.

  • Medlem
  • Nacka
  • 2011-03-10 07:45

Hej!

Har samma problem

Excel 2011 - inställd på svenska
OS X 10 6 4 - inställd på svenska
Rutan ordning för listor är inställd på svenska

Misstänker ändå att det är SBS då jag är ny på Mac

Men jättetacksam för en lösning på problemet.

/J

1
Bevaka tråden