Kan inte använda mig utav ALT-kombinationerna på siffrorna

Tråden skapades och har fått 36 svar. Det senaste inlägget skrevs .
  • Medlem
  • Stockholm
  • 2010-07-17 19:21

Hej!

Jag har råkat ut för ett något mysko problem. Jag kan inte längre skriva specialtecken (såsom till exempel snabel-a) genom att hålla inne ALT-knappen och sedan trycka på siffertangenterna. Genom att gå in och gröta lite i språkinställningarna under input source (och genom att där mixtra med valen av "Svensk" och "Svensk pro" så lyckas jag ibland få snabel-a att dyka upp genom att trycka ALT+*. Problemet kvarstår dock att jag inte får något resultat när jag tycker på ALT+valfri siffra.

Någon som har något förslag?

Jag har en MacBook och kör OS X 10.6.

  • Medlem
  • Stockholm
  • 2010-07-22 19:02

Jag gör en fuling och bumpar. Problemet kvarstår och sökningar på internet ger fortfarande bara som enda information att man ska trixa runt med språkinställningarna, någonting som uppenbarligen inte fungerar för mig.

Det bör börjar bli en aning irriterande.

Vad har du inställt under tangentbord?

det finns ju ngn switchhistoria för Funktionstangenterna, men det är ju inte den som felar.
Du skall ha "Svensk Pro" inställd, "Svensk" är för äldre tangentbord.

Så här ser mina inställningar ut

Ha på inställningar/tangentbord "Visa tangentbords- och teckenvisaren i menyraden"

Gå sedan upp i menyraden och välj "Visa tangentbordsvisning"

Då kan du få ledtrådar till vad som händer.

"Mixtra" låter lite väl random för min del.

  • Medlem
  • Stockholm
  • 2010-07-22 19:20

Jag kör engelska som standardspråk i mitt OS X (vilket har fungerat klockrent med snabel-a och hela tjoflöjten fram tills nu) men har "Swedish - Pro" som min inmatningskälla (vilket också anges uppe i menyraden när jag har på visningen av detta såsom du rekommenderade).

Fortfarande ingenting.

  • Medlem
  • Stockholm
  • 2010-07-22 19:32

Låt mig för övrigt poängtera att det att "mixtra" runt med inmatningskällorna inte var mitt primära försök att lösa problemet (mitt primära försök var att ställa in "Swedish Pro" såsom jag har sett att folk säger att man ska göra på andra forum). När jag dock började att stänga av och på "Swedish", "Swedish Pro" och "U.S" på måfå, helt enkelt i förhoppningen om att snubbla över en lösning, då det primära förslaget inte hjälpte, så lyckades jag vid ett tillfälle göra så att ALT+* skapade ett snabel-a. Detta kunde jag sedan inte replikera.

Anledningen till att jag inkluderade denna information var för att någon insatt möjligtvis kanske skulle kunna vara hjälpt av detta när det gällde att assistera mig fram till en lösning.

Ingen fara Pluffo.

Hur ser det ut på det virtuella tangentbordet?
Där kan man ju se ALT-knappar och cmd/shift osv. vad händer när du trycker ner ALT?
Byter raden med siffror till Bakvänt-P, Copyright, snabel-a, pund, dollar, oändlighet ?

  • Medlem
  • Stockholm
  • 2010-07-22 19:55

Nu ska vi se.

Ja, när jag slår på det och sedan håller in allt så dyker snabel-a:t upp där istället för tvåan (resten av sifferraden får också sina respektive symboler såsom du beskrev.

När jag sedan trycker på tvåan blir den gråmarkerad såsom de andra tangenterna blir när jag trycker på dem, men ingen symbol dyker upp i fältet där jag försöker skriva.

Det här känns mystiskt.

  • Medlem
  • Stockholm
  • 2010-07-23 23:47

Ehh...Jaha.

Nu när jag laddade hem Amazons Kindle-applikation för OS X så fungerade det i denna att skriva snabel-a. Dock går det fortfarande inte i något av mina andra program såsom till exempel Safari, Google Chrome, Writerroom eller Taskpaper.

WTF?

Kan du prova med ett annat tangentbord, bara för att utesluta att det är ngt mankemang med det.

Sedan vore det ju intressant att se om byte till USA, starta om, funkar det då?
Sedan byta till Svensk Pro och starta om.

  • Medlem
  • Göteborg
  • 2010-07-24 15:37

Kan du ha råkat ställa in så att alt-2 blivit kortkommando för något annat?

Exempel där jag ställt in alt-2 som kortkommando för kopiera i Textredigerare.app
(funkar dock inte i praktiken, man kan fortfarande skriva @ med alt-2 och kopierar inget)

  • Medlem
  • Göteborg
  • 2010-07-24 15:39

Gäller det alla alt-siffer kombinationer som du antyder i trådrubriken?

  • Medlem
  • Stockholm
  • 2010-07-24 15:59

Goflorp: Jag har dessvärre inte något USB-keyboard till hands som jag kan pröva med.

Vidare ska jag prova det du föreslår. Jag återkommer.

IngoX: Jag har ställt tillbaka alla shortcuts till default-inställningarna för att det inte ska vara några problem med detta. Problemet gäller för övrigt alla "ALT+siffra"-kombinationer, men det är främst snabel-a-problemet som irriterar mig. Det är inte så ofta jag sträcker mig efter oändlighetssymbolen

  • Medlem
  • Stockholm
  • 2010-07-24 16:11

Nope. Det där fungerade inte. Med U.S inställt så fungerade inte "ALT+siffra"-kombinationerna då heller. Det är alltså bara just kombinationen av ALT och siffra som krånglar. Jag kan till exempel skriva "¶" och "±" som fås genom att använda tangenterna direkt till vänster respektive höger om siffrorna.

  • Medlem
  • Stockholm
  • 2010-07-25 16:12

Mysteriet fortsätter.

När jag idag var inne på Konst-ig / Architecture, Design, Art och fyllde i ett formulär som dyker upp när man klickar på mailadressen på sidan "Store info" så kunde jag skriva snabel-a:n för glatta livet (och alla andra roliga symboler också).

Det här luktar ett känt PC-dilemma lång väg.
på de flesta BÄRBARA PC's som jag kört kan man trycka olika tangenter (Fn, Function, NumLock etc) och får då olika funktioner bland de vanliga tangenterna - den vanligaste är ju att man har ett numeriskt tangentbord "insprängt" bland de vanliga tangenterna.

Givetvis kom man hela tiden åt den där skift-tangenten ... så "j" blev "1" eller ngt sånt.

  • Medlem
  • Göteborg
  • 2010-07-25 22:31

Pröva med ett usb-tangentbord. Testet du gjorde i inlägg #8 där Tangentvbordsvisning verkar registrera rätt tangentkombinationer talar ju i och för sig emot hårdvarufel. Men överhuvudtaget verkar ju detta vara ett fel som kommer och går och då är det väl troligast att det är glapp/kortis i Macbookens tangenter.

Skulle du få samma inkonsekventa beteende med ett annat tangentbord då kan du fortsätta felsöka genom att göra ett nytt användarkonto mm.

  • Medlem
  • Stockholm
  • 2010-07-25 22:42

GoFlorp: Ja, jag vete sjutton vad det är som kan ha hänt. Jag har varit och petat på "Use all F1, F2, etc. keys as standard function keys." i keyboardinställningarna tidigare men har nu ställt tillbaka detta till grundinställningarna. Samtidigt är ju inte detta någonting som _borde_ påverka det som jag håller på att krångla med nu.

IngoX: Med tanke på att jag konsekvent kan skriva snabel-a i formuläret på Konst-ig / Architecture, Design, Art så kan man ju avskriva att det skulle vara något slags hårdvarufel.

  • Medlem
  • Göteborg
  • 2010-07-25 23:11

Skulle inte vara så snabb att avskriva det ändå - förrän du testat!

Det har ju inte med en viss webb-sida att göra. Menar du att samtidigt som du kan fylla i alt-siffer symboler på nämnda webbsida, så kan du inte göra det i till exempel adress-fältet på samma webläsare som du använder?

  • Medlem
  • Stockholm
  • 2010-07-25 23:46
Ursprungligen av IngoX:

Menar du att samtidigt som du kan fylla i alt-siffer symboler på nämnda webbsida, så kan du inte göra det i till exempel adress-fältet på samma webläsare som du använder?

Precis

Jag ska dock pröva ett annat tangentbord när jag besöker skolan nästa gång, vilket antagligen blir på tisdag.

  • Medlem
  • Stockholm
  • 2010-07-26 04:06

Nu har jag funnit ännu en miljö där det funkar att skriva snabel-a (och alla de andra symbolerna): Textediteringsprogrammet TextWrangler.

Det känns en aning skumt det här. Felet verkar vara applikationsspecifikt.

  • Medlem
  • Stockholm
  • 2010-08-13 13:56

Ok. Här kommer den senaste knasiga uppdateringen.

När jag kör Gmail i Firefox så kan jag inte skriva snabel-a. När jag däremot kör Gmail genom Fluid så kan jag skriva snabel-a i själva meddelandefönstret men inte i fälten ovan, såsom "Subject" och "To".

Vaba?

  • Medlem
  • Göteborg
  • 2010-09-13 14:36

Hur gick det med det här knasiga alt-siffer problemet?

  • Medlem
  • Stockholm
  • 2010-09-13 14:45

Jo, tack! Jag har ett snabel-a inklistrat i ett dokument som jag öppnar och kopierar ur varje gång jag behöver använda mig av denna symbolen. Helsmidigt!

När jag ska göra andra saker, såsom klamrar, brukar jag söka på Google efter något matematiskt begrepp. Jag hittar oftast vad jag söker inom någon minut eller så.

Så det går ingen nöd på mig!

  • Medlem
  • Göteborg
  • 2010-09-13 15:13

Ha, ha, gott att höra. Det är ju människans fantastiska anpassningsförmåga som gjort oss till skapelsens krona. Här får du ett bidrag av mig:

¶ © @ £ $ ∞ § | [ ] ≈ ± • ¡.” ¥ ¢ ‰ \ { } ≠ ¿

Hör av dig om du kommer på var felet ligger 

  • Medlem
  • Stockholm
  • 2010-09-13 15:17

Lysande. Nu har jag uppdaterat min textfil

Ja, en dag kanske jag orkar sätta mig ner och lösa det här på riktigt. Jag förutspår dock att det hela inte kommer att lösa sig förrän den dagen jag uppdaterar till 10.7 eller köper en ny dator

Har skummat igenom tråden snabbt, och kan inte se att någon har bett dig att prova med att skapa en ny användare i datorn, för att se om problemet dyker upp även där.

Det brukar vara första saken att prova när man har den här typen av mystiska problem.

Om du provar detta - prova gärna både med en admin- och en icke-admin-användare.

jag har haft precis detta problem, eller i alla fall liknande. jag kan skriva @, men inte kombinationerna alt-5, 6, 7, 8, 9, 0, d.v.s inte hakparentes och liknande. Gjorde nyss som jesper ohlsson sa och skapade en ny användare, och i den användare så funkade alla tecken! vad kan då vara felet? går det att få det att funka i min vanliga användare också?

Då har du säkert lagt in egna kortkommandon, som gör att vissa tangentkombinationer gör något annat än det normala.

Prova att flytta ut alla filer liknande com.apple.keyboard.NÅNTING.plist samt filen com.apple.symbolichotkeys.plist från mappen/Users/användarnamn/Library/Preferences. Du kan lägga filerna på t.ex skrivbordet.

Prova om det funkar (ev. behöver du logga ut och in igen först, eller starta om).

Om du har gjort viktiga ändringar vad gäller tangentbord som du vill slippa göra om kan du lägga tillbaka filerna en i taget och se vilken det är som krånglar. Annars kan du kasta dem.

Bevaka tråden