Min dator stänger ner switchen på HELA företaget. Både genom ethernet och trådlöst.

Tråden skapades och har fått 26 svar. Det senaste inlägget skrevs .
1

Jag har en MacBook Pro (2.33 GHz Intel Core 2 Duo) och jag har precis börjat på ett nytt företag men vill jobba med min mac och inte den PC jag blev tilldelad.

Mitt problem är att så fort jag kopplar in ethernet sladden i datorn så dör hela switchen på företaget och de 8 pers som jobbar närmast mig blir utan internet... Jag bannlyst från att använda ethernetsladden och blev hänvisad till att ansluta trådlöst. Där fortsätter min mac att spöka och stänger ner switchen med jämna mellanrum.
Datasupporten på företaget fattar ingenting (dock är han mer haj på PC än mac) och har ingen lösning på problemet.
Det som är extra oroväckande är att vi prövat att koppla in mig i två olika switchar ena 3com och den andra en HP.
Sen har jag också prövat att nollställa nätverksresurserna genom Terminal (/Bibliotek/Preferences/SystemConfiguration/preferences.plist.bak)

Detta funkade inte heller och dom vill att jag ska ta en PC i stället... Jag vägrar och kopplar upp mig genom min trådlösa telia uppkoppling istället. Det jobbig är att jag nu inte kan komma åt de gemensamma mapparna på företagets server och inte heller skriva ut på skrivaren...

Hjälp mig! Va faan är fel?
Hemma kopplar jag upp mig på ethernet genom Time Capsule helt utan problem.

Ett nätverk som kollapsar när man kopplar in en ny dator är inte särskilt robust.

Dessutom är skillnaden mellan pc och Mac när det gäller nätverk liten. Nätverksprotokollen är desamma. Antagligen har ni något system som bara är tänkt att hantera Windows-datorer, och när det kommer en maskin det inte känner igen får det krupp.

Det kanske krävs speciell mjukvara för att komma in på nätverket, exempelvis om ni har nån speciell säkerhetslösning. Men oavsett så är det upp till "datasupporten" att se till att nätverket funkar.

  • Medlem
  • International user
  • 2010-05-14 15:39

Enda orsaken jag känner till som brukar få switchar att stanna är om en dator eller nån annan nätverksenhet broadcastar massor med trafik. Helt enkelt överbelastar processorn i switchen.

Kan det va så att du har något skit i datorn som spökar? Kanske Little Snitch (Little Snitch) eller nåt sånt kunde hjälpa dig. Annars kanske du skulle prova slå igång OSX interna brandvägg och se om du har något som försöker komma åt nätverket.

  • Medlem
  • Stockholm
  • 2010-05-14 15:53
Ursprungligen av savv3:

Enda orsaken jag känner till som brukar få switchar att stanna är om en dator eller nån annan nätverksenhet broadcastar massor med trafik. Helt enkelt överbelastar processorn i switchen.

Min första tanke också.

Ursprungligen av savv3:

Enda orsaken jag känner till som brukar få switchar att stanna är om en dator eller nån annan nätverksenhet broadcastar massor med trafik. Helt enkelt överbelastar processorn i switchen.

Kan det va så att du har något skit i datorn som spökar? Kanske Little Snitch (Little Snitch) eller nåt sånt kunde hjälpa dig. Annars kanske du skulle prova slå igång OSX interna brandvägg och se om du har något som försöker komma åt nätverket.

Laddade ner Little Snitch och såhär ser det ut? Något skumt?

Det där tycker jag ser helt normalt ut. Inget konstigt alls. bara det vanliga som en Mac - och MobileMe - går ut och kollar.

Ursprungligen av Stockholm25:

Laddade ner Little Snitch och såhär ser det ut? Något skumt?

inte så att du har internetdelning påsatt? dvs att du har en dhcpd igång som delar ut ipn till alla datorer nära dig och sedan kan dom inte surfa...

  • Oregistrerad
  • 2010-05-16 19:07
Ursprungligen av =JoNaZ=:

inte så att du har internetdelning påsatt? dvs att du har en dhcpd igång som delar ut ipn till alla datorer nära dig och sedan kan dom inte surfa...

Det var precis min tanke också, men för att det ska fungera på en bärbar så måste man ju dela ut sin fasta till trådlösa eller tvärtom, delar man ut sitt trådlösa till sitt fasta (som skulle sätta igång DHCP servern på Ethernet) så kan det ju ha den effekten men låter inte så vanligt.

Något annat kan jag inte se, det finns ju liten chans att du har ett virus i din dator (ja mac) som bråkar med andra datorer. Det är ju inte så vanligt hemma då du kanske är själv.

  • Medlem
  • Härnösand
  • 2010-05-16 18:51

Är IPv6 igång på macen? Om så fallet prova stäng av det.

sen finns ju faktiskt möjligheten att göra som man blir tillsagd av sin arbetsgivare och köra den maskin man blir tilldelad...

Ah, Gusten68. Erkänn nu. Nog byter du hellre job än använder en PC med Windogz på jobbet.

  • Oregistrerad
  • 2010-05-16 21:59
Ursprungligen av bjelkeman:

Ah, Gusten68. Erkänn nu. Nog byter du hellre job än använder en PC med Windogz på jobbet.

Det skulle jag aldrig göra iaf Jag gillar windows 7

nja...

En protokollanalysator (dels på Macen och dels på någon av datorerna som är anslutna till switchen) skulle nog ge en god hint. Wireshark tänker jag på. Samt terminalinloggning på switchen för att se om det finns några loggar eller liknande.
En annan sak att observera är om det blir några förändringar i ARP-cachen på PC-datorerna när du kopplar in din dator. "arp -a" i Windows terminal. Kan ju vara så att du skapar någon slags adresskonflikt och "suger åt dig" trafiken. Att du skulle få MAC-adresskonflikt låter så klart mer osannolikt, men eftersom jag inte vet om du har någon skum programvara på din dator så kan en titt i bryggtabellen på switchen vara en idé.

  • Oregistrerad
  • 2010-05-16 22:00
Ursprungligen av Jonas Mellander:

En protokollanalysator (dels på Macen och dels på någon av datorerna som är anslutna till switchen) skulle nog ge en god hint. Wireshark tänker jag på. Samt terminalinloggning på switchen för att se om det finns några loggar eller liknande.
En annan sak att observera är om det blir några förändringar i ARP-cachen på PC-datorerna när du kopplar in din dator. "arp -a" i Windows terminal. Kan ju vara så att du skapar någon slags adresskonflikt och "suger åt dig" trafiken. Att du skulle få MAC-adresskonflikt låter så klart mer osannolikt, men eftersom jag inte vet om du har någon skum programvara på din dator så kan en titt i bryggtabellen på switchen vara en idé.

Mest nyfiken, men vad tror du Wireshark skulle ge för tips här?

Ursprungligen av studiox:

Mest nyfiken, men vad tror du Wireshark skulle ge för tips här?

Jag tror inte att programmet i sig ger tips. Men det är ju rimligen något som skickas från datorn som får nätet att balla ur. Och wireshark kommer att visa vad som skickas och tas emot. Sedan måste man analysera det data Wireshark visar, vilket inte är någon omöjlighet om man vet vad man borde se och inte.
Jag har dock inget specifikt som jag misstänker riktigt. Men det är det första steget jag skulle ta. Kanske mest för att jag har en förkärlek för protokollanalys

  • Medlem
  • International user
  • 2010-05-16 21:50

Du kan prova att starta från en ren MacOS X installation (eller kanske från MacOS X dvdn) och kolla om du får samma problem när du kopplar in ethernet kabeln. Får du samma problem så är det fel nätverks inställningarna och måste fixas från nätverksadministratorn eller låta bli att koppla in dig på nätverket. Fungerar det så är det något fel på ditt system och du får leta efter vad det är som orsakar problemet.

//Rob

Vad är det för switch ? Märke - modell ?

Ursprungligen av lilledanne:

Vad är det för switch ? Märke - modell ?

Den stängde ner två olika switchar.

Först stängde den ner en 3com switch (vet ej modell).
Sen testade vi att köra genom en HP Procurve 2848 switch men den dog också.
Vi prövade att sätta en brygga emellan men när signalen nådde switchen så dog den igen. As segt!

  • Medlem
  • Helsingborg
  • 2010-05-17 12:42

Vad säger loggarna på switcharna? Ni får nog börja i den ändan på detta problemet, verkar nästan som det kommer in så mycket skit att switcharnas cache'ar slår i taket.

Har ni provat något så enkelt som att testa en annan kabel? (ibland kan det enklaste vara det svåraste att hitta)

Ursprungligen av lando:

Vad säger loggarna på switcharna? Ni får nog börja i den ändan på detta problemet, verkar nästan som det kommer in så mycket skit att switcharnas cache'ar slår i taket.

Har ni provat något så enkelt som att testa en annan kabel? (ibland kan det enklaste vara det svåraste att hitta)

Ingen aning vad loggarna säger. När jag kopplar in kabeln så står den och glappar mellan att den får ip adress till att kabeln inte är ansluten (alltså switchen startas om och om hela tiden)

Jepp, vi har prövat med en annan kabel och med en annan switch men samma resultat.

Eftersom jag kan koppla upp mig hemma med kabel och det funkar utan några problem så vet jag att det inte är något fel på själva ethernet porten utan det är något problem med min mac och de switcharna vi har här på företaget.

Känns ju lite onödigt och dyrt att gå och köpa en ny MacBook pro för att lösa detta problem. Det borde ju finnas något annat man kan göra för att se vad faan som är fel.

Ursprungligen av Stockholm25:

Känns ju lite onödigt och dyrt att gå och köpa en ny MacBook pro för att lösa detta problem. Det borde ju finnas något annat man kan göra för att se vad faan som är fel.

Du har fått flera bra tips i tråden. Har du testat några, t.ex. att stänga av IPv6 eller internetdelning om de är aktiverade? Du kan också prova att stänga av Bonjour.

Ursprungligen av M. Sundbom:

Du har fått flera bra tips i tråden. Har du testat några, t.ex. att stänga av IPv6 eller internetdelning om de är aktiverade? Du kan också prova att stänga av Bonjour.

Ja det har vi prövat också. På företaget finns det flera andra macar som kör utan problem så det är bara min mac som är cp och stänger av switchen.

  • Medlem
  • Sollentuna
  • 2010-05-17 13:18
Ursprungligen av Stockholm25:

Eftersom jag kan koppla upp mig hemma med kabel och det funkar utan några problem så vet jag att det inte är något fel på själva ethernet porten utan det är något problem med min mac och de switcharna vi har här på företaget.

Om du är ensam hemma så finns nog felet där också, men det finns inga andra som drabbas.

Ursprungligen av frazze:

Om du är ensam hemma så finns nog felet där också, men det finns inga andra som drabbas.

Nej för att på jobbet kan jag inte komma åt internet alls. Switchen dör hela tiden och startar om sig gång på gång. Hemma så kopplar jag inte ethernet sladden och det flyter på utan problem.

Har du provat att logga in på Macen som en annan användare. Skapa en ny "ren" användare, konfigurera nätverket för denna användareom det behövs och koppla sedan in ethernetsladden?

Om det funkar då har du isolerat felet till någon inställning eller process hos din ordinarie användare.

  • Oregistrerad
  • 2010-05-17 18:37

Kanske verkar långsökt men kan du kolla så Ethernetporten är satt till AUTO och att den inte har någon custom MTU?

1
Bevaka tråden