MamP + Joomla

Tråden skapades och har fått 8 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Stockholm
  • 2010-03-18 20:05

Försöker få igång med joomla.
Har installerat MAMP men när jag ska skriva porterna är det lite knasigt.
Skrev i apache 80 och försöker skriva 330 i mql server men ändras förväges till 8889 igen.

skriver in http://localhost/joomla/

och kommer in i installationen men sen efter jag har skrivit in andvändarnamn och password och trycker på nästa så kommer det upp "Kunde inte ansluta till databasen. anslutningen returnerade nummer: Unable to conect to database. Could not connect to MySQL"

  • Medlem
  • International user
  • 2010-03-18 20:43

MySQL installationen fungerar inte. Prova att köra MAMP installationen igen eller ännu bättre installera mysql från mysql.com och aktivera PHP så ska det fungera.

//Rob

  • Medlem
  • Stockholm
  • 2010-03-18 20:53

Saken är när jag körde MAMP i skolan gick det bra felfritt.
Kanske nåt fel med systeminställningar eller dylikt?

Vad är anledningen till att du ändrar portarna?

När jag installerar mamp så behöver jag inte göra nånting.

När lägger Joomlaarkivet i htdocs så hittas sidan på "localhost:8888/namnet på sajten/" som standard.

Men du kanske vill undvika 8888?

  • Medlem
  • Stockholm
  • 2010-03-18 22:18

delvis ja för att undvika 8888, samt så jag fick lära mig

Funkar det inte om du går in på:

mamp (programfönstret)-->preferences-->ports-->och sen klickar du bara på "set to default Apache and MySQL ports"

Då skall ju mamp starta om med standardportarna av sig självt.

--------------
Tillägg: och MySQL porten skall vara 3306, inte 330

  • Medlem
  • Stockholm
  • 2010-03-26 09:05

Nu har jag testat på olika möjliga sätt men får inte igång skitet.

1. Installerar MAMP
2. går in i phpadmin skapar en databas
3. Laddar ner Joomla
4. Lägger in den i Webbsidor mappen har även testat lägga den i htdocs
5. Nu kommer jag inte ens i installation sidan längre (för att installera joomla via sidan)

Har kollat att Webdelning är av och Portarna stämmer. Dock utan resultat

Det var ett tag sen jag installerade Mamp/Joomla, men med standardinställningar och Joomla-katalogen inlagd i
(applications)/MAMP/htdocs/joomla
hittar jag joomla på
http://localhost:8888/joomla/

  • Medlem
  • Stockholm
  • 2010-03-26 15:36

Ska testa avinstallera bort allt igen och installera.
Uppdaterar om det går fint fint

1
Bevaka tråden