Är Exchange-stödet annorlunda i Mail och på iPhone?

Tråden skapades och har fått 17 svar. Det senaste inlägget skrevs .
1

Jag har lagt in företagsmailen på min iphone utan problem. Jag skapade ett exchange konto på den och la in server, user name, password sen konfigurerade den alltihop själv.

I mail (os x 10.6.2) så fungerar ingenting, jag får ingen kontakt med mailservern. Jag har testat alla kontotyperna inkl. exchange imap och exhange 2007. Varför kan inte mail sköta det på samma sätt som telefonen??

Problemet är att om iphonen har ställt in en massa portar och grejer själv så ser inte jag det för inställningarna visar ju bara den information som jag lagt in på egen hand och den räcker inte till i mail verkar det som.

iPhone kommunicerar med Exchange-servern via ActiveSync. Mail, iCal och Adressbook på Mac OS X gör det via Exchange Web Services.

/c

  • Medlem
  • Stockholm
  • 2010-02-24 08:20

Är du säker på att ni har Exchange 2007 på företaget? Det är nämligen ett krav för att Snow Leopard skall funka.

  • Medlem
  • Helsingborg
  • 2010-02-25 16:35

Sitter du på företagets LAN när du försöker eller sitter du utanför & går genom nån form av firewall/proxy (oftast ISA 2004/2006 när det gäller exchange).

Jag gjorde bort mig lite när jag satte upp min Exchange 2007 så hos mig fungerade bara iPhone också, men det löste sig genom att sätta på AUTH på dom virtuella siterna i IIS'en på Exchangeservern.

Ärligt talat har jag ingen som helst aning, det är företaget som styr det där och det finns inga instruktioner för hur man får det att fungera med mail. Jag och alla andra kör via deras webbmail istället, men det är surt eftersom iphone mailen är så enkel att konfigurera och använda. Borde vara samma på macen!

  • Oregistrerad
  • 2010-03-07 17:14

Precis som Christian Å säger så använder iphone ActiveSync för att kunna prata med företagets Exchange Server. Mail, samt Enoturage Webservice edition använder just en Webservice. Det är något som ditt företag kan välja att ha igång eller inte ha igång. Webservice fungerar dessutom bara med Exchange 2007 RU2 eller senare (vilket även iofs iphone verkar kräva, vet inte varför)

Så det är inget fel på din mac, det är "fel" på Er exchange server. Testa om det fungerar med Entourage (som använder WebDav) .

Bumpar en gammal tråd och undrar om detta problem verkligen råder än?

Ny i PC-organisation (kommun, say no more) och ansluter min iPhone till exchange-servern hur enkelt som helst men Mail på datorn hävdar bara att den angivna servern (samma som på telefonen) inte svarar.

Trodde att det kanske berodde på att jag fortfarande satt med OS 10.5 och pyntade för en välbehövlig uppdatering till Snow Leopard 10.6.7 dock med samma problem.

Work-arounds någon? Funkar det på telefonen så borde det ju kunna lira i Mail också tycker man ju. Nej den kommunala help desken supportar bara på de egna maskinerna, dvs MS Outlook.

Ursprungligen av Johan Andersson:

Bumpar en gammal tråd och undrar om detta problem verkligen råder än?

Detta är kraven för att stödet ska fungera i Snow Leopard.

• Update Rollup 4 for Exchange Server 2007 Service Pack 1.
• Exchange Web Services (EWS) must be enabled. EWS is on by default in Exchange 2007.
• Exchange AutoDiscover must be turned on for automatic setup.
• Snow Leopard uses SSL over port 443 to connect to EWS.

När det inte fungerar som det ska, är det uppsättningen av servern som är felaktig. Stödet för Exchange 2007 och 2010 fungerar i Mac OS X och i Outlook 2011.

På företaget jag jobbar har jag en server att gå mot när jag sitter innanför brandväggen och en annan om jag sitter utanför. Vår leverantör ser bara till att det fungerar på Windows XP och Office 2007 just nu.

/c

  • Oregistrerad
  • 2011-05-12 22:44
Ursprungligen av Christian Å:

När det inte fungerar som det ska, är det uppsättningen av servern som är felaktig. Stödet för Exchange 2007 och 2010 fungerar i Mac OS X och i Outlook 2011.

Liten korrigering, det fungerar i Entourage WebServices edition också som går att ladda hem gratis från microsoft (under förutsättning man har entourage såklart)

För mig är det så att man skriver användarnamnet olika:

iPhone: p.marriott_[domain utan .se]

Mail på datorn: p.marriott@domain.se

  • Oregistrerad
  • 2011-05-12 12:39

Kolla inställningarna på mail om de blev rätt. Det är inte säkert autodescover fungerar.

Kolla så att serverinställningarna pekar mot webmailadressen (typ https://webmail.kommun.se/owa)
Kolla så att domäninställningarna är rätt domän\användarnamn eller användarnamn@domän

Det kan också vara så att it-avdelningen enbart supportar iphone (sånt kan man ställa in i exchange)
Har du officepaketet hemma kan du köra outlook annars, det borde vara supportat.

Tackar för tipsen.

1. Enligt helpdesken ska jag skriva mitt kortnamn som användarnamn trots att jag skriver hela mailadressen i iPhone. Oavsett vilket visar dock Mail genast att servern inte svarar varför jag antar att detta ej är problemet.

2. Autodiscover funkar uppenbarligen inte med tanke på att jag skickas vidare till manuella inställningar. Anger då till synes samma som i iPhone med får det inte att funka.

3. Outlook i macen? Tack men svära i kyrkan?

Andra tips?

  • Oregistrerad
  • 2011-05-12 13:54

Har du verifierat att det är rätt extern serveradress i apple mail?

Ang. användarnamn ska du skriva exakt samma som du använder för webmailen.

Tack men var har du hittat ditt screenshot?

För inställning av Exchange 2007 anges:
- Beskrivning
- Server, inkommande e-post
- Användarnamn
- Lösenord

Väljer jag istället Exchange IMAP så tillkommer fält för Outlook Web Access-server.

Med andra ord inget som heter extern server.

  • Oregistrerad
  • 2011-05-12 14:25

Jag har Mail 4.5

Jag använder Exchange 2007 som kontotyp (Nej inte imap)

  • Medlem
  • Karlskoga
  • 2011-05-12 15:09

En del servers gillar inte @ i användarnamnet, och då kan man testa % istället. Om det hjälper här vet jag inte....
Nu vet jag att du skrev att det funkar i datorn, men det kanske kan ha betydelse för klienten också.

Tack Christian Å och övriga. Då antar jag helt enkelt att mail-servern inte är optimerad för Snow Leopard.

Jag är medveten om att OS:en inte är desamma men tycker det är konstigt att två produkter från samma tillverkare (iphone och macbook pro) ställer olika krav för att fungera med exchange.

Förhoppningsvis kan jag över tid utveckla en relation med IT-folket och få hjälp att titta på detta.

Ett separat mailprogram för jobbmailen är inte ett alternativ.

  • Oregistrerad
  • 2011-05-16 11:51
Ursprungligen av Johan Andersson:

Jag är medveten om att OS:en inte är desamma men tycker det är konstigt att två produkter från samma tillverkare (iphone och macbook pro) ställer olika krav för att fungera med exchange..

Nåja. Det är helt enkelt så det fungerar. Även om du kör microsoft-produkter. En Windows-telefon använder active-sync, det gör alla telefoner från alla tillverkare. Kör du Outlook däremot så är det en annan sak, där används MAPI som är ett gammalt protokoll som hängt med länge. Tyvärr har inte microsoft lyckats konvertera det till Entourage och senare Outlook för mac. Där använder man istället WebServices (som Christian så fint nämnt). Detsamma gäller med Apple Mail (som bara kan använda de protokollen microsoft ger tillåtelse till)

Om ni snart uppgraderar till Exchange 2010 så kommer problemen försvinna, och då får ni även en webmail som fungerar i safari

1
Bevaka tråden