Problem med homedirectory, OD

Tråden skapades och har fått 11 svar. Det senaste inlägget skrevs .
1

Hej,
Jag sitter precis innan skolstarten och konfigurerar ett nytt OD för skolan.
Allt går riktigt smidigt fram tills dess att jag ska skapa upp nya hem-mappar lokalt på servern.

Alltså mappen som eleven ska komma åt när dom loggar in (ersätta den vanliga "hem-mappen" som ligger lokalt på klienten).

Det som händer när jag skapar ett nytt home i workgroupmaneger för användaren, är att det inte går att logga in på klienten via OD't. Den kommer åt servern men säger "du kan inte logga in till användarkontot "namn" just nu. inloggningen misslyckades eftersom ett fel inträffade."

Få fort jag ger en ogiltig länk eller tar bort hem-mappen för användaren så går det att logga in.

Likväl som det går att logga in som användaren från ett lokalt konto till afp server och på så sätt komma åt sin hem-mapp.

Hjälp mig!! skolan börjar på fredag!

Sannolikt kan det var DNS konfigurationen som strular.

Ursprungligen av kvarne:

Sannolikt kan det var DNS konfigurationen som strular.

Att DNS:en är konfigurerad rätt är viktigt i OD-sammanhang. Vad får dig att misstänka att felet ligger där?

Ursprungligen av Martin Pettersson:

Att DNS:en är konfigurerad rätt är viktigt i OD-sammanhang. Vad får dig att misstänka att felet ligger där?

Jag är inte så hemma vad det gäller dns'er, därför misstänker jag det.
Keberos fungerar inte för tillfället för att jag tabbat mig med dns'en.
Skapat upp en ny tråd om hur jag ska lösa det.

Skapar du hemmappen via WGM och knappen "create home" under kontoinställningarna?

Ja, precis.

Och hemmappen skapas, och återfinns i delade mappar om man går in via afp och aktuell användare.

  • Oregistrerad
  • 2010-01-06 11:55
Ursprungligen av mr_kvarne:

Och hemmappen skapas, och återfinns i delade mappar om man går in via afp och aktuell användare.

Och du har skapat AFP mounten som en home folder mount ? (Kommer inte ihåg vad det heter nu exakt)

Du råkar inte ha samma användarnamn på den lokala dator? (Då ska du iofs loggas in lokalt men jag tycker det strular ibland)

Har du OD connectivtet på klienten? om du klickar på hostname under OSX namnet i inloggningsfönstret ett par ggr ser du om nätverksinloggning är aktiverat.

Yes, det stämmer. I os x snow leopard blir den det automagiskt.

Och nej, samma användare finn inte på den lokaladatorn.

Yes, i got it! katalogserver tillgänglig eller var det nu står..

Fungerar inte Kerberos är det förmodligen DNS men det kan också vara Tidsservern men jag sätter mina pengar på DNS.

Mycket riktigt är det min DNS konfiguration som strular, jag gjorde om allt från början. Och vips, det fungerade klockrent, tills i fredags! Så nu var jag tvungen att ge mig in i den fantastiska världen igen..

så här ser min konfiguration ut för tillfället: (taget ifrån Mac OS X Server Next Steps)
Configure DNS
The domain name servers you’re using don’t have an entry for the domain geab-033-1.ephone.se, and therefore your clients won’t be able to access your server using the name cust-076.geab-033-1.ephone.se. To fix this, purchase your domain name through your ISP or from a public domain name registrar, and ask them to configure the domain to point to 77.53.33.76. To provide easier access to your services, create an entry for the name www.geab-033-1.ephone.se that points to your server.

Jag vill givetvis peka mitt egen domän till servern men har inte lyckats.
så... hur ställer man in dns'en så det fungerar till 110%

Någon som som kan visa sin egen konfig? Så jag bara kan få en överblick hur det bör se ut.

  • Oregistrerad
  • 2010-01-18 10:21

Tips #1 är att INTE, INTE, INTE använda en riktig domän.

1. Använd xserver.local eller något liknande som INTE är en riktig domän
2.) Låt dina klienter använda din Xservers DNS
3.) Låt din Xserver agera DNS på stora stygga internet
4.) Låt dina klienter köra privata adresser ur ett DHCP scope som din XServer delar ut

Att dela ut Ip adresser, dns och PTR records från en ISP är duumt

1
Bevaka tråden