rsync och svenska tecken

Tråden skapades och har fått 2 svar. Det senaste inlägget skrevs .
1

Hej

Försöker få till en backup och vill exkludera mappen Microsoft användardata, men det skiter sig. Det är förstås nåt med teckenkodningen men jag få ingen ordning på det.
En dry run med --exclude "/Documents/Microsoft användardata" blir i loggen
Documents/Microsoft anva\#314\#210ndardata/
Jag har testat --exclude "/Documents/Microsoft nva\#314\#210ndardata",
-exclude "/Documents/Microsoft*" plus ett antal andra varianter
men inget hjälper. Vad göra?
Ska kanske nämna att jag har en engelsk snöleopard.

  • Medlem
  • Göteborg
  • 2009-11-30 23:53

Det är som du säger troligen teckenkodningen. Snökatten kör UTF-8 och Windows kör ISO 8859-1. Det fina är dock att rsync hanterar detta med flaggan --iconv=utf8,iso88591 (eller omvänd ordning beroende på vilket system som sändare och vilket som är mottagare).

Hoppas det hjälper!

Mvh
/genell

Tack för svaret, men jag hittar ingen iconv-parameter. Däremot hittade jag -8 när jag lusläste man sidan och det tycks fixa saken, åtminstone vid torrkörningarna. Får se när jag testar skarpt.

1
Bevaka tråden