Joomlas artikel-editor (TinyMCE 2.0) funkar nu i Safari

Tråden skapades och har fått 5 svar. Det senaste inlägget skrevs .
1

Som utvecklare av Joomla-siter så har man länge varit tvungen att påpeka för kunder och kursdeltagare att den editor i vilken man skriver artiklar i Joomla (som heter TinyMCE) inte fungerar i Safari. Man måste använda Firefox istället. Ingen större nackdel med det, då Firefox har en massa annat trevligt i form av plugins. Men i alla fall, lite struligt att man för minsta ändring måste starta en annan webbläsare än dem man har som förval.

Nåväl, jag lade märke till att Joomla för någon version sedan och Safari för någon version sedan numera alltså fungerar med varandra. Eller snarare artikeleditorn gör det. Att kunna surfa som besökare till Joomla-siter har funkat alldeles utmärkt hela tiden. Nästan allting annat i Joomlas Admingränssnitt har också funkat i Safari, utom just editorn.

Just nu är aktuella versioner när jag skriver detta: Joomla 1.5.15 och Safari 4.0.4.

Tänkte att det kanske är av intresse för oss här som kör Joomla.

Senast redigerat 2009-11-19 20:07
  • Medlem
  • Stockholm
  • 2009-11-19 18:53

Använder inte Joomla, men dock tinyMce. Och det låter ju underbart om det blivit safarikompatibelt nu... dags att uppdatera.

  • Medlem
  • Sollentuna
  • 2009-11-19 19:06

Tack för upplysningen. Och att vi ånyo måste uppgradera vår site från .14 till .15. Typiskt men bra.

Upptäckte just att även Wordpress har samma editor, flera ställen där TinyMCE finns på denna sida:

TinyMCE - Using

(En enormt lång lista finns på denna sida: TinyMCE:CMS systems - Moxiecode Documentation Wiki ) Däribland märks tex CMS Made Simple, Drupal, E107, Expression Engine, Movable Type, PHP Fusion, PHP Nuke, Plone, Type3 och Xoops. Ojdå! )

  • Medlem
  • Stockholm
  • 2009-11-22 13:41

Man kan ju köra med JCE istället som också ger mer möjligheter än TinyMCE

Jag lägger alltid in den som deafult editor.

Janne

  • Medlem
  • Stockholm
  • 2009-11-29 20:47

Jag håller precis på att bygga min första sida i Joomla, och det har gått bättre än väntat. Men jag har dock sprungit på ett litet problem, efter att jag igår bytte från editor från Tiny till JCE för att jag ville få lite bättre kontroll bla över textwrap runt bilderna.. Men något knas har hänt. I editorn så fungerar allt och jag har bra marginaler runt bilden, när jag sedan laddar sidan så ser det helt rätt ut i ca en sekund och sedan så hoppar texten åter ned och hamnar under bilden.. JCD Editorn skriver till en editor.css ,, samma som jag tror att Tiny gjorde,, men som sagt så här det något knas, är det någon som vet vad som kan vara problemet? Är det en konflikt mot någon annan CSS?

1
Bevaka tråden