Problem med MacPorts

Tråden skapades och har fått 2 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Skurup
  • 2009-09-05 22:52

Tjenare!

Nu har jag försökt under ca 2 års tid utan att fråga. Gång på gång efter varje formatering samt nya datorköp så har jag försökt få igång MacPorts.

Just nu sitter jag och försöker få in ircii med MacPorts. Jag har installerat xcode från min Leopard Snow skiva. Jag har också kört port -d selfupdate i terminal.

I guiden som jag följer står det följande

1. cd /opt/local/bin/portslocation/dports/ircii
2. sudo port install ircii

Problemet jag egentligen har är steg 1. När jag slår det kommandot så får jag bara
"No such file or directory"
Jag har försökt att köra kommandot efter att jag loggat in som root och när jag inte varit inloggad. Samma svar.

Ikväll blev jag irriterad och struntade i första steget och hoppade över det. Installationen går bra. Men när jag sen skriver sudo ircii i terminal så fungerar ingenting. Det är bara ett ogiltligt kommando.

Någon som har någon aning om detta eller har tips?

Vänligen LXSU

Du ska inte behöva det första steget utan port ska generellt kunna köras oavsett vad din cwd är. Kontrollera om /opt/local/bin finns i din PATH-variabel. Det är där MacPorts installerar program som standard. Du kan skriva echo $PATH eller använda programmet env för att se var den innehåller.

  • Medlem
  • Skurup
  • 2009-09-05 23:18

Om jag kör detta kommando vilket jag har gjort för att se om bin finns till så får jag fram

/opt/local/bin:/opt/local/sbin:/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin

Detta ser enligt mig ganska rätt ut.. Men jag är väl inte speciellt duktig på sånt här egentligen

1
Bevaka tråden