ID3 problem

Tråden skapades och har fått 2 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Huddinge
  • 2009-08-12 18:41

Jag nyligen gått igenom musikarkivet och korrigerat ID3-taggarna där det behövts för att göra iTunes nöjd. Dock har jag ett problem med vissa album där ID3-taggen stämmer med iTunes säger motsatsen.
Kikar man på låten genom iTunes så skriver den ut låten som "artistnamn - låtnamn" men högerklickar jag och kollar på informationen för den specifika filen så ser det helt rätt ut; artistnamn, låtnamn och spårnummer. Backar jag nu tillbaka till låtlistan så har den nu uppdaterat vyn och just den låten ser rätt ut.
För jag över hela albumet till min iPhone så är det bara låten ovan som ser rätt ut, resten skrivs ut "artist - låtnamn".

Har inte hjälpt att plocka bort hela biblioteket ur iTunes och lägga till det igen. Rättar jag till en låt, plockar bort rubbet ur biblioteket och lägger tillbaka allt igen så blir de där låtar fel igen.
Foobar2000 bekräftar att ID3-taggen är korrekt på ovan nämnda låtar.

Har även försökt välja "konvertera ID" och låtit bli att välja en ID3-version, samt att välja en annan eller samma ID3 version, utan resultat.

Tips och idéer?

  • Medlem
  • International user
  • 2009-08-17 15:48

Jag hänger inte riktigt med vad problemet är men jag kan ge dig lite av mina erfarenheter kring trilskandes ID3-taggar:

  • Testa att slänga fileniTunes Music Library.xml som ligger i din iTunes-mapp. Funkar inte det kan du ju även testa att slänga filen iTunes Libraryoch börja om på nytt.

  • Jag har upplevt problem med min iPod (4:e generationen) när jag har använt ID3-taggar (ID3v2) av version 2.4. Det är möjligt att detta kan ställa till det även i iTunes. Var även medveten om att det finns två typer av ID3-taggar – ID3v1 och ID3v2 - jag har dock inte koll på skillnaden.

  • Testa att ladda hem det härscriptetoch kör igenom hela ditt bibliotek. Det uppdaterar informationen i iTunes från filernas ID3-taggar.

Jag har nyligen skrivit en städguide som kanske kan vara till hjälp.

Hoppas att allt löser sig!

  • Medlem
  • Huddinge
  • 2009-08-17 18:35

Mitt bekymmer är att i vissa album läser den inte ID3-taggen. Den visar istället någon slags standardbeteckning "artist - låtnamn". Högerklick och tryck på info bekräftar att taggen är korrekt. Tillbaka i ursprungsvyn visas den nu med korrekta namnet.

Att plocka bort de där filerna ger samma resultat som när jag slänger hela biblioteket och importerar det igen. Filen visas inte med rätt ID3-tagg åter igen.

Att konvertera från 2.3 till 2.4 hjälper inte. Konverterar jag till en lägre version så klipper den en del av albumnamnet.

Kan tyvärr inte köra scriptet då kör XP.

Tack för tipsen.

1
Bevaka tråden