Ethernet plötsligt dött på iMac G5!

Tråden skapades och har fått 11 svar. Det senaste inlägget skrevs .
1

Hej,
ursäkta språket... Jag kopierade och orkar inte översätta
Några idéer?

Mvh / Per

Hi all,
it seems I lost my ethernet port...

Last Tuesday I shut down all machines and went away on a trip. When returning five days later my iMac initially wouldn't start at all, but hung with the spinner on a grey screen. After removing all cables, resetting the SMU and zapping the PRAM the iMac boots, but I have no network.

Setup
iMac G5 20" 2GHz (PowerMac8,2)
Local network with gigabit switch, iMac connected to this switch
Router, printers and disks also connected to this switch.

Status
All other equipment working properly
All ethernet cables are OK
All ports on the switch are OK
Internet access OK

Symtoms
No ethernet connectivity to iMac (no light, no network access)
System preferences hang forever when I try to access Network Prefs

Actions performed
Unplugged iMac from power for 4 hours. Plugged it back in while pressing the power button.
Zapped PRAM (Strangely, I only get two chimes, then it boots. Every time. This is new to me...)
Ran the hardware tests using the install DVD - OK
Run a disk check - OK
Repaired file permissions - no real errors
OS was initially 10.5.7, I upgraded to 10.5.8 after the incident

All input on this is greatly appreciated. I can't believe that the ethernet port was just destroyed on a switched-off (but still conected) computer, it's gotta be something else.

TIA, I'm hoping for a miracle

Best / Per

Bor du där det kan åska?

Hur uppdaterade du systemet? Har du även Airport?

Visst kan det åska här, men såvitt jag vet inte under förra veckan. Alla maskiner (utom switchen ser jag nu...) är skyddade mot överspänning, och switchen är hel, så det borde vara OK.
(Allt är överspänningsskyddad sedan ett år tillbaks då jag verkligen hade ett åsknedslag; alla nätaggregat- även den i iMacen - rök all världens väg men förutom en skrivare överlevde alla maskiner)

Uppdatering hur... tja, du vet.. 'Installera' eller vad det står Men minsta möjliga, alltså 10.5.7.=> 10.5.8, inte Combo.

Airport, jovisst, och det skulle jag väl kunna leva med om jag kunde slå på den. Men jag kommer ju inte in i Nätverksinställningar. När jag klickar på Nätverk i Systeminställningar ser jag 'Läser in Nätverk...' i fönsterhuvudet, och där hänger den sedan. Jag måste tvångsavsluta Systeminställningar för att komma ur det.

Jag menade så här angående installering. Om du inte har ett fungerande nätverkskort kan du inte komma åt internet och ladda hem uppdateringen. Så när du skriver att du gjort det låter det lite konstigt. Ett alternativt sätt att komma åt internet och programuppdatering är ju Airport, så därför frågade jag om det fortfarande fungerade. Självklart ifrågasätter jag inte att du har problem med nätverkskortet.

Att ett åsknedslag färdas genom många prylar med nätverksutrustning utan att skada dem på vägen och bara slår ut nätverkskortet i datorn förekommer förstås också. Olika saker är olika känsliga helt enkelt.

I det här fallet så tror jag du skall lämna in den och få kortet utbytt.

Hej igen!
Aha, du menade så... Jag plockade ner uppdateringen till min MBP och kopierade till en usb-sticka. Fiffigt, eller hur!
Det finns alltså ett separat nätverkskort i iMac G5, inte bara kretsar på moderkortet? (Det var längesedan jag var inne och tittade...

Tack för klargörandet.

Om det är ett separat kort anslutet vill moderkortet på en iMac vet jag faktiskt inte. Skall inte svära på det. Men kanske du har lite tur och har kvar Applecare eller kanske garanti?

Ack nej..... Ingen AppleCare, ingen garanti.... Och burken köptes en månad innan Apple tillkännagav övergången till Intel; en uppvisning i dålig timing

Det beror på vad som är trasigt i det hela. Jag googlade på saken och ethernetporten verkar sitta direkt på moderkortet.

Här är några ideer jag hittade på vad du kan göra:

Om problemet är att porten glappar kan du göra något av följande
* Dra i en skruv i ett hål du gör väldigt nära kontakten så att ena sidan av skruvskallen pressar ner kontakten mot moderkortet.
* Löda loss kontakten från något billigt ethernetkort, löda på det på moderkortet. Eller förstås köpa en sådan kontakt på tex ELFA -- Elektronikdistributör i norra Europa Men detta funkar ju bara om just kontakten är paj.

Om problemet inte är en trasig kontakt:
* Köpa en USB->Ethernetadapter
* Köp Airport-kort.

Dessa fyra förslag från dessa trådar:
Replacing ethernet port on mobo
iMac USB->Ethernet Adaptor/Fried Enet

Här är en sådan adapter:
http://www.prisjakt.nu/produkt.php?p=76762

Du får kolla om de har drivrutiner för Mac OS X innan du köper, eller om sådana inte ens behövs.

Det verkar finnas massa sådana från alla möjliga tillverkare: D-Link, Belkin, Sabrent, Linksys, TRENDnet, Cables to go.

Hej Taz, tack för alla förslag
Jag slutade mecka hårdvara för 20 år sedan, på goda grunder - software rules Därvidlag återstår serviceverkstan, hehehe...
Nya nätverksgrejjor är OK, men jag har redan ett fungerande Airport i burken. Oavsett, problemet är att jag inte kan öppna Nätverksinställningar, då låser sig hela Nätverksinställningar.... Har du någon idé kring detta blir jag dig evigt tacksam!

Har du prövat installerat om systemet?

Roffe

Hej Roffe,
nej det har jag inte - jag väntar på en regnig dag...
Jag ville testa allt annat först, det tar ändå duktig tid att installera om, även fast jag har allt i TimeMachine. Men det kanske är dags...
Hmmm... hur gör jag restore om nätverksporten ändå inte därefter skulle funka?

/P

So I managed to set it straight, thanks for all input!

I made an Archive&Install and lo and behold - the ethernet port is there and works.
(Remains only one question - what happened really? But I can live with that )

Best / Per

1
Bevaka tråden