Problem med inloggning av Mobile accounts - tidsfel?

Tråden skapades och har fått 17 svar. Det senaste inlägget skrevs .
1

Fruns Powerbook uppdaterades till 10.5.7 innan servern.
Nu när man försöker logga in så köper den inloggningsuppgifterna men innan något annat händer skjuts en dialogruta upp som säger:
Skriv in administrationnamn och lösenord för lpadmin för att göra ändringar.
Jag kan inte skriva in några som helst uppgifter här.
Spelar ingen roll om jag försöker logga in med lokalt konto eller nätkonto.

Tittar jag i servers kerberos log står det så här:
Jun 13 21:11:51 server.loc krb5kdc[135](info): TGS_REQ (7 etypes {18 17 16 23 1 3 2}) 10.0.1.100: ISSUE: authtime 1244920311, etypes {rep=16 tkt=16 ses=16}, namn@SERVER.LOC for ldap/server.hedman.loc@SERVER.LOC

Säger den att tiden inte stämmer eller vad är det för fel?

jag är för trött/lat att läsa ditt inlägg ordentligt men jag vet att Kerberos är kinkig med klockan ja. 5-10 minuters diff eller vad det är som är gränsen. Ställ klockorna rätt och testa igen?

Problemet är att jag inte kan ställa klockan eftersom jag inte kan logga in på klientdatorn.

Logga in som root?

Ingen inloggning funkar. Hade det fungerat hade det inte varit något problem.
Kan jag göra något i single-user mode?

  • Medlem
  • 2009-06-15 09:37

Boota på installationsskiva?

Det kommer funka, frågan är vad jag kan göra sedan? Reparera disken?

Funderar på att utnyttja "kraften" i mobile accounts och blåsa burken och låta den synka tillbaka allting igen.

Men samtidigt vill jag lösa problemet.

Du kan ställa klockan från Open Firmware. Här finns en beskrivning: http://www.macosxhints.com/article.php?story=20060814075952448&query=dec

Gjorde du skrev Marcus och trots detta kan jag inte logga in nu säger loggen på servern "Clock skew to great" vilket säger precis det jag trodde tids skillnad.
Hur fasen rättar jag till detta?

Jag provade att boota i single user mode och såg att klockan diffade på två timmar, ändrade det och startade om. Trots detta får jag upp:
Dialogen:
"Skriv in administrationnamn och lösenord för lpadmin för att göra ändringar.
Jag kan inte skriva in några som helst uppgifter här."

Som jag sedan inte kan skriva i. Vad göra?

  • Medlem
  • Bollnäs
  • 2009-06-15 20:43

Blir det någon skillnad om du nollställer PRAM och PMU? Kanske kan tvinga en koll mot tidsservern på klienten...

  • Medlem
  • 2009-06-15 20:48

Ställ om klockan i serven en liten stund annars.

lpadmin är helt nytt för mig. Det dök upp för någon vecka sen och strular till det när jag vill installera skrivare. Kan det finnas något samband?

http://www.99.se/mac-os-x/265614-krangel-med-att-laegga-till-skrivare.html

Om det skiljer två timmar låter det som om man inte har kompenserat för skillnaden mot UTC som Kerberos använder.

Jag har nu blåst hennes maskin allt funkar fin fint tills jag sätter igång Directory Access och försöker logga in som henne. Då får jag upp detta lpadmin.
Jag blir även utelåst från det lokala kontot när Directory Access är igång.
Jag kan logga in på datorn via SSH och kan då döda /Library/Preferences/DirectoryService/ efter omstart så kan jag då logga in med det lokala kontot.

Alltså är det något som krånglar på servern med lpadmin.
Något med skrivare skulle jag gissa på.

Någon som kan peka vad jag ska göra?

Frågan är vad som händer om jag dödar ODet för att efter omstart på servern sätta upp det igen.
Rensas alla eventuella inställningar så jag får nya?

Jag tog backup på hennes hemmamapp och blåste hennes dator.
Raderade hennes användare från servern och gjorde en ny.
Kopierade sedan tillbaka allt utom Librarymappen till hennes nätvolym, det synkas till hennes maskin precis som det ska.

Så nu återstår frågan - vad är det som triggar lpadmin och hur dödar jag det en gång för alla?

Är det en PPC mac med MCX för skrivare?

1
Bevaka tråden