Uppdatering av Java för Bank-ID

Tråden skapades och har fått 15 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • 2009-04-14 09:34

Vill skaffa Bank-ID men kan inte ladda hem programvaran eftersom den säger att jag inte har uppdaterat Java.

Java säger dock att jag ska uppdatera via Programuppdateraren. Det finns ju ingen ny uppdatering. Snark.

Sitter på 10.4.11, någon som vet vad man kan göra med detta onödiga problem?

  • Medlem
  • Gnesta
  • 2009-04-15 11:53

Java vill inte fungera i min Mac OS X 10.4.11

Jag liksom CEB här på Diskussonssidan försöker skaffa ett bank-id.

Men Java vill inte fungera på min Mac.

Har nyinstallerat Java för Mac OS X 10.4 release 7, som sagt gjort installationen och fått godkänt. Men Java fungerar ändå inte.

Vad ska jag göra? Känner mig hjälplös.

"Release 7"-uppdateringen uppdaterar både Java 1.4.2 och 1.5.0

"This release updates J2SE 5.0 to version 1.5.0_16 and Java 1.4 to version 1.4.2_18. "
http://support.apple.com/downloads/Java_for_Mac_OS_X_10_4__Release_7

Så trots att ni har kört "Release 7"-uppdateringen så kör ni förmodligen fortfarande Java 1.4.2

Om man vill ha allra senaste versionen, så måste man först ladda ner Java 1.5.0:
http://support.apple.com/downloads/Java_2_SE_5_0_Release_1

Observera den här meningen:
"This release does not replace the existing installation of J2SE 1.4.2."
1.4.2 ligger alltså kvar, så efter installationen av 1.5.0 måste man gå in i Java-inställningarna och säga åt OSX att det är 1.5.0 som ska användas.

Och man bör kanske köra "Release 7"-uppdateringen igen, så att 1.5.0 också uppdateras till senaste versionen.

Senast redigerat 2009-04-15 16:33

Det där med Java verkar ju ... så glasklart ....

  • Medlem
  • Gnesta
  • 2009-04-15 17:04

Java, nej icke!
Jag gjorde som du sa Jesper, laddade ner Java 1.5.0

men...att installera gick inte.
"Du kan inte installera J2SE 5.0 Release 1 Package på den här enheten.
This volume contains a newer version of Java 1.5

Bara att stänga och fundera vidare.

Nu sitter jag där med rumpan bar och skägget i brevlådan, efter månaders ideliga försök
att skaffa ett ynkligt bank-id från en näst intill sprillans ny Intel-Mac.
Suck

Hoppas på under

OK, då hade du redan 1.5.0 installerat...

Men gick du in i Javainställningarna och kollade att det verkligen är 1.5.0 som OSX använder?

För som jag skrev tidigare, så kan flera versioner av Java existera parallellt i datorn, och man måste själv ange vilken av dem som ska användas.

  • Medlem
  • Gnesta
  • 2009-04-15 17:30

Jesper,

Tack,
måste med rodnadens färger på kinderna medge att jag
inte vet hur man kommer in i Javainställningar.
Kan du vägleda mig???

OlleQ

Ursprungligen av OlleQ:

Jesper,

Tack,
måste med rodnadens färger på kinderna medge att jag
inte vet hur man kommer in i Javainställningar.
Kan du vägleda mig???

OlleQ

Inget att rodna för, macen är lite eljest på det här med Java.

I Program->Verktygtygsprogram->Java hittar du "Java-inställningar". Drag och släpp så att önskad version ligger längst upp i respektive ruta. Klart!

  • Medlem
  • Gnesta
  • 2009-04-16 18:42

Fortfarande pannan i väggen med Java. Dunk, dunk....

Nu har jag hämtat J2SE 5.0 release 1 och när jag skall installera programmet
och kommer till Välj målplats möts jag av en röd varningsskylt med texten:

Du kan inte installera J2SE 5.0 Release 1 Package på den här enheten.
This volume contains a newer version of Java 1.5

Vad gör jag nu, kan inte komma vidare.
Flera versioner av Java med olika releaser besudlar min dator, jag lyckas inte
heller i Program, Verktygsprogram hitta vad som skall dras och släppas dit och till
vilken ruta.

I´m lost, fullständigt.

Ska jag kasta ut alla nedladdade Java-program och börja om från början, men var?

Om du kör "Programuppdatering..." så får du se om nyare grejer finns att installera. Du behöver inte ladda ned och installera något särskilt själv, kör programuppdatering bara. Säger den att inget behöver uppdateras så är det så.

Och sååå himla svårt är väl inte "Java-inställningar" heller... det finns två rutor, en för applets och en för javaprogram. Den java-version du vill använda för respektive ska vara överst i listan. That's it.

  • Medlem
  • 2009-04-18 08:50

Jag kan tyvärr inte installera versionerna Jesper föreslår eftersom "jag redan har nyare versioner installerade". I mina prefs ligger Java 1.5.0 överst.

Per: tyvärr så har jag redan kört uppd som det står först i tråden men där finns inget att hämta och det går alltså fortfarande inte att köra Bank.ID tyvärr...

  • Medlem
  • Stockholm
  • 2009-04-18 12:41

jag hade nyligen samma problem. Försökte skaffa bank-id med Firefox 3. Jag lyckades "lösa" det hela genom att ignorera felvarningen på bank-id:s hemsida vid installation och klicka mig vidare med Nästa. Allt gick bra till slut och fungerar fast det inte borde.

  • Medlem
  • 2009-04-18 15:36

Ha, ja det verkar funka, ska göra en testrun på deras hemsida också!

  • Medlem
  • 2009-04-21 15:34

Hm, testomgången gick inte och tyvärr funkar det inte på skatteverkets hemsida heller...

Andra tips tas gärna emot!

  • Medlem
  • Överallt
  • 2009-04-21 15:45

Du har ju fått tips om att göra ändringar med Java-inställningar.app, har du gjort det?

  • Medlem
  • 2009-04-21 15:58

Jag har det. Men nu har det precis funkat när jag körde Safari istället, då plötsligt fanns Java på plats!

1
Bevaka tråden