Hur bli av med Self Assigned IP?

Tråden skapades och har fått 17 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Stockholm
  • 2009-03-18 15:51

På jobbet, när jag drar ut nätverksladden och ska köra trådlöst får min MBP för sig att den ska ha "Self Assigned IP Adress" på 196.254.xxx.xxx.

Jag har följt alla tips som jag hittat i andra trådar här på forumet:

1. Renew DHCP-licens, ingeet blir nytt, så klart.
2. Kolla Macens firewall, den är satt till "Allow all incoming connections" (lite läskigt bara det) Har togglat lite fram och tillbaka men ingen nytta
3. Nyttja Cocktail till att tömma chache. Blev inte bättre...
4. Kolla med IT-ansvarig på jobbet (som normalt inte ger Mac-support tyvärr, jag är lite av en hermelin bland windows-katterna). Min dator syns inte i DHCP-servern, så det är inte den som ger mig samma IP hela tiden...

Överallt annars funkar datorn på trådlöst, så det känns som om det inte är datorn egentligen, utan jag hade hoppats på IT-supportens hjälp, men tyvärr.

Vad är nästa steg? Hilfe är ni snälla.

  • Medlem
  • Stockholm
  • 2009-03-18 16:09

Hmmm... Om jag tömmer cachen med Cocktail får jag en ny Self Assigned IP varje gång... Hur ska jag tolka det...

/Seb

Jag tror att när du drar ut sladden så letar Macen efter en DHCP-server på det trådlösa nätverket. När den inte hittar någon så får du en "dummy-IP". När du hamnar inom något öppet trådlöst nätverk uppdateras inte IP-adressen automatiskt då?

Jag använder flera olika "nätverksplatser" i min MBP. PÅ jobbet där jag kör med kabel har jag helt enkelt tagit bort möjligheten till trådlöst nätverk. När jag kommer annorstädes byter jag helt enkelt till en annan "plats" där WiFi kör igång automatiskt. På det sättet slipper datorn leta efter något som inte finns.

Nätverksplatser kan enkelt administreras under "Nätverk" i systeminställningarna.

  • Medlem
  • Stockholm
  • 2009-03-18 17:11

Hmmm, du menar att om jag använder "Locations"?
Men om jag skapar en ny Location, så får jag bara en annan self assigned ip.

  • Medlem
  • Stockholm
  • 2009-03-18 18:20

En möjlig orsak är att den fortfarande letar efter DHCP-servern över ethernet-gränssnittet.

Vad händer om du startar om utan nätverkssladden i? Vad händer om du inaktiverar ethernet i nätverksinställningar?

Jag har haft liknande problem (eller ja.. typ) på SJs X2000-tåg, men det beror på att deras nätmask är otroligt dumt gjord. VPN på X2000 = trubbel.

Hur som helst.. prova att öppna terminalen och skriva

netstat -r

för att rensa routingtabellerna. Är du inte administratör skriver du sudo netstat -r följt av lösenord.

Inte helt säker på om det hjälper, men det kan vara värt ett försök iaf.

Ett enkelt sätt att bli av med en egentilldelad IP-adress är att tilldela sig själv en ny manuellt. DHCP är inte mer magiskt än att det ger din dator en IP-konfiguration och det gör ingen praktisk skillnad om du gör det själv.

  • Medlem
  • Stockholm
  • 2009-03-18 19:47

Tack för alla tips! Ska kolla i morgon igen när jag är i grottekvarnen!

Thnx!

  • Medlem
  • Stockholm
  • 2009-03-18 22:37
Ursprungligen av Marcus K:

Ett enkelt sätt att bli av med en egentilldelad IP-adress är att tilldela sig själv en ny manuellt. DHCP är inte mer magiskt än att det ger din dator en IP-konfiguration och det gör ingen praktisk skillnad om du gör det själv.

Ja, men om du ställer in en statisk ip-adress som ligger i dhcp-serverns range så kan det bli krockar när dhcp:n försöker dela ut din adress till någon annan, och då blir garanterat inte it-avdelningen glad.

  • Medlem
  • Stockholm
  • 2009-03-19 13:31

Inget ovan funkar tyvärr...

1. Netstat -r ger ingen skillnad, men -r flaggan verkar inte rensa routingtabeller utan bara visa?

man netstat

     -r    Show the routing tables.  Use with -a to show protocol-cloned routes.  When -s is
           also present, show routing statistics instead.  When -l is also present, netstat
           assumes more columns are there and the maximum transmission unit (``mtu'') are
           also displayed.

2. Starta om utan ethernetkabeln i eller stänga av ethernet gör ingen skilnad. På verkar inte tcp/ip för airport alls.

3. Företagets IT-avdelning har inte tagit bort DHCP eller stängt för okända MAC-adresser heller...

4. Jag tror, om jag minns rätt att jag har försökt lösa detta problemet genom att ge mig själv ett eget IP, så det är kanske det som är problemet? Att DHCP-serven nu har delat ut det ip-t till någon annan? fast varför skulle jag då få nya "self assigned IP's" hela tiden?

Tacksam för mer hjälp.

/Seb

  • Medlem
  • International user
  • 2009-03-18 19:48

Det är nog företagets IT som antingen har stängt av DHCP eller släpper bara in kända MAC adresser på nätet. I vilket fall som helst så kommer du inte in på nätet utan hjälp från företagets IT.

//Rob

Senast redigerat 2009-03-18 23:28
  • Medlem
  • Sollentuna
  • 2009-03-19 13:35

Kan vi få en skärmdump på din inställning för AirPort > Advanced > TCP/IP? Och du är säker på att du är ansluten till rätt företagsnätverk? Jag tänker på möjligheten att det finns andra inom räckvidden.

  • Medlem
  • Stockholm
  • 2009-03-20 09:28

Skärmdump...

Här kommer den:

Det roliga är att igår fulade jag mig och satte en egen manuell IP som jag visste skulle fungera på jobbet, men tänkte inte på att det då var svårt att koppla upp mig när jag kom hem sen

MEN: Nu är min fråga, jag fattar inte riktigt hur System Preferences egentligen fungerar, och i vilken ordning jag ska göra saker för att mina ändringar ska slå igenom:

Hemma igår så kom jag förstås inte ut på nätet, jag hade ju den manuella IP som jag satt på jobbet.
Ok, jag öppnade System Preferences - Network - Airport - advanced - TCP/IP.
Väl där väljer jag "Using DHCP" i Configure IPv4.
MEN när jag då trycker Eenew DHCP Lease så hoppar Configure IPv4 tillbaka till "Using DHCP with manual adress".

Så det verkar som jag måste välja "Using DHCP" i Configure IPv4, trycka OK för att komma tillbaka till förra fönstret, kunna välja APPLY, och sen gå tillbaka till advanced TCP/IP för att då trycka på Renew Dhcp Lease... Då hämtar den korrekt adress.
Hemma alltså, det funkar fortfarande inte på jobbet...

Är det designat att fungera så? Känns så inte Apple att ge användaren möjlighet att sabba för sig själv innan ändringarna slår igenom...

  • Medlem
  • Sollentuna
  • 2009-03-20 15:00

Tja, det säger ju inte så mycket än att du inte fick något svar från DHCP-servern. Att din IT-avdelning inte ser din dator i DHCP-servern skvallrar väl om att du inte kommer in på det trådlösa nätverket i någon mening. Det vore ju intressant och se i loggarna på DHCP-servern om din MAC-adress från ditt trådlösa nätverkskort finns i loggen. Likadant i själv utrustningen för det trådlösa nätverket. Jag tror inte att vi kommer så mycket längre än så just nu på den punkten.

Angående betendet i Systeminställningar så kan jag bekräfta det. Men om det är rätt eller fel måste jag fundera på vad jag tycker. Troligen lutar jag ändå åt att man ska få trycka Renew utan att gå via Apply.

  • Medlem
  • Stockholm
  • 2009-03-20 16:59

Ok, tar helt enkelt tag i IT igen och frågar varför de inte ser min macadress i DHCP-loggen. Min Iphone dyker ju upp utan probs... Strange.

Tack för hjälpen

/Seb

  • Medlem
  • Stockholm
  • 2009-03-24 09:38

Ok, ett steg till närmare lösningen;

Vårt kontor sträcker sig över flera våningar. Jag startade upp datorn på översta våningen, och där får jag en korrekt IP-adress. Ingen skillnad på de andra kontorsplanen. Det verkar som om de olika routrarna på de olika våningarna har lite olika inställningar. Kanske en cachad MAC-adress? Tips tas tacksamt emot.

  • Medlem
  • Sollentuna
  • 2009-03-24 09:53

OM du kan påvisa att det är platsberoende på ditt företag var du lyckas med att få en IP-adress torde det ju vara ganska enkelt för din IT-grupp att lösa problemet. Anledningen till att det ser underligt ut är att alla basstationer heter samma sak, men just nu hittar jag inte var man enkelt ser MAC-adressen för den basstation som man är ansluten mot.

  • Medlem
  • Stockholm
  • 2009-03-25 13:56

Japp, det är platsberoende

Min kollega googlade på

macbook airport not getting dhcp address

där ser man att det inte är ett ovanligt problem...

Vi letar vidare

  • Medlem
  • Stockholm
  • 2009-09-03 14:52

Problemet lever vidare, testade denna lösning, men det funkade inte.

Nu har även min Iphone slutat få korrekta Ip addresser, och får egenassignade... Jisses...

1
Bevaka tråden