Instabilt 10.5.6 efter iTunes-uppdatering (?)

Tråden skapades och har fått 14 svar. Det senaste inlägget skrevs .
1

Uppdaterade till iTunes 8.1 och senaste Front Row i går och efter detta (gissar jag) uppför sig datorn underligt. Efter 10-15 min användning Funkar inte tangentbordet och jag kan inte klicka med musen (dock röra markören). Startar om och reparerar behörigheter med skivverktyg.

Får en lång radda behörighetsfel, som alla slutar enligt nedan:

2009-03-15 23:47:11 +0100: Fel behörigheter på ”System/Library/CoreServices/Front Row.app/Contents/CodeResources”,ska vara -rw-r--r-- , de är lrw-r--r-- .

Men får också flera Varningar för SUID-filer enligt nedan

2009-03-15 23:47:52 +0100: Varning: SUID-fil ”System/Library/Filesystems/AppleShare/afpLoad” har ändrats och kommer inte att repareras.
2009-03-15 23:47:53 +0100: Varning: SUID-fil ”usr/bin/setregion” har ändrats och kommer inte att repareras.
2009-03-15 23:47:55 +0100: Fel behörigheter på ”System/Library/CoreServices/RawCamera.bundle/Contents/CodeResources”, ska vara -rw-r--r-- , de är lrw-r--r-- .
2009-03-15 23:47:56 +0100: Varning: SUID-fil ”System/Library/PrivateFrameworks

Flera omstarter och reparationer ger samma meddelanden. Vad skall jag göra?

Angående den sista delen av din fråga:
Om du hade sökt lite innan du startade tråden (en sökning på "SUID" t.ex), så hade du sett att det finns massor av trådar om det. Det är inget nytt. Och det är helt ofarligt.

De andra frågorna överlåter jag till någon annan.

  • Medlem
  • Stockholm
  • 2009-03-16 12:17

1. Starta från Leopard installationsskiva och kör Reparera skiva.
2. Tag hem och installera Mac OS X 10.5.6 Combo Update http://support.apple.com/downloads/Mac_OS_X_10_5_6_Combo_Update
3. Om detta inte hjälper installera om Leopard med Arkive inställningen som behåller din användare och alla inställningar och filer, men bygger ett nytt system och lägger ditt gamla i en separat mapp.

Ursprungligen av Joel:

1. Starta från Leopard installationsskiva och kör Reparera skiva.
2. Tag hem och installera Mac OS X 10.5.6 Combo Update http://support.apple.com/downloads/Mac_OS_X_10_5_6_Combo_Update
3. Om detta inte hjälper installera om Leopard med Arkive inställningen som behåller din användare och alla inställningar och filer, men bygger ett nytt system och lägger ditt gamla i en separat mapp.

Jag kan och har reparerat via Skivverktyg. Är det någon skillnad på reparationsprogrammet på installationsskivan?

Det konstiga är att samma fel kvarstår hela tiden, trots att jag reparerar flera gånger.

10.5.6 kör jag redan.

Ursprungligen av Tomas Svedgård:

Jag kan och har reparerat via Skivverktyg.

Du måste skilja på att "Reparera skiva" och "Reparera skivbehörigheter".

Det du har kört är förmodligen "Reparera skivbehörigheter".

"Reparera skiva" kan man inte göra på samma volym som man har bootat från, utan måste göras från en annan volym, t.ex en installations-DVD.

Frågan är vad det står i loggen vid tiden då datorn ”låser” sig...
Vad är det för dator du har?

Ursprungligen av star-affinity:

Frågan är vad det står i loggen vid tiden då datorn ”låser” sig...
Vad är det för dator du har?

iMac 24" alu, köpt förra sommaren. Har försökt kopiera och klistra in från loggen, men nu hänger den sig allt snabbare. Ett par gånger har jag också fått ett felmeddelande vid omstart och jag har också skickat vidare till Apple. Problemet är som sagt att jag inte har hunnit klippa och klistra in här. Minns dock att ordet Kernel fanns med i rapporten till Apple.

En annan sak jag lagt märke till nu i kväll är att Spotlight börjat indexera hårddisken nån minut efter varje omstart. Sen funkar datorn några minuter, varefter tangentbord- samt musklicksfunktionerna försvinner.

Har nu också kört hårdvarutest (utökat) vid uppstart och inte hittat några fel. Skulle även testa att reparera disken, från installationsskivan vid uppstart, MEN jag får inte ens upp skivan vid uppstart; den läser och läser men slutar sen och skärmen fortsätter vara gråvit.

Loggmeddelandet efter omstart, efter den har hängt sig, enligt nedan.

Tue Mar 17 06:16:27 2009
panic(cpu 1 caller 0x00405DEB): "NVRM: Read Error: GPU 0, PCI 0x00000100, BAR0 0xa2000000 0x44a7b000"@/SourceCache/xnu/xnu-1228.9.59/iokit/Kernel/IOLib.cpp:724
Backtrace (CPU 1), Frame : Return Address (4 potential args on stack)
0x28d22cc8 : 0x12b4f3 (0x45b13c 0x28d22cfc 0x1335e4 0x0)
0x28d22d18 : 0x405deb (0x49da40 0xe25280 0x28d22d5c 0x28d22d4c)
0x28d22d38 : 0xbf64f7 (0xe25280 0xe25280 0xde9c88 0x0)
0x28d22d78 : 0xeadd1a (0x4971004 0x50ca004 0x9410 0xe44960)
0x28d22db8 : 0xed8738 (0x50ca004 0x9410 0x1fdc8000 0x9)
0x28d22df8 : 0xcf7ddb (0x50ca004 0x45e5004 0x0 0x0)
0x28d22e18 : 0xc381fe (0x45e5004 0x28d22e8c 0x0 0x0)
0x28d22e58 : 0xe49f6e (0x50ca004 0x3d0900 0x28d22e8c 0x0)
0x28d22eb8 : 0xe7f015 (0x50ca004 0x5141804 0x0 0x1)
0x28d23058 : 0xe833d2 (0x50ca004 0x513ea04 0x4a4d684 0x0)
0x28d231b8 : 0xc42088 (0x50ca004 0x513ea04 0x0 0x5845704)
0x28d23268 : 0xc0386e (0xc1d00040 0xbeef0003 0xcafe0259 0x5845d80)
0x28d232d8 : 0xbf474b (0x28d23468 0x6 0x0 0x0)
0x28d23438 : 0xbe62b4 (0x0 0x600d600d 0x7057 0x28d23468)
0x28d234f8 : 0x10e951b (0xc1d00040 0xbeef0003 0xcafe0259 0x5845d80)
0x28d23578 : 0x10e97f3 (0x244d8000 0x5845d80 0x5833a04 0x0)
Backtrace continues...
Kernel loadable modules in backtrace (with dependencies):
com.apple.GeForce(5.3.6)@0x1096000->0x112dfff
dependency: com.apple.NVDAResman(5.3.6)@0xbdd000
dependency: com.apple.iokit.IONDRVSupport(1.7.1)@0xbcf000
dependency: com.apple.iokit.IOPCIFamily(2.5)@0x5c6000
dependency: com.apple.iokit.IOGraphicsFamily(1.7.1)@0xb80000
com.apple.nvidia.nv50hal(5.3.6)@0xe3a000->0x108efff
dependency: com.apple.NVDAResman(5.3.6)@0xbdd000
com.apple.NVDAResman(5.3.6)@0xbdd000->0xe39fff
dependency: com.apple.iokit.IONDRVSupport(1.7.1)@0xbcf000
dependency: com.apple.iokit.IOPCIFamily(2.5)@0x5c6000
dependency: com.apple.iokit.IOGraphicsFamily(1.7.1)@0xb80000

BSD process name corresponding to current thread: WindowServer

Mac OS version:
9G55

Kernel version:
Darwin Kernel Version 9.6.0: Mon Nov 24 17:37:00 PST 2008; root:xnu-1228.9.59~1/RELEASE_I386
System model name: iMac8,1 (Mac-F227BEC8)

Hmm... verkar vara något med grafikkortet och/eller drivrutinen till det.
Går datorn stabilare om du håller ned shift-tangenten under uppstarten (tar en stund att starta i detta läget) och sen kör datorn ett tag (du ska komma till inloggningsfönstret och det ska stå ”säker start” med röd text ovanför användarna). En hel del prylar som inte ”läses in” i detta läge, men testa att köra lite och se om det är stabilare. Bara starta om ”som vanligt” (utan shift nere) när du vill återgå.

  • Medlem
  • White Beach, Puerto Galera
  • 2009-03-17 14:23
Ursprungligen av star-affinity:

Hmm... verkar vara något med grafikkortet och/eller drivrutinen till det.
Går datorn stabilare om du håller ned shift-tangenten under uppstarten (tar en stund att starta i detta läget) och sen kör datorn ett tag (du ska komma till inloggningsfönstret och det ska stå ”säker start” med röd text ovanför användarna). En hel del prylar som inte ”läses in” i detta läge, men testa att köra lite och se om det är stabilare. Bara starta om ”som vanligt” (utan shift nere) när du vill återgå.

Mina fläktar varvade på 2300-2500 på min MBP utan att något var igång på den (förutom Finder då). Testade att göra en säker start, loggade in på mitt konto där allt hackade och gick trögt. Startade om på normalt vis och nu ligger fläktarna på 1800 varv. Kalas ju. Vad är det som händer med systemet efter säker start egenligen? Tack för tippset.

Ursprungligen av onnyt:

Vad är det som händer med systemet efter säker start egenligen?

Det står på Apples hemsida:

http://support.apple.com/kb/HT1564

Ursprungligen av star-affinity:

Hmm... verkar vara något med grafikkortet och/eller drivrutinen till det.
Går datorn stabilare om du håller ned shift-tangenten under uppstarten (tar en stund att starta i detta läget) och sen kör datorn ett tag (du ska komma till inloggningsfönstret och det ska stå ”säker start” med röd text ovanför användarna). En hel del prylar som inte ”läses in” i detta läge, men testa att köra lite och se om det är stabilare. Bara starta om ”som vanligt” (utan shift nere) när du vill återgå.

Tack! Gjort så och datorn har tuffat på nu i ca tre timmar. Det mesta funkar om än bitvis lite segare. Vad indikerar detta, att felet ligger i mjukvaran och inte i t ex grafikkortet? Inga hårdvarutest har visat några fel heller.

Nästa åtgärd, är det bara ominstallation som gäller? Isf, skall det vara någon fara med "Arkivera och Installera" eller att återinstallera från Timemachine (har en färsk backup från både före och efter krånglet)? Finns det risk för att felaktiga inställningar följer med?

  • Medlem
  • Stockholm
  • 2009-03-18 12:19

Jag har bara goda erfarenheter av "Arkivera och Installera", det brukar lösa alla problem, men du måste som sagt köra "reparera skiva" först.
Gör så här.
1. Sätt i installationsskivan.
2. Slå av datorn och vänta någon minut så att minnet är helt tomt.
3. Slå på datorn och håll ner alt-knappen och välj sedan att starta i från installationsskivan.
4. Efter bootning från installationsskivan välj Skivverktyg i menyraden. Kör reparera skiva. (Om du fortfarande har problem med att starta från installationsskivan tvätta den med ett milt diskmedel). Avsluta Skivverktyg.
5. Kör "Arkivera och installera".
6. Kör programuppdatering flera gånger tills det inte finns några uppdateringar kvar.
Lycka till!

Ursprungligen av Joel:

Jag har bara goda erfarenheter av "Arkivera och Installera", det brukar lösa alla problem, men du måste som sagt köra "reparera skiva" först.
Gör så här.
1. Sätt i installationsskivan.
2. Slå av datorn och vänta någon minut så att minnet är helt tomt.
3. Slå på datorn och håll ner alt-knappen och välj sedan att starta i från installationsskivan.
4. Efter bootning från installationsskivan välj Skivverktyg i menyraden. Kör reparera skiva. (Om du fortfarande har problem med att starta från installationsskivan tvätta den med ett milt diskmedel). Avsluta Skivverktyg.
5. Kör "Arkivera och installera".
6. Kör programuppdatering flera gånger tills det inte finns några uppdateringar kvar.
Lycka till!

Nu gjort exakt så, men det funkade inte alls. Efter uppdatering startade datorn; jag konstaterade att det var 10.5.2 och skulle precis börja uppdatera när den hängde sig grovt. Försökte starta i felsäkert läge, men inte ens det gick. Nu har jag lämnat den med strömmen av och gör ett nytt försök med felsäkert senare ikväll.

1
Bevaka tråden