Skrivare och AirPort vägrar fungera (samsung scx4300 och extreme/express)

Tråden skapades och har fått 10 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Stockholm
  • 2009-02-21 13:19

I min enfald trodde jag att en modern samsungskrivare borde fungera trådlöst, men icke, så jag tänkte se om någon kan komma med lite tips.

Den fungerar självklart när den är inkopplad till datorn, med drivrutinerna som kom med.
Både extremen och expressen hittar den när man går in under airport-verktyg.

När man däremot ska skriva ut via nätverkat säger den att 'skrivaren är frånkopplad just nu'.

Så, tips, ideer, någonting! Allt som kan leda till att man slipper sladden till datorn mottages tacksamt..

  • Medlem
  • Sollentuna
  • 2009-02-21 14:08
Ursprungligen av MagnusG:

I min enfald trodde jag att en modern samsungskrivare borde fungera trådlöst, men icke, så jag tänkte se om någon kan komma med lite tips.

Den fungerar självklart när den är inkopplad till datorn, med drivrutinerna som kom med.

Menar du att det fungerar med USB och/eller Ethernet?

Ursprungligen av MagnusG:

Både extremen och expressen hittar den när man går in under airport-verktyg.

Ahaa, det är en USB-only-skrivare. Då menar du att den syns som en USB-skrivare på AirPorten.

Ursprungligen av MagnusG:

När man däremot ska skriva ut via nätverkat säger den att 'skrivaren är frånkopplad just nu'.

Vad händer om du kollar status på skrivakön via Print & Fax i System Preferences?

  • Medlem
  • Stockholm
  • 2009-02-21 14:33
Ursprungligen av frazze:

Menar du att det fungerar med USB och/eller Ethernet?Ahaa, det är en USB-only-skrivare. Då menar du att den syns som en USB-skrivare på AirPorten.

Precis, USB-only. Dessvärre billigaste möjliga för de små behoven.

Ursprungligen av frazze:

Vad händer om du kollar status på skrivakön via Print & Fax i System Preferences?

'Skrivaren redo' tills något ska skrivas ut, då ändras det till 'Skrivaren är frånkopplad just nu' efter att snabbt ha blinkat till med ett 'printing 1.7%..'. Tas dokumentet bort från kön återgår den direkt till det första, att den är redo.

  • Medlem
  • Sollentuna
  • 2009-02-21 21:17

Då skulle nog en vända i Console ge oss lite mer kött på benen. Kolla under cups och error_log och berätta.

  • Medlem
  • Stockholm
  • 2009-02-22 12:09
Ursprungligen av frazze:

Då skulle nog en vända i Console ge oss lite mer kött på benen. Kolla under cups och error_log och berätta.

Ojoj, det var nog lite mycket för en söndagsmorgon, du tror inte att du kan guida mig i hur jag får fram den informationen via terminalen? Jag har inte precis vuxit upp med macen om man säger det så.

  • Medlem
  • Sollentuna
  • 2009-02-22 19:43

Det finns ett program i Utilities som heter Console (du klarar säkert av att hitta var det blir i ett svenskt OS X). Det visar en rad olika logfiler, däribland CUPS (Common Unix Printing System, www.cups.org). Titta i entryt error_log - bifoga gärna innehållet i denna tråd.

Ursprungligen av MagnusG:

I min enfald trodde jag att en modern samsungskrivare borde fungera trådlöst, men icke, så jag tänkte se om någon kan komma med lite tips.

Den fungerar självklart när den är inkopplad till datorn, med drivrutinerna som kom med.
Både extremen och expressen hittar den när man går in under airport-verktyg.

När man däremot ska skriva ut via nätverkat säger den att 'skrivaren är frånkopplad just nu'.

Så, tips, ideer, någonting! Allt som kan leda till att man slipper sladden till datorn mottages tacksamt..

Det där problemet har jag också med min Samsung. Inte hittat någon lösning, men finner någon en sådan i denna tråden är jag tacksam.

  • Medlem
  • Stockholm
  • 2009-02-22 20:40

Det som dök upp vid försök till utskrift

2009-02-22 20.37.58 TextEdit[203] InkChecker tool data: * * * error: usbDeviceRequest - ssUsbInit failed
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dt...">
<plist version="1.0">
<dict>
<key>prtMarkerSuppliesTable</key>
<array>
<dict>
<key>prtMarkerSRGBRepresentation</key>
<array>
<integer>0</integer>
<integer>0</integer>
<integer>0</integer>
</array>
<key>prtMarkerSuppliesClass</key>
<integer>3</integer>
<key>prtMarkerSuppliesDescription</key>
<string>Print Black Color Cartridge</string>
<key>prtMarkerSuppliesLevel</key>
<integer>143</integer>
<key>prtMarkerSuppliesMaxCapacity</key>
<integer>100</integer>
<key>prtMarkerSuppliesSupplyUnit</key>
<integer>7</integer>
<key>prtMarkerSuppliesType</key>
<integer>3</integer>
</dict>
</array>
</dict>
</plist>

2009-02-22 20.38.40 TextEdit[203] InkChecker inkCheckFinished could not decode XML: XML parser error:
Unexpected character * at line 1
Old-style plist parser error:
Unexpected character '0x2a' at line 1

2009-02-22 20.38.40 TextEdit[203] InkChecker tool data: * * * error: usbDeviceRequest - ssUsbInit failed
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dt...">
<plist version="1.0">
<dict>
<key>prtMarkerSuppliesTable</key>
<array>
<dict>
<key>prtMarkerSRGBRepresentation</key>
<array>
<integer>0</integer>
<integer>0</integer>
<integer>0</integer>
</array>
<key>prtMarkerSuppliesClass</key>
<integer>3</integer>
<key>prtMarkerSuppliesDescription</key>
<string>Print Black Color Cartridge</string>
<key>prtMarkerSuppliesLevel</key>
<integer>143</integer>
<key>prtMarkerSuppliesMaxCapacity</key>
<integer>100</integer>
<key>prtMarkerSuppliesSupplyUnit</key>
<integer>7</integer>
<key>prtMarkerSuppliesType</key>
<integer>3</integer>
</dict>
</array>
</dict>
</plist>

Jag hade liknande problem med en Canon iP4500 skrivare, som bara fungerade om den var inkopplad direkt till min Macbook Pro.

Lösningen var att hämta hem de färskaste drivrutinerna till skrivaren. Dessvärre så fanns på Canons svenska sida bara drivrutiner från juni 2008, 10.1.0.0, vilka INTE fungerar.
Men via Canon USA fanns drivrutin från augusti 2008, 10.1.2.0 vilka fungerar som de ska.

(Jag vet inte hur det är med andra fabrikat, men för Canon gäller att USB-kabeln till skrivaren måste vara urkopplad när drivrutinen installeras. Annars vill det sig inte.)

Lycka till,

Nils

  • Medlem
  • Sollentuna
  • 2009-02-27 07:48

Det verkar ju som om drivrutinen misslyckas med att kolla (bläck)status på skrivaren. Så som Nils D tipsar om är att kolla om det finns en nyare drivrutin. I vissa fall finns det kanske krav på att inte ha den ansluten då man installerar drivrutinen, vilket verkar lite underligt.

  • Medlem
  • Stockholm
  • 2009-02-28 14:31

Icke, laddade ner de senaste drivrutinerna, installerade utan att ha den inkopplad. Men icke. Nu ger den däremot ett felmeddelande efter första sidan vid första utskriften när den är inkopplad med sladd
..tror nog att jag återgår till de ursprungliga drivisarna och skriver ut med sladden i tills vidare.

Kommer någon på någonting nytt som jag kan pröva så vore det såklart underbart! Tack för hjälpen sålänge.

1
Bevaka tråden