Är min MacBook Pro (unibody) feloptimerad?

Tråden skapades och har fått 27 svar. Det senaste inlägget skrevs .
1

Har en ny MBP, antagligen första 'leveransen' om det nu har hunnit komma nya, förbättrade mjuk-/hårdvaru-uppdaterade. Bytte från en MacBook, 2.0 C2D (nyare med 800MHz FSB) med 2GB ram och en 160GB 5400 hårddisk, samt den senare grafiken. En rejäl uppdatering med MBP tänkte jag, visserligen grundutförande med 2.4/2/250, men ändå. Efter några månader har jag börjat tröttna, den har snarare sinkat mig än hjälpt mig jobba snabbare...

Körde Photoshop CS3 på MB'n, började med det på MBP'n, men har även testat CS4 i 30 dagar då det ska dra nytta av grafikkortet på MBP'n. Det är framförallt här datorn sinkar mig, men det finns även en rad andra problem;

- Systemet (10.5.6) känns väldigt mycket segare än på MB'n, där spotlight är det bästa exemplet. Det går för långsamt helt enkelt.
- Finder beter sig konstigt och öppnar fönster i storlekar större än skärmen.
- Program tar lång tid att starta.
- Det virtuella minnet är mycket större enligt aktivitetshanteraren än vad jag minns det som på MB'n, trots identiska förutsättningar.
- RAM-minnet fylls upp till max väldigt snabbt, gärna av Adium, Itunes, Safari och något mer program, vilket det aldrig gjort tidigare.
- Har flera gånger försökt köra XP/Vista med Bootcamp, men partitionen har aldrig hittas när jag försökt installera.
- Jag måste hålla inne alt vid uppstart annars hänger sig datorn helt.
- Uppstarts-"chimen" låter bara ungefär varannan gång jag startar datorn.
- Vid Photoshopjobb kan det ta 15 sekunder för datorn att måla upp histogram för 'curves' på en 12MP stor bildfil som nyss öppnats. Pinsamt långsamt.

Överlag är det som att datorn använder en fjärdedel av sin kapacitet. Jag har installerat om hela OS X mha dvd'n flera gånger, tagit bort allt onödigt, tömt hårddisken, osv. Jag trodde först hårddisken hade för lite ledigt utrymme, men inte ens med ca 100GB ledigt jobbade datorn felfritt. Konstigt, med tanke på att MB'n mestadels hade 30GB ledigt av 160.

Så, jag undrar helt enkelt vad jag gör för fel. Är OS X "feloptimerat", använder jag den fel, eller är den helt enkelt trasig?

  • Medlem
  • Umeå
  • 2009-02-04 00:53

Datorn låter inte riktigt frisk - är alla firmware updateringar osv applicerade. Enat så kan det handla om någon mjukvara som strular och får datorn att inte gå friskt alternativt så kan det ju förstås vara någon hårdvaru problem - har du testat att köra hårdvaru test på burken ?

Det snabba hårdvarutestet gav inga felsvar. Har alla uppdateringar installerade, inkl den stora EFI-chip-omprogrammeringen eller vad det nu var.

Ingen som har någon aning?

  • Medlem
  • Umeå
  • 2009-02-04 14:20

Kör alla underhålls script i onyx (http://www.titanium.free.fr/pgs2/english/onyx_leopard.html) eller någon annan system underhålls program. Om datorn inte blir snabbare av det. Testa att skapa en ny användare och logga in som den och kör photoshop och se om programmet känns lika hängigt.

När du flyttade från MB till MBPn använde du överförings assistenten? - ibland kan inställningar strula med den

Skapat en ny användare för att kolla om det går lika fort/långsamt med den? Om inte är der nog inställningsproblem hos huvudanvändarkontot.

Hårdvarutest och ny användare, inget fungerar. Den är bara S E G som sirap i minusgrader. Med några öppna (inte så krävande?) program sätter den sig på tvären... Och varför kan jag inte byta fönster i något program med "cmd+>" som innan med Leopard?

Edit: Kan tillägga att oavsett grafikkort är problemen samma och något jag märkt det senaste är att vid bläddring i Safari fladdrar både bilder och text, bilder försvinner och kommer tillbaka först när man stannar scrollningen. Detta sker oavsett om ramminnet är fullt eller om det finns plats.

Jag blir galen på denna dyrgrip som presterar som min P4-Laptop från 2002.

Senast redigerat 2009-02-07 19:19

Kanske dags att skicka in den på felsökning?

Vill ju inte betala mer än 18500.-... Vad kostar det om de nu inte hittar något fel på den och vad bör jag göra då? Vill helst lösa problemet på enklast sätt. Vill inte vara utan den i två veckor heller...

  • Medlem
  • Stockholm
  • 2009-02-07 22:51
Ursprungligen av Alexander_222:

- Uppstarts-"chimen" låter bara ungefär varannan gång jag startar datorn.

Om jag inte minns fel så SKA det ljudet låda VARJE gång, annars har datorn inte klarat någon form av grundläggande hårdvarutest (jämför POST, power on self-test, på "vanliga" PC-datorer med BIOS). Med andra ord är något fel i din hårdvara och om det varit så sedan du köpte datorn så borde det vara garanti på det.

http://en.wikipedia.org/wiki/Power-on_self-test#Macintosh_POST

Senast redigerat 2009-02-07 23:17

Ny dator som det är något fel på = lämna in på felsökning/reparation. Det kostar inget...

  • Medlem
  • Stockholm
  • 2009-02-09 16:02

Har du testat att blåsa systemet helt och hållet? Alltså göra en ny och fräsh installation av OS X. Inte arkivera och installera eller nåt nedsmutsat med flyttassistenten, utan formatera disken och göra en grundinstallation av systemet.

Självklart ska du ju göra en backup först.

Ursprungligen av Solid:

Har du testat att blåsa systemet helt och hållet? Alltså göra en ny och fräsh installation av OS X. Inte arkivera och installera eller nåt nedsmutsat med flyttassistenten, utan formatera disken och göra en grundinstallation av systemet.

Självklart ska du ju göra en backup först.

Ungefär 3 gånger... Har plockat loss en 80GB hårddisk jag ska pröva att installera OS X på snart. Får se hur det går. Upptäckte en sak nyligen; när Transmission eller liknande program startas ser jag i aktivitetshanteraren hur RAM-minnesdiagrammet snabbt blir helt blått, upptaget. Stannar med ca 10MB ledig plats och då går allt lååångsamt.

Datorn är givetvis seg som sjutton även utan Transmission igång, men att det programmet äter RAM är det första beviset jag sett på att något är fel.

Ursprungligen av Alexander_222:

Ungefär 3 gånger... Har plockat loss en 80GB hårddisk jag ska pröva att installera OS X på snart. Får se hur det går. Upptäckte en sak nyligen; när Transmission eller liknande program startas ser jag i aktivitetshanteraren hur RAM-minnesdiagrammet snabbt blir helt blått, upptaget. Stannar med ca 10MB ledig plats och då går allt lååångsamt.

Datorn är givetvis seg som sjutton även utan Transmission igång, men att det programmet äter RAM är det första beviset jag sett på att något är fel.

Transmission äter inte bara RAM utan även hårddiskprestanda vilket slöar ned datorn....

  • Avstängd
  • International user
  • 2009-02-09 18:27

Nu har du klagat i en vecka. Lämna in datorn eller ring till Apple. Du har ju garanti på den så det skall ju inte kosta dig något. Gör det NU!

  • Medlem
  • Stockholm
  • 2009-02-10 20:31

Lämna in den.

Det tråkiga(-ste?) i detta är att datorn fått en på utsidan synlig stöt, eller buckla snarare, och frågan är om Apple kommer hänvisa alla problem till detta för att slippa stå för reparationer. Jag kan ju inte påvisa att problemen funnits från början, vilket de gjort. Det är därför jag drar mig för att lämna in den... T.ex. har skärmen flyttat sig i sitt fäste ca 1 mm vilket syns enbart vid gångjärnet på baksidan. Så problemen jag har med skärmen, att det blöder lila främst i nederkant kommer de garanterat hänvisa till min klumpighet också. Eller?

Har inte systemkameran med mig, men skadan är som på bilden.

  • Medlem
  • Nacka
  • 2009-02-11 16:34

Det skulle kunna vara problem med minnet, men det brukar inte göra datorn så seg, utan istället ge kernel panics eller pip vid start. Alltså oanvändbar.

Ursprungligen av smurf:

Vilka minnen har du i? Andra än Apples egna originalminnen? Om så är fallet, skall du nog prova att sätta tillbaka originalminnena. Nya MBP är hyperkänslig på vilka minnen man sätter i den.

Hur menar du nu? Huvudsaken är ju att det är minnestyp SO-DIMM DDR3 1066MHz 240-pin, sen om det är minnen från Samsung, Hynix, Kingston eller till och med ICE spelar ju ingen roll. Är minnet trasigt så är det trasigt, datorn däremot skiter ju fullständigt i vem som tillverkat minnet...

Ursprungligen av Alexander_222:

Det tråkiga(-ste?) i detta är att datorn fått en på utsidan synlig stöt, eller buckla snarare, och frågan är om Apple kommer hänvisa alla problem till detta för att slippa stå för reparationer. Jag kan ju inte påvisa att problemen funnits från början, vilket de gjort. Det är därför jag drar mig för att lämna in den... T.ex. har skärmen flyttat sig i sitt fäste ca 1 mm vilket syns enbart vid gångjärnet på baksidan. Så problemen jag har med skärmen, att det blöder lila främst i nederkant kommer de garanterat hänvisa till min klumpighet också. Eller?

Har inte systemkameran med mig, men skadan är som på bilden.

I och med att du har en buckla på datorn så skulle jag ju tippa på att det är hårddisken som är trasig, det kan göra datorn långsam. Om felet finns kvar om du startar om på annan disk med annat system så är det ju något annat.
Att den "blöder lila", hur menar du då? Har du som streck på skärmen, eller är det mer som att skärmen är knäckt? Lägg upp en bild!

EDIT: Bara en tanke, har du använt flyttassistenten från den gamla datorn till den nya?

Senast redigerat 2009-02-11 16:53
  • Medlem
  • Sundsvall
  • 2009-02-11 23:44
Ursprungligen av nllub:

Det skulle kunna vara problem med minnet, men det brukar inte göra datorn så seg, utan istället ge kernel panics eller pip vid start. Alltså oanvändbar.

Hur menar du nu? Huvudsaken är ju att det är minnestyp SO-DIMM DDR3 1066MHz 240-pin, sen om det är minnen från Samsung, Hynix, Kingston eller till och med ICE spelar ju ingen roll. Är minnet trasigt så är det trasigt, datorn däremot skiter ju fullständigt i vem som tillverkat minnet...

Där har du fel, nya MacBook (Pro) är mycket känslig på vilket minne du stoppar in i den.
Om du vill vara säker på att den skall fungera klanderfritt är det stort sätt bara Apples egna minnen som räcker.

Gamla MBP var inte alls så känslig på minnena.

Ursprungligen av smurf:

Där har du fel, nya MacBook (Pro) är mycket känslig på vilket minne du stoppar in i den.
Om du vill vara säker på att den skall fungera klanderfritt är det stort sätt bara Apples egna minnen som räcker.

Gamla MBP var inte alls så känslig på minnena.

Va? Upp med länkar som bekräftar vad du säger.

Ursprungligen av Gilbert 2:

Va? Upp med länkar som bekräftar vad du säger.

De har åtminstone varit problem med 3djepartsminne tidigare under hösten 2008, men jag tror att det gällde ful-minne. Inte Corsair, Kingston etc. Läs här: http://www.tuaw.com/2008/12/07/aluminum-macbooks-unstable-after-3rd-party-ram-upgrade/

  • Avstängd
  • International user
  • 2009-02-12 09:19
Ursprungligen av smurf:

Om du vill vara säker på att den skall fungera klanderfritt är det stort sätt bara Apples egna minnen som räcker.a.

Tyvärr. Apple tillverkar inga egna minnen. De köper från Samsung, Kingston osv.

  • Medlem
  • Nacka
  • 2009-02-12 10:08
Ursprungligen av smurf:

Där har du fel, nya MacBook (Pro) är mycket känslig på vilket minne du stoppar in i den.
Om du vill vara säker på att den skall fungera klanderfritt är det stort sätt bara Apples egna minnen som räcker.

Gamla MBP var inte alls så känslig på minnena.

Haha nej jag har inte fel. I datorerna sitter det minnen från Samsung, Hynix eller Nanya.. Det är ju inte Apple som tillverkar dom. Sen fungerar det utan problem med Kingston eller Corsair om man nu vill ha lite mer budget.
Det som däremot inte fungerar så bra är ju riktigt dåliga budget minnen, t ex. Ice och One, men dom har aldrig varit bra, inte ens till dom gamla datorerna. Men det beror ju inte på datorn, det beror på att minnena tillverkas och hanteras dåligt.
Jag köper inte att datorn känner av vilka minnen som sitter i. Då skulle dom ju sätta en spärr i datorn och inget annat än Applemärkta minnen skulle fungera, men nu är det ju inte så! Korten är inte ens märkta av Apple.
Att minnen som är av dålig kvalité inte fungerar är ju inget nytt.

Ursprungligen av smurf:

Men, om han har problem, och vet att han kör med 3dje parts minnen, så bör han försöka att sätta i originalminnena, och se om problemet kvarstår.

Minnen som fungerar bra är bl.a. Kingston och Crucial, fast det har varit problemer med dessa också. Så dom enda minnene vi kan garantera att fungerar klanderfritt, är dom som tillhandahålls av Apple själva, och då är det likgiltig vilka minnen det är, men dom fungerar.

Vi rekommenderar våra kunder som vill ha mer minne i sina maskiner, att beställa det direkt från fabrik, då vet vi att maskinen kommer att fungera som den skall.

Det är ju dumt att rekommendera något sådant om man vill tjäna pengar och ge snabb service. Vi säljer enbart minnen från Samsung. Garanterat bra grejer. Ett minne av 1000 är dåligt..

Ursprungligen av Alexander_222:

Det tråkiga(-ste?) i detta är att datorn fått en på utsidan synlig stöt, eller buckla snarare, och frågan är om Apple kommer hänvisa alla problem till detta för att slippa stå för reparationer. Jag kan ju inte påvisa att problemen funnits från början, vilket de gjort. Det är därför jag drar mig för att lämna in den... T.ex. har skärmen flyttat sig i sitt fäste ca 1 mm vilket syns enbart vid gångjärnet på baksidan. Så problemen jag har med skärmen, att det blöder lila främst i nederkant kommer de garanterat hänvisa till min klumpighet också. Eller?

Har inte systemkameran med mig, men skadan är som på bilden.

Jag instämmer i kören: ring Apple eller lämna in den direkt tillen auktoriserad reparatör och be om tips/eventuella prisförslag. Det går absolut snabbast.

  • Medlem
  • Sundsvall
  • 2009-02-11 14:12

Vilka minnen har du i? Andra än Apples egna originalminnen? Om så är fallet, skall du nog prova att sätta tillbaka originalminnena. Nya MBP är hyperkänslig på vilka minnen man sätter i den.

  • Medlem
  • Sundsvall
  • 2009-02-12 09:54

Men, om han har problem, och vet att han kör med 3dje parts minnen, så bör han försöka att sätta i originalminnena, och se om problemet kvarstår.

Minnen som fungerar bra är bl.a. Kingston och Crucial, fast det har varit problemer med dessa också. Så dom enda minnene vi kan garantera att fungerar klanderfritt, är dom som tillhandahålls av Apple själva, och då är det likgiltig vilka minnen det är, men dom fungerar.

Vi rekommenderar våra kunder som vill ha mer minne i sina maskiner, att beställa det direkt från fabrik, då vet vi att maskinen kommer att fungera som den skall.

  • Avstängd
  • International user
  • 2009-02-12 10:23
Ursprungligen av smurf:

Men, om han har problem, och vet att han kör med 3dje parts minnen, så bör han försöka att sätta i originalminnena, och se om problemet kvarstår.

Minnen som fungerar bra är bl.a. Kingston och Crucial, fast det har varit problemer med dessa också. Så dom enda minnene vi kan garantera att fungerar klanderfritt, är dom som tillhandahålls av Apple själva, och då är det likgiltig vilka minnen det är, men dom fungerar.

Vi rekommenderar våra kunder som vill ha mer minne i sina maskiner, att beställa det direkt från fabrik, då vet vi att maskinen kommer att fungera som den skall.

Jo men det är ju en helt annan sak. Om du som säljare rekomenderar dina kunder som inte har riktig koll att köpa "Apple minnen" utan att specifiera vad det är så kommer de fatta noll när de söker på nätet och inte hittar minnen från tillverkaren "Apple".

Men att göra en uppgradering av minnet i efterhand skall ju inte vara några problem, så läge man använder sig av bra minnen som inte är de absolut billigaste som man kan hitta och som inte kommer från någon obskyr tillverkare.

Rådet att sätta tillbaka originalminnena när det strular är dock ett väldigt bra råd.

För att klagöra -

- Det är orginalminnen i, 2x1GB DDR3.
- Jag har inte flyttat över något från min gamla MB med flyttassistenten.
- Jag har installerat om OS X mer än 5 gånger på olika sätt.
- Problemen verkar hårddiskrelaterade, men fanns redan innan datorn tappades.
- Det blöder bakbelysning längst ner i skärmens kant, inga digitala pixelfel, utan ett konstruktionsfel som gör att skärmen ser ut som en budget-BenQ från elgiganten. Har sett detta på något amerikanskt forum och verkar tillhöra första sändningen datorer.
- Jag har påbörjat en installation på min gamla orginaldisk på 80GB till MB'n, men jag fick avbryta installationen pga tidsbrist.

Får väl gå med den till Macforum i centrum här i Göteborg och se vad det kan kosta med en undersökning och om jag själv får stå för eventuell reparation.

  • Medlem
  • Nacka
  • 2009-02-12 20:59
Ursprungligen av Alexander_222:

För att klagöra -

- Det är orginalminnen i, 2x1GB DDR3.
- Jag har inte flyttat över något från min gamla MB med flyttassistenten.
- Jag har installerat om OS X mer än 5 gånger på olika sätt.
- Problemen verkar hårddiskrelaterade, men fanns redan innan datorn tappades.
- Det blöder bakbelysning längst ner i skärmens kant, inga digitala pixelfel, utan ett konstruktionsfel som gör att skärmen ser ut som en budget-BenQ från elgiganten. Har sett detta på något amerikanskt forum och verkar tillhöra första sändningen datorer.
- Jag har påbörjat en installation på min gamla orginaldisk på 80GB till MB'n, men jag fick avbryta installationen pga tidsbrist.

Får väl gå med den till Macforum i centrum här i Göteborg och se vad det kan kosta med en undersökning och om jag själv får stå för eventuell reparation.

Låter som en vettig idé. Kolla upp vad din försäkring täcker, för annars är ju inte en ny hårddisk så himla dyr. Om du installerar system på 80GB disken så kan du boota på det och köra ett blocktest i drive genius.

1
Bevaka tråden